7 Replies Latest reply on Jan 26, 2011 3:47 PM by ssprengel

    Zoom/resize not working consistently in ACR 6.3

    descender

      Hi, I'm on Windows 7 32-bit (switching to 64 soon and upgrading memory to 12 or more Gb but for now stuck with 4Gb), and have been using ACR 6.3.0.79 and PS 5 12.0.3.  Shooting raw in .PEF format with a Pentax K-5, 18Mb files.

       

      I'm having trouble with inconsistent behavior of the image zoom setting (in the lower left corner of ACR).  Sometimes, under some conditions, I get no results when I type Ctrl-plus or Ctrl-minus to zoom in or out.  Of course I would expect this if the program was busy computing a transformation or something, but it happens when my processor is unloaded and nothing has been done at all for a few seconds.  And I know my quad core system is definitely not busy at the time.

       

      Sometimes if the keyboard zoom shortcuts show no effect, I am still able to zoom in or out by right clicking in my image with the hand icon and selecting a different degree of zoom.  Sometimes I can get results by using the zoom select box in the lower left hand corner of ACR.  There's another peculiar thing which might help pinpoint a possible bug: usually if I'm having trouble with this, the mouse options for zooming *will* let me zoom the image smaller, but not larger.  Sometimes I get no result if I attempt to change zoom level from 100% to 66%, but i DO succeed if I try going directly from 100% to 50%.

       

      It gets worse -- just now, having freshly opened ACR/PS5 and Bridge (so I'm pretty sure I didn't have a bunch of old cache in memory or whatever) I was totally unable to alter the zoom of a raw image no matter what I tried.

       

      What's going on here?  I have a feeling my upgrade to 12Gb or more of RAM will avoid this, but it still should not be happening.  I want to emphasize the change in zoom level is not merely delayed... I can wait as long as I want and it does not eventually show results.  It's not as if the operation was carried out, only much slower due to virtual memory paging on the scratch disks or something (yes i do have scratch disks set up in PS, not SSDs or anything, just hard drives, but reasonably good ones).

       

      I searched for this topic already existing but may not have done such a good job.  It's difficult to do a successful search for "ACR" and "resize" or "zoom" and not get hits from nearly every thread in existence.

       

      Thanks in advance for any hints on what's going on or how to fix this.

      -- Eric

        • 1. Re: Zoom/resize not working consistently in ACR 6.3
          Fred K. Level 1

          Hi Eric,

           

          First....This thread is not 100% my stuff.

           

          But ..... you say nothing about preferences of PS .... in EDIT -menu ..... PREFERENCES .... PERFORMANCE..... >>>> memory usage ????

           

          Is that something to look at ?

           

           

          -Fred

          • 2. Re: Zoom/resize not working consistently in ACR 6.3
            Yammer Level 4

            In the past, I have found that some keyboard controls don't work until you've completed a settings change. For example, if you change something like Exposure, you'll notice that its value is highlighted. This highlight disappears when you press Enter. I've noticed that some zoom keyboard shotcuts will not work until these highlights are gone, so I get into the habit of pressing Enter after making an adjustment. It's second nature now, and I'd forgotten all about it, until I read this post.

            • 3. Re: Zoom/resize not working consistently in ACR 6.3
              Robert Shomler Level 4

              One possibility:  This type of problem sometimes can result from a graphics card driver.  What card?  Are you using the latest driver?

              • 4. Re: Zoom/resize not working consistently in ACR 6.3
                descender Level 1

                I'm running an ATI Radeon HD 4870 and my Catalyst drivers are up to date as of last week.

                 

                My PS prefs are set to give 50% of RAM for photoshop, and i've tried 60% and 70%.  Too much might not leave enough for ACR, too little would be bad too.


                If I cleanly boot and start up Bridge and PS and open a raw file into ACR, I can do anything.  But after working with it for a while (sometimes not very long, sometimes a good number of operations) there starts to be a lot of trouble with resizing.  When I first open everything I can be in the middle of an adjustment (this is a response to two posts above) and the keyboard zoom shortcuts work fine.  So i know it's not just the keyboard shortcuts.  Also, when the problem occurs later on (maybe with fuller memory buffers, i don't know) it's not just the shortcuts that don't work, sometimes I can't use the zoom tool or the zoom setting at the lower left corner properly either.

                 

                So I'm kind of suspecting memory leaks in the programming.  In any case I'm sure this will not be an issue when I go 64-bit and get enough RAM in a few days here.  But meanwhile it's a pain because it should work fine as long as I'm over the minimum system requirements, which I am with 4Gb.  If it runs out it should just use more hard drive... I would understand if it just took 30 seconds to re-zoom.  But that's not it; it's refusing to zoom at all when this problem occurs.  I can wait as long as I want and ACR does not honor the zoom command.

                 

                It's similar to the other issue I just posted, where ACR refuses to save my raw files to any format sometimes (even to the smallest size JPEG it offers, like a 1Mb file) but is perfectly willing to open them in Photoshop where I can save them instead.

                 

                Should I be making a bug report?

                • 5. Re: Zoom/resize not working consistently in ACR 6.3
                  descender Level 1

                  I corrected a problem as a result of a different memory-related message thread, and it looks like it probably solved this one too.

                   

                  I had an ACR cache folder set up on a drive with plenty of space, but I had forgotten to give it an actual cache size limit.  It was at the default 1.0Gb and that is far too small!  So I gave it 20Gb and everything seems to be working properly.

                   

                  Still sort of a bug ... if the program is going to be unable to honor the user's command to resize/zoom the display, it should really say so, rather than just become unresponsive.  But I understand that sometimes programming for speed optimization can be antagonistic to including every possible catch for stupid error conditions that the user should not have caused.

                   

                  Thanks for the ideas!

                  • 6. Re: Zoom/resize not working consistently in ACR 6.3
                    descender Level 1

                    Solved -- just needed to set a better cache size limit in preferences.  I had set up a cache folder with lots of room but I had neglected to tell PS/ACR to use more of that room.

                    • 7. Re: Zoom/resize not working consistently in ACR 6.3
                      ssprengel Adobe Community Professional & MVP

                      Will the problem return when the 20FB is full, where it is only working, now, because it's not full, yet, because you've just recently increased the limit, or is it already full and still working ok?