0 Replies Latest reply on Jan 29, 2011 1:39 PM by dgibas1

    Weird Flash Issue, All Symbols Empty after some type error and restart


      Last night I went to compile an application I was developing when all of a sudden I started getting an error with a callback function missing/not being seen. Nothing big, maybe I changed the name of the function on accident or accidently deleted the parent reference. So, I checked and everything was correct, but it would not compile.


      I commented out the callback and it compiled fine. I went back and uncommented and tried to compile again. It did, but only after giving me a new TLF text error. I had no text on the stage, just one font class imported into the library. Note, I had neither of these issues the last time I compiled the application - only 10 minutes before.


      So I saved my work and closed Flash to do a restart thinking that Flash was just acting up.


      When I reloaded the FLA, now about 1/2 of symbols were now empty on the stage. The imported psd files were still in the library, but they had been removed from the actual symbols. Crap.


      Well, thinking ahead I had a backup I had just recently made. So, I deleted the old FLA from the package and put a copy of the backup into the folder and opened it. When it opened, all of its symbols were empty as well but I had not TFL error.  It would compile and run, but 1/2 the symbols were missing. They were fine when I made the backup - in fact I checked the backup 30 minutes before because I had to send it to a client for review. The copy the client received worked fine. Note: Flash was still open when I moved the FLA, I had only closed the corrupt FLA before replacing it with the backup file and opened the backup through the open file menu.


      Long story short, I had to spend 5 hours rebuilding all of the empty symbols. After that the application worked and comiled fine.


      I called up a friend about the problem and she informed me that about 2 week prior she had the same exact thing happen to her, so this does not appear to be an isolated issue. What gives? Anyone else have this hapen with CS5?




      OSX 10.6.6

      Flash CS5  version