12 Replies Latest reply on Feb 4, 2011 1:34 PM by cspecter

    Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19

    cspecter Level 1

      We've been going around and around with our tech staff trying to solve this problem with no avail.  I first posted it here: http://forums.adobe.com/thread/780555?tstart=0 but wanted to make a new thread to see if anyone had a solution.

       

      Our company upgraded to CS5 earlier this month.  Everything went fine for a day or two until BG Renderer stopped working, new aerender instances would not start.  We thought that it had something to do with the script and a few other things, but finally came to the conclusion that it was related to multiprocssing.  If we turn on multiprocessing AE will hard crash.  If we try to launch a render using aerender form a command line (or via BG Renderer), the aerendercore instance never starts.  AE will render fine in single-threaded mode via the GUI.

       

      Deleting the prefs for AE will not rectify the problem.  The only way we can get multiprocessing to work is to create a new user on the machine.  AE will work fine (aerender, BG Renderer and multiprocessing), but after working on a couple projects it will break, usually after 4-5 launches).  We've tried deleting all sort of user prefs both Adobe and Apple with no luck.  Productivity has been radically reduced without the use of background renders.

       

      When trying to run aerender we get this error in the console:

       

      1/31/11 5:05:12 PM [0x0-0x20a20a].com.adobe.aerendercore[4740] After Effects can�t continue: sorry, After Effects has crashed. See http://www.adobe.com/support/products/aftereffects.html for known issues. If you still can�t resolve the issue, please contact Adobe Technical Support (2).

      1/31/11 5:05:12 PM com.apple.launchd[107] ([0x0-0x20a20a].com.adobe.aerendercore[4740]) Exited with exit code: 1

       

      I'm hoping someone out there will have had this problem and will have a solution.

       

      OS X 10.5.8

      AE 10.0.1.19

      8 Core Mac Pro

      10 GB Ram (Low I know)

        • 1. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
          cspecter Level 1

          A little more information.  We have tried a few more things.  If we take all the prefs in USER/Library/Preferences for an non-working user account and copy them over to a new user account, everything works.  If we then take all the prefs created (after running AE and making sure multiprocessing works) for a new user account and copy them over to an old user account where multiprocessing is not working then multiprocessing is still broken.  We've also tried in various combinations deleting everything in the USER/Library/Caches and USER/Library/Application Support with no luck. 

           

          We have 10 workstations in our company here (all basically the same hardware) and all have the exact same symptoms.  In a new user account everything will work for a day or two then multiprocessing breaks, never to work again.  If we just knew what file was getting corrupted that would be something, but whatever file or combination of files is getting corrupted is a mystery.

          • 2. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
            TimeRemapper Level 4

            What kind of users/accounts are experiencing this issue? Are they admins? Standards? Any parental controls enabled?

            • 3. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
              cspecter Level 1

              It doesn't matter what kind of user account.  Standard.  Admin.  They all exhibit the problem.  We don't have any parental controls on (since these are corporate computers).  AE must be messing up something in the Library folder, as once a user account is broken it stays broken. 

              • 4. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
                A. Cobb Level 3

                Are you using older versions of AE on these accounts as well?

                • 5. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
                  cspecter Level 1

                  Sure.  We have CS4 still installed, though I don't see why that should effect CS5.

                  • 6. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
                    A. Cobb Level 3

                    I'm trying to nail down commonalities between your setup and mine.  I've got a similar problem.  Enabling MP doesn't crash AE CS5, but the individual background processes do crash when they try to start up.  Setting up a new user account does allow me to use MP, and I haven't yet figured out how to break it.  This is all on Mac OS X 10.5.8.  Other machines here use Snow Leopard and seem to do MP just fine, but I don't think their users have been using MP with any regularity.  They are also on newer hardware and have more memory (12-core 24GB vs my 8-core 16GB).

                    • 7. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
                      cspecter Level 1

                      Yeah, we are running 8-core machines with 10GB, 10.5.8.  We haven't yet figured out what is breaking it in a new user account either.  Though at some point it will stop working.  We've done a test reinstalling AE back to the base-line 10.0 version and multiprocessing seems to be working in that version, but we are having some other problems with 10.0 that makes working on it untenable.  We don't really use multiprocessing in-app, since we've had a ton of problems with that, but we do use aerender and the BG Renderer script to render in the background which uses the same components as multiprocessing.  We'd upgrade to Snow Leopard, but we're a big cable broadcaster and we have to coordinate with out IT department before we can switch to a new OS (another frustrating aspect of the whole thing).

                      • 8. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
                        craulmedia Level 1

                        Hi, I'll link from here to my topic http://forums.adobe.com/thread/786393?tstart=0

                        because I believe that 10.0.1.x is buggy as hell!

                         

                        Thanks

                        • 9. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
                          cspecter Level 1

                          Agreed.  The real sad thing is no word from Adobe here.  Plus out IT staff has been totally stonewalled by Adobe customer support.  Basically just been given the standard "reinstall and restore" message.  Not helpful at all.

                          • 10. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
                            cspecter Level 1

                            Just to keep everyone updated.  We uninstalled CS5 and reinstalled back to the baseline 10.0 version.  If we delete all Adobe and Apple preferences in a user account, log out and log back in, load After Effects and multiprocessing will work.  But if you change some settings and close After Effects, then reload it, it no longer works.  We can do this reliably in new user accounts as well.  After Effects seems to be creating some corrupt preference file or combination of the, we just don't know which ones.

                            • 11. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
                              Dave LaRonde Level 6

                              You've simply said that multiprocessing won't work.  Perhaps it's set up improperly.

                               

                              Have you looked at the following recommendations for processor & memory allocations in AE 10:

                              http://blogs.adobe.com/toddkopriva/2010/10/please-try-recommended-memory-settings-for-afte r-effects-cs5-and-give-feedback.html

                              • 12. Re: Multiprocessing broken on CS5, OSX 10.5.8, AE 10.0.1.19
                                cspecter Level 1

                                I am pretty sure it is unrelated to any multiprocessing settings and is effected by something else that AE is doing.  We are not really using multiprocessing in-app, but we do use aerender for background rendering quite a bit.  What we've deduced is that both in-app multiprocessing and aerender launch a precess called aerendercore.  One for each processor used.  On the Mac this is program included inside the After Effects package (you can see it if you select "Show Package Contents" when right-clicking on the AE app).  When trying to invoke a render via the aerender command (aerender -project /someproject.aep) you can see this aerendercore process fail to launch by watching the log in Console (the error I posted before).  When we create a new user account (or delete all the prefs out of an existing account) we can get this process to launch, as notices in Activity Monitor.  But something is happening in either the process of closing AE and relaunching or changing settings in app that breaks this aerendercore component.  If we just knew what pref was getting corrupted, that would be something, we could delete it, but it's a little annoying to have to delete all your prefs and have to reset all your OS and AE settings just to get a background render up and running. 

                                 

                                We're at our wits end.  We've tried reinstalling the OS and AE with no luck.  Same symptoms.  If we didn't have to use it (because of project files we are receiving from vendors) we'd just go back to CS4, in which background rendering works fine, but that is not the case. 

                                 

                                The other weird thing is that in CS4 with multiprocessing off, when rendering you can see that AE is using more than one processor (usually between 4-5 by the Activity Monitor, a CPU score of 400-500).  WIth CS5 with multiprocessing off it always uses just one processor (a CPU score of under 100).  So maybe that is a related issue.