2 Replies Latest reply on Feb 4, 2011 7:39 AM by GilbertYu

    Few questions on Flex customization

    dankokozar Level 1

      Hi,

       

      I've just started to customize a LiveCycle instalation for the first time. I'm using Flash Builder, and Flex 3.4.1. - LCES2 as SDK.

       

      I have a few questions:

       

      1) The process of building (with Ant) is painfully slow. It lasts over a minute (1:03) to build and publish the ".ear" file (the CPU is Intel Core2 Quad CPU Q 6600 @ 2.40GHz).

      Does in have to be like that or am I doing something wrong here? Do I have to use "Cray" os something?

       

      2) As I see, the Workspace version we are using is built from the 'old' Halo components, and not Spark components.

      Is it because we have an old LC version? Can it be updated to a Flex 4 version? Can it work with the same server-side? Does a newer version exist?

       

      3) What we NEED to use (bottom line) is TLF (Flex Layout Framework). It depends on Flash Player 10. Can it be done with Flex 3.4.1.-LCES2?

        • 1. Re: Few questions on Flex customization
          GilbertYu Level 2

          1) The process of building (with Ant) is painfully slow. It lasts over a minute (1:03) to build and publish the ".ear" file (the CPU is Intel Core2 Quad CPU Q 6600 @ 2.40GHz).

          Does in have to be like that or am I doing something wrong here? Do I have to use "Cray" os something?

           

          One minute is about right. This is because ANT is packaging the compiled source into an WAR and EAR file. If you just want to work with the code and not deploy it, you can switch back and use the "Flex" builder. You will see some unresolved SWCs. Just resolve each error by point to the SWC file that is created undre the export folder for each of the api and foundation projects.  If you need more details, let me know.

           

          2) As I see, the Workspace version we are using is built from the 'old' Halo components, and not Spark components.

          Is it because we have an old LC version? Can it be updated to a Flex 4 version? Can it work with the same server-side? Does a newer version exist?

           

          No. You must use 3.4.1 from the LiveCycle ES2 DVD or the FLex SDK from the Workbench ES2 folder. 3.4.1 is the only version that has been tested and certificated with the release.

           

          3) What we NEED to use (bottom line) is TLF (Flex Layout Framework). It depends on Flash Player 10. Can it be done with Flex 3.4.1.-LCES2?

          Sorry, I'm not familiar with that but I can run Workspace using the latest version of Flash Player 10.2.  But if the TLF was introdced post Flex 3.4.1, then it probably won't work. Try checking the Flex forums for that answer. Again, apologies, I don't have an answer for this.

           

          Hope that helps!

          • 2. Re: Few questions on Flex customization
            Michael.Imhoff Level 1

            You can also use the -incremental compiler flag and exclude running the locale or theme swf's if that's not something your changing.  You should be able to compile the workspace source, build the ear, and deploy it to a server in about 20 seconds.

             

            Hope that helps,

            Michael