0 Replies Latest reply on Feb 2, 2011 11:47 PM by surrealsoftware

    FB 4 Premium licence not being recognised by automation library

    surrealsoftware

      Hi All,
          I've been tasked with setting up a continuous integration platform to build, release and perform automated testing of a Flex 4.1 application. To this end the entire process has been scripted and setup on a Mac OSX server.

       

      When setting up the automated tests I ran into the common issue of needing the FB 4 premium license. This has been purchased and integrated into the scripts successfully. When I run a build locally (Windows 7) and run the tests everything works fine. When running against the QA server the app reports that no license is available. When comparing the two swc files, the Mac version is approximately 1-2kb smaller (every run on either machines has a slightly different file size).

       

      Apart from different OS everything is identical. Same SDK version (4.1.0.16072), same version of ant, same config files, etc. I'm using the ant tasks for mxmlc.

       

      Can any please help me understand what may be different between the two environments that prevent the license from being included in the build?

       

      Many thanks in advance!