3 Replies Latest reply on Feb 8, 2011 12:06 AM by EileenPalsson

    Snippets can't be imported - "It is not a valid HTML file."

    EileenPalsson Level 1

      Hi, I'm trying to import copies of snippets from one RH 8.0.2 file to another. About 2/3 of the files are being import just fine, while the rest RH is refusing to import, since they are (accdg to RH) not valid HTML files.

       

      Since those HTS files were created and maintained in another RH8 project, it seems unlikedly that they aren't valid. However, I looked carefully at several of the problem files, and there is nothing wrong with them.

       

      Any ideas about what could be causing this?

       

      Thanks

      Eileen

        • 1. Re: Snippets can't be imported - "It is not a valid HTML file."
          RoboColum(n) Level 5

          Is there a pattern in the content of the snippets that won't import? For example are any special characters?

           


            The RoboColum(n)   @robocolumn   Colum McAndrew
          1 person found this helpful
          • 2. Re: Snippets can't be imported - "It is not a valid HTML file."
            Peter Grainge Adobe Community Professional (Moderator)

            It's a long shot but trying making a change to one that will not import and see if you can then import. I'm hoping that will correct whatever RoboHelp is whingeing about.

             


            See www.grainge.org for RoboHelp and Authoring tips

             

            @petergrainge

            • 3. Re: Snippets can't be imported - "It is not a valid HTML file."
              EileenPalsson Level 1

              Thank you for your replies! After awhile I figured out the common denominator in the snippets that could not be imported: The topics in which they were used had already been imported.

               

              So, if you are importing topics and snippets that used to be in a separate project, import the snippets first!

               

              (The really annoying part of this is that the error message was incorrect. The snippets were perfectly correct HTML files. That error message caused me to waste a lot of time scratching my head over what could possibly be wrong with the HTML code in those files. ARGH!)

               

              This is how I solved the problem (if I remember correctly -- it was a LONG day yesterday):

              1. Go through the motions of importing the snippets, ignoring the error messages.
              2. Close the project.
              3. Delete the CPD file.
              4. Open the project again. The snippets are in place, but they are not in RoboSource Control. (As a consequence, you get an error message if you try to edit such snippets.)
              5. Close the project again, and add them to RSC using RSC Explorer.

               

              Disclaimer: I haven't worked very much in this project since I fixed it as above. It's possible other erorrs could occur because of what I did. (I know that generally it's not recommended to add files to a project using RSC Explorer.) But I will post again and report any problems. In the meantime, you can assume that this is a valid workaround if you encounter the problem I did.

               

              Regards,

              Eileen