3 Replies Latest reply on Feb 9, 2011 8:10 AM by ForrestGimp

    3D-Toolbar shows up for Flash-RMA

    ForrestGimp Level 1

      I'm pretty sure I have posted this before, but it seems to have disappeared (?)...

       

      I have a BIG problem with ReaderX and Flash-RMAs. This is a serious bug in ReaderX! Whenever I have a Flash-RMA on a page other than the first in a pdf the 3D-toolbar pops up. It has NO USE WHATSOEVER for an annotation which contains no 3D content. Instead it just makes my layout look crappy, it makes my customers confused, and of course it makes me look like a bad developer.

       

      This is getting kind of ridiculous. The 3D-toolbar has been a source of neverending joy ever since Acrobat Version 9. In prior versions we could disable the bar for 3D-Annots using a checkbox in the annotations' properties. In 9 this checkbox is still there, but no matter how often you uncheck it, it always snapps back to being checked after closing and reopening the settings-dialogue. Apart from that, the checkbox had no function at all. The toolbar also used to show up now and then for pure Flash-RMAs in version 9, but usually it disappeared after clicking around in the Flash.

       

      While the functionality of the checkbox seemes to have been fixed for 3D-Annots in version X, the bar now shows up reliably for flash-annots on pages two and after. This applies to ReaderX and AcrobatX Pro. In a Flash-only-annotation there is obviously no checkbox to disable the 3D-Toolbar, as it shouldn't ever be there in the first place!

       

      So you see, this bug has a long, long history!

       

      This makes Flash unusable for professional pdfs!!!

        • 1. Re: 3D-Toolbar shows up for Flash-RMA
          Dave Merchant MVP & Adobe Community Professional

          We can't reproduce that issue here on Windows - I've tried several PDFs containing Flash Rich Media annotations on different pages and they all display correctly in Acrobat X Pro and Adobe Reader X (with no 3D toolbar), even if there's an active 3D annotation elsewhere on the same page.

           

          What platform are you using, how are you constructing your files; and in the Content browser on the navigation pane, what are the annotation subtypes? They should be "RichMedia".

          • 2. Re: 3D-Toolbar shows up for Flash-RMA
            ForrestGimp Level 1

            The acrobat-ninja himself is here to eliminate my problem. I feel honored.

             

            As for the information you requested:

            1. With my file I was able to reproduce it on three computers:

                 - my workstation (Fujitsu Celcius, xeon X5670 processor, 12 Gig RAM) running Windows 7 Professional (64-bit)

                  - an older PC we use for testing (Fujitsu Celcius, pentium 4 single  core at 3200 MHz, 2 Gig RAM) running Windows XP Professional (32-bit)

                 - an even older Office-PC (AMD Athlon 1,6 GHz, 1 Gig RAM)  running Windows XP Professional (32-bit)

             

            2.  The content-browser gives me RichMedia as classification, and I can  access the annotation using "getAnnotsRichMedia". This pretty much  confirms that it is indeed a genuine RMA.

             

            3. Construction procedure is as follows:

                 - I make the layout-templates for my PDFs using Ilustrator CS4

                 - the template is exported as a PDF

                 - I open the template-PDF in Acrobat 9 Pro Extended

                  - To get the scaling of my RMAs correct I make another template in  Illustrator, which has the same measurements as the swf which is going  to be my RMA

                 - I also open this template in Acrobat

                 - in this RMA-template I use the add-flash-tool to add my swf and its ressources

                 - I copy the RMA I have just created and paste it into my layout-template-PDF

                 - I place the RMA where I want it and save the PDF

                 - When I combine some of those pages into one PDF the trouble starts

             

            4. My RMAs

            The  problem is probably in the complexity of my swf-files. They contain  multiple AS-classes and load a lot of XMLs and various images... (Maybe  after all I AM a bad developer....)

             

            As the project I'm  working on is confidential, I tried to replicate the error using simple  swfs, but no luck so far. I keep on testing to find which part exactly  causes the problem. So far I have found out, that the toolbar is not  shown when I remove all XML-ressources from the RMAs. The XML-ressource  itself doesn't seem to be the problem, though. I tested it with a simple  swf, and had no problems.

            My swf-widgets are highly dependent on  XML for providing configuration settings and other data, so I suspect  removing the XML just cripples my swf in a way which prevents the  problem from happening. I will keep testing in that direction.

             

            If you permit me, I will send you a testfile per e-mail to reproduce the error. It will contain a part of the widget which is not too critical. Still I don't want it published in any form. I hope you understand that.

            • 3. Re: 3D-Toolbar shows up for Flash-RMA
              ForrestGimp Level 1

              Update:

               

              I have sort of tracked the bug down. I can now safely reproduce the error with a simple file. If required I can provide a test-file for general use, as I found that the problem has nothing to do with my project in itself.

               

              Steps to reproduce:

               

              1. create an swf (no matter what it contains -  for testing I used a simple square with a color-gradient)

              2. create a PDF "from empty page" (in the "file"- menue [this applies to Acrobat 9 pro extended])

              3. use the add flash-tool from the advanced editing panel to add your simple swf

              4. configure the annotation to "open when page is visible"

              5. save and duplicate the pdf several times

              6. open one pdf and go to the "page" section in the navigation-panel

              7. click on the little gears-icon and "add pages from file"

              8. add a few of the duplicate-pages you have created

              9. you can play around with the flash-RMAs a bit if you like, i.e. place more of them on one page etc.

              10. create a document-script using "Advanced/Document processing/document JavaScripts"

              11. add the following code to the document script:

              stirrUpToolbar();

              function stirrUpToolbar()
              {
                  for(var i=0; i<this.numPages; i++)
                  {
                      for each(var anAnnot in this.getAnnotsRichMedia(i))
                      {
                          anAnnot.activated = true;
                      }
                  }
              }

              12. Save and exit

              13. reopen in ReaderX and watch, how every RMA which isn't on the first page will have a nice, ugly and totally useless 3D-toolbar popping up on mouseover.

               

              Some sidenotes: I use ActionScript3 in my swfs, but in fact I found it doesn't matter whether there's any script at all in the RMA. It seems to me, that activating the RMA offscreen could probably cause this (mis)behaviour?