0 Replies Latest reply on Feb 10, 2011 1:37 AM by Parth Yadu

    faultCode = "Client.Error.MessageSend"     faultDetail = "Channel.Security.Error error Error #2048

    Parth Yadu

      Hi,

       

       

      while working with Flex-CF9 (with JRun4), I am getting Client.Error.MessageSend error. As well I gone thru some other threads on the same error and found that I need to use crossdomain.xml, but I am using every thing on local machine, Any ways I have also write crossdomain.xml file and the contents of the xml file are -

       

      <?xml version="1.0"?>
      <!DOCTYPE cross-domain-policy SYSTEM
      "http://www.adobe.com/xml/dtds/cross-domain-policy.dtd">
      <cross-domain-policy>
          <site-control permitted-cross-domain-policies="master-only"/>
          <allow-access-from domain="http://127.0.0.1"/>
          <allow-access-from domain="http://127.0.0.1"/>
          <allow-http-request-headers-from domain="http://127.0.0.1" headers="SOAPAction"/>
      </cross-domain-policy>

       

       

      and the error is -

       

      (mx.messaging.messages::ErrorMessage)#0


        body = (Object)#1


        clientId = (null)


        correlationId = "B08065F6-14BA-0578-B27F-0EE3418B02A0"


        destination = ""


        extendedData = (null)


        faultCode = "Client.Error.MessageSend"


        faultDetail = "Channel.Security.Error error Error #2048 url: 'http://stplt542/test'"


        faultString = "Send failed"


        headers = (Object)#2


        messageId = "2EA67159-67AD-F2FF-471E-0EE3420864DC"


        rootCause = (mx.messaging.events::ChannelFaultEvent)#3


          bubbles = false


          cancelable = false


          channel = (mx.messaging.channels::AMFChannel)#4


            authenticated = false


            channelSets = (Array)#5


              [0] (mx.messaging::ChannelSet)#6


                authenticated = false


                channelIds = (Array)#7


                  [0] (null)


                channels = (Array)#8


                  [0] (mx.messaging.channels::AMFChannel)#4


                clustered = false


                connected = false


                currentChannel = (mx.messaging.channels::AMFChannel)#4


                initialDestinationId = (null)


                messageAgents = (Array)#9


                  [0] (mx.rpc::AsyncRequest)#10


                    authenticated = false


                    autoConnect = true


                    channelSet = (mx.messaging::ChannelSet)#6


                    clientId = (null)


                    connected = false


                    defaultHeaders = (null)


                    destination = "forF"


                    id = "9C0E84DD-F31D-46F8-E738-0EE3367F754E"


                    reconnectAttempts = 0


                    reconnectInterval = 0


                    requestTimeout = -1


                    subtopic = ""


            connected = false.

       

       

       


      I am clue less now and have no idea what I should change now. please help!