4 Replies Latest reply on Feb 13, 2011 11:42 PM by FTQuest

    Possible bug in the latest SDK 4.5.0.19786

    FTQuest Level 3

      Hello there,

       

      There seems to be a bug in the latest build of the SDK.

      Here is a simple case of Parallel transition. It works fine in the Hero 4.5.0.17689, but if you compile it in 4.5.0.19786, you should see incorrect behavior.

       

       

      <?xml version="1.0" encoding="utf-8"?>

      <s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"

         xmlns:s="library://ns.adobe.com/flex/spark"

         xmlns:mx="library://ns.adobe.com/flex/mx"

         width="1200" height="800">

       

      <fx:Script>

      <![CDATA[

      private function toggleStates():void

      {

      if(currentState == 'normal')

      currentState = 'expanded';

      else

      currentState = 'normal';

      }

      ]]>

      </fx:Script>

       

      <s:states>

      <s:State name="normal" />

      <s:State name="expanded" />

      </s:states>

       

      <s:transitions>

      <s:Transition toState="expanded">

      <s:Parallel duration="1000">

      <s:Resize target="{panel}" />

      <s:Move target="{panel}" autoCenterTransform="true" />

      </s:Parallel>

      </s:Transition>

      <s:Transition toState="normal">

      <s:Parallel duration="1000">

      <s:Resize target="{panel}" />

      <s:Move target="{panel}" autoCenterTransform="true" />

      </s:Parallel>

      </s:Transition>

      </s:transitions>

       

      <s:Button label="Toggle States" click="toggleStates()" />

       

      <s:Rect id="panel" x.normal="200" y.normal="300" width.normal="600" height.normal="500"

      x.expanded="100" y.expanded="100" width.expanded="800" height.expanded="700" >

      <s:fill>

      <s:SolidColor color="0x000000" />

      </s:fill>

      </s:Rect>

       

      </s:Application>

       

      I attribute this problem to the latest SDK build because compiling this in Max prerelease SDK works fine in both versions of FP 10.1 and 10.2

      I'm on Mac 10.6.6

       

      Hope to get a reply,

      Igor Borodin