4 Replies Latest reply on Aug 14, 2012 12:35 AM by triadenfisch

    Adobe Reader X issues with DFS shares?

    ssway

      I recall that when Adobe Reader X was released there was a documented issue with opening files on DFS network shares (I confirmed this issue during my testing). Has this since been resolved or is it ongoing? Thanks.

        • 1. Re: Adobe Reader X issues with DFS shares?
          Ankit_Jain Adobe Employee

          Yes, the DFS issue has been fixed with the latest release of Adobe Reader X i.e. 10.0.1. You can download the same by doing a Help > Check for Updates from your Reader application.

           

          Ankit

          • 2. Re: Adobe Reader X issues with DFS shares?
            TimD_CSC

            I'm still experiencing issues with files on DFS shares. Even after  version 10.0.1 has been applied. It would seem my issue is not in  opening normal PDF files but in the fact that the PDF files have been  Archived, and have the Black Clock Symbol on them. If i disable the  Adobe Sandbox the files "un archive" and open perfectly but with the  sandbox  still enabled it fails with "Access Denied". I have even generated a  customised Whitelist as specified in the AcrobatApplicationSecurity.pdf  (with help of the broker log) and with help with this article http://forums.adobe.com/message/3519895#3519895. I must  add that if i use the DFS  link directly (\\server\share\xxxx\xxx\xx\filename.pdf) the PDF opens  fine even with the sandbox enabled and it being in the "Archived state"  but through a mapped drive to the DFS  share it won't open (z:\xxxx\xxx\xx\filename.pdf). Here is my last  broker log with "no errors seen anymore..." :

             

            [03:09/22:18:33] Adobe Reader Protected Mode Logging Initiated

            [03:09/22:18:33] Found custom policy file: C:\Program Files\Adobe\Reader\ProtectedModeWhitelistConfig.txt

            [03:09/22:18:33] Adding custom policy: FILES_ALLOW_ANY = \??\UNC\MYSERVER.NET\SVR\*

            [03:09/22:18:34] Adding custom policy: FILES_ALLOW_ANY = \??\UNC\MYSERVER2\SVR\*

            [03:09/22:18:34] Adding custom policy: FILES_ALLOW_ANY = \??\UNC\MYSERVER3\SVR\*

            [03:09/22:18:34] Adding custom policy: FILES_ALLOW_ANY = \??\C:\WINDOWS\system32\*

            [03:09/22:18:34] Adding custom policy: REG_ALLOW_ANY = HKEY_LOCAL_MACHINE\SOFTWARE\Adobe*

            [03:09/22:18:34] Adding custom policy: REG_ALLOW_ANY = HKEY_CURRENT_USER\Software\Adobe\Adobe Acrobat*

            [03:09/22:18:34]  Adding custom policy: REG_ALLOW_ANY =  HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet  Settings*

            [03:09/22:18:34] Adding custom policy: REG_ALLOW_ANY = HKEY_CURRENT_USER\Software\Microsoft\Direct3D\MostRecentApplication*

            [03:09/22:18:34] Adding custom policy: EVENTS_ALLOW_ANY = MSFT.VSA*

            [03:09/22:18:34] Adding custom policy: EVENTS_ALLOW_ANY = _fCanRegisterWithShellService*

             

            Any help would be deeply appreciated! Tim.

            • 3. Re: Adobe Reader X issues with DFS shares?
              MattReginald

              Tim,

               

              I am experiencing the exact same issue, with almost identical trouble shooting steps. Does it matter at all if you are testing with a local admin account versus an account with limited access? Any help from the community would be appreciated.

               

              ************Edit*****************5/16

               

              I ran the manual installation of 10.0.1 AdbeRdr1001_en_US.exe and I had success. I tried installing the patched version of 10.0.1 I deployed and opening a PDF from a DFS share did not work. I looked and there are a number of DLLs that still read 10.0.0.396, even though Reader is displaying a successful installation of 10.0.1. I ran across this article which seems to be what I am running into.

               

              http://forums.adobe.com/message/3648631?tstart=0

               

              ****************Edit*************5/17

               

              So after applying the patch again, going through the same process and confirming the msi reads as 10.0.1 I still find files with 10.0.0.396 listed. So the fix for my issue is deploy 10.0.1 but right now I can't see to fully patch 10.0.0.

               

              Ideas?

               

              -Matt

              • 4. Re: Adobe Reader X issues with DFS shares?
                triadenfisch Level 1

                We are experiencing the same problem here, when folders from one LUN are linked into folders on another LUN via NTFS mounting. The direct link works, when using a mapped drive it doesn't.

                 

                I tried it with Adobe Reader 10.0.0 with successive patches to 10.1.3 and also with the full version of 10.1.3. It hade the same effect, so patching with MSP-files cannot be the (only) problem.

                 

                I also tried the whitelist, which didn't work as well, but this may be because I didn't do it right.

                 

                I asked Adobe for help, but without a service contract (which we don't have) they cannot help.

                 

                Does anybody know what needs to be in the whitelist config to surpass the protected mode for files on specific servers, shares or network drives?