4 Replies Latest reply on Feb 23, 2011 3:01 AM by angiewho

    CF Builder on Windows 7 64 Bit, with Coldfusion 9 & Xampp

    angiewho

      Hi

       

      Just wondering if anyone has successfully installed and used CF Builder with Xampp on Windows 7?

       

      My issue is code assist and other editor profile options, as well as internal browser previewing doesn't work at all. I have also done the same on a Mac with CF 9, CF Builder and Xampp, same issue.

       

      I am just trying to use CF with an external web server (instead of the built in one) for development.

       

      Appreciate any constructive feedback.

       

      Thanks

        • 1. Re: CF Builder on Windows 7 64 Bit, with Coldfusion 9 & Xampp
          charlie@carehart.org Adobe Community Professional & MVP

          @Angie, I hope I can help some.

           

          First, though, I don't see how the configuration of server-side software like XAMPP (which, for those not familiar, installs PHP, MySQL, and Perl) would affect something like "code assist", "other editor profile options", and "internal browser previewing". You say you had the "same issue" on a Mac. I would think there must be some other common denominator (like how you're setting things up within CFB) that would be the explanation. Really, even these things aren't related to each other (code assist, internal browsing), so that seems another reason to ignore XAMPP as being somehow the "cause".

           

          So as for "code assist", what you are you finding doesn't work? Are you saying tag attributes don't pop up when you type a CFML tag? If so, are you sure you've opened the CFML file with the CFML editor? Is there a CF logo on the tab at the top of the editor window (which names the file you've opened)?

           

          Or do you mean, perhaps, that when you use something like CFQUERY and choose the DATASOURCE attribute, you don't get a list of datasources as defined on your server? Or that when you use CFOBJECT/CFINVOKE to name a CFC, you don't see a list of CFCs? Those two kinds of things rely instead on proper configuration of CFB to connect your project to your server (and also, you do have to have opened the file as a project, not from the file system, for such features to work).

           

          So have you configured your project to connect to a server? And if you look at the Servers view, do you see that server listed? And does it show running? You could also have a server defined, but misconfigured. Is the server your local machine, or a remote one? See the CFBuilder docs for extended discussions of proper configuration of a Server setup for CFB.

           

          Related to that will be the URL to be used to browse files. When you say the internal browser is not working, is it that when you click the browser button at the bottom of the screen (or use ctrl-tab), it goes to the browser but the page doesn't load? It could just be that you have the wrong URL for the files you're trying to browse. Again, the docs can help you see the places where you can configure the URL (whether for the server, the project, or even for a directory).

           

          Finally, you mention "I am just trying to use CF with an external web server (instead of the built in one) for development." Well, again, that doesn't really connect directly to what you say above. All those settings above don't care whether you use the internal or external web server (Apache, in your case). But it does mean that you have to get all the settings write to point to your CF deployment, via that web server, in all those settings where a URL is to be entered (which includes also the RDS settings, if using features related to that).

           

          So I realize you may be seeing all this and saying, "I just want it to work. I didn't think it would be this complicated, let alone that I would have to read a dissertation on setting it up". Sadly, it's just that there are a lot of moving parts to CFB. Some depend on your server configuration (within CFB), some depend on proper URL configuration (in those places). Some are still more complicated when the server is remote to you (where you then have to configure "JNDI ports and username/passwords). These are all documented, so it just takes some time to properly read about, understand, and configure them.

           

          If someone really just needs it "up and running" without understanding, there are folks (like myself) who can help guide you through the process on consulting basis. I don't say all this above to sell that service. Not at all. I have given you (and all readers here) insight into what you can do on your own to find and resolve the problems. Or obviously you can reply here with more questions, and I and/or others will try to help. I'm just offering another option for those pressed for time.

           

          /charlie arehart

          charlie@carehart.org

          Providing on-demand troubleshooting services for CF and CFBuilder

          at http://www.carehart.org/consulting

          1 person found this helpful
          • 2. Re: CF Builder on Windows 7 64 Bit, with Coldfusion 9 & Xampp
            angiewho Level 1

            Thank you Charlie for your prompt and detailed response.

             

            Firstly, I have followed video tutorials closely in setting up CF Builder inthe Mac and the Windows computer.

             

            In both cases, I did not use the internal built in CF server but apache in xampp, and  the web root resides in the xammp htdocs folder. The server is installed on my  local machine

            Coldfusion is up and running fine in both cases. I have configured the connectors in both cases as well. I am able to view any CF page that I place in the web root folder

             

            In CF Builder, I have set up the localhost servers (not remote) and I can see that it say running. I have also been to the Services Window to double check and yes its all running. I have set up Projects and CF pages in the xampp/htdocs folder.

            In both cases, I am only able to preview the pages by clicking the run button at the top of the panel, which then opens up the respective browser externally.

            When I click on the browser button at the bottom, nothing happens, it doesn't prompt me to save the page nor does it show anything at all in  the preview screen, as I said it only shows in the external browser. I did  notice that when setting up the server in the mac, it had the Internal Viewing option whereas in the windows, it didn't. I downloaded both from Adobe on the same day and I think they are the latest versions. However , in both cases, internal viewing doesn't work at all. I have been thru the setting and checked internal viewing option in Mac.

             

             

            As for code assist and coloring, I have been through all the settings in Editor and editor profiles and created custom profiles, but when I hit ctrl+space, the attributes don't pop up  e.g. when I type <cff and then hit the ctrl+space, it doesn't pop up.

            I have been thru the Keys options under Editor and I have the correct shortcut under Comment Assist .

             

            The only reason I am thinking its got something to do with the server is because the video tutorials I am following use the built in web server in CF.

            In my case in CF builder, I have configured the local server (localhost) to install extensions etc in the web root (xampp/htdocs)

            I am wondering if this is correct.

             

            I hope this clarifies things a little more.

             

            Thanks

            • 3. Re: CF Builder on Windows 7 64 Bit, with Coldfusion 9 & Xampp
              charlie@carehart.org Adobe Community Professional & MVP

              Angie, sorry for the delay in responding (and that no one else jumped in with thoughts). I have a couple of clarifications, and then some specific suggestions.

               

              First let me clarify that there's absolutely nothing special about connecting CFBuilder to a CF Server using CF's built-in web server versus using an external web server (IIS, Apache, etc.) I suspect the reason you see the docs and videos using them is that then the writer didn't need to detail things for each external web server. It's too bad if that may leave the impression that there's something special, or if in fact it may mean there would be some differences (like the web server port) that someone would have to be able to understand.

               

              But to your point, if there's anything where your tests "work with the built-in server" but "fail with an external web server", then I'd say it's really got to be down to configuration, either in CFBuilder or in that external web server (and how it's connected to CF).

               

              Also, though this may not be your issue, I want to offer it just in case, and in case it may help others finding this thread in the future. You say that "When I click on the browser button at the bottom, nothing happens, it doesn't prompt me to save the page nor does it show anything at all in the preview screen, as I said it only shows in the external browser." Just to be clear, if you mouse of the white space of the internal browser "not showing anything at all", can you confirm that you don't see the icon indicating that CFB is waiting for a response? That could be what happens. I see this behavior if I try to browse a page whose URL is setup to connect to a server that is not yet started. After several seconds, I then see "Server Error: Either the Macromedia application server(s) are unreachable or none of them has a mapping to process this request". I realize that may not be your specific problem, but it's worth confirming that if you wait, you don’t see some error.

               

              But then you say that when you click the run button, it does open in an external server, so that would again seem to suggest that the URL is a good one.

               

              So let's focus instead on this issue of not being able to browse internally. I don't know if it will be a Mac issue. Maybe, maybe not. But with respect to the internal browsing feature in CFB, there are two places with settings related to that that you should explore.

               

              One is in the project properties, in the section, "HTML Preview". I'm not on a mac, but I assume you'd see the same. There are multiple settings, including specific listing of the internal browsers that are enabled or not. There is also a setting at the top to "override workspace settings". For me, that's not checked, and after that the settings show that the project document root is "/", the "preview type" options are all grayed out, the sample URL is blank, and IE and Firefox are listed and checked. What about for you?

               

              The second place is in preferences>html>editors>html>preview. (This page is in fact what's linked to if one clicks the link on that prior page for "edit workspace settings"). That too has multiple settings that may be affecting you. Check them out.

               

              Finally, you say that "when I hit ctrlspace, the attributes don't pop up  e.g. when I type <cff and then hit the ctrlspace, it doesn't pop up." So here you mean not attributes but instead the list of tags starting with CFF, right? That should work, though. If it doesn't, then I would wonder if perhaps (even related to the other problem above) you may instead have a problem where the "cfml editor" is not what you've opened the file with.

               

              Looking at the tab that appears at the top of the code display, where it shows the filename you've opened, do you see a little white <> icon to the left of the filename? If not, then you're not using the CFML editor. That should, of course, open by default. But things can get out of whack for any number of reasons (some in your control, some perhaps unexpectedly).

               

              Here's a test: in the project navigator on the left (and to be clear, you are opening this file as part of a project, right? Not in the File view?), right-click on the file and choose "open with". Do you see "CFML Editor"? Open it with that, and see if any of your problems show a different behavior.

               

              Let us know what you find.

               

              Hope that helps.

               

              /charlie

              1 person found this helpful
              • 4. Re: CF Builder on Windows 7 64 Bit, with Coldfusion 9 & Xampp
                angiewho Level 1

                Thanks again Charlie.

                 

                I read through your email, and I remember doing everything you suggested and also I was indeed using the editor.

                I have been thru most of the settings in CF Builder in both the Mac and windows computer.

                 

                Finally, I decided to unistall CF server and reinstall with the built in web-server and then reinstall CF Builder. And voila! Everything worked like a charm. I just had to turn on code assist and it worked straight after that. As for previewing in te internal browser

                 

                I intend to redo this again with an external webserver, but I kinda needed it up and running for now.

                If I do find a solution to this, I will def post it here.