0 Replies Latest reply on Feb 19, 2011 5:08 PM by Angela's ARIA

    SWFAddress Not Working For Root Directory Application

    Angela's ARIA

      Hello,

       

      I am having some problems implementing SWFAddress on my main application.  The problem seems to be because my application resides in the root directory.  The application's URLs work fine when navigating the applicaiton, but when a SEO friendly URL is used, the SEO content is loaded correctly but the Flex application does not load the correct page as the URL does not change to use the SWFAddress format including the #.

       

      I have two similar instances of the application live at the moment.  The application at http://www.accessiblerichinternetapplication.com/ has the problem described above while a second instance of a VERY similar application that is hosted at http://www.accessiblerichinternetapplication.com/angelasaria-seo-swfaddress/ works perfectly fine.

       

      The only difference between these two applications is the location and the .htaccess.
      The application in the root directory has a .htaccess file of:
         
          <IfModule mod_rewrite.c>

       

          # Enables mod_rewrite
          RewriteEngine on

       

          RewriteCond %{HTTP_HOST} ^accessiblerichinternetapplication.com [NC]
          RewriteRule ^(.*)$ http://www.accessiblerichinternetapplication.com/$1 [L,R=301]

       

          RewriteBase  /

       

          RewriteCond  %{REQUEST_FILENAME}    !-f
          RewriteCond  %{REQUEST_FILENAME}    !-d
          RewriteRule  .*                     index.php

       

          </IfModule>

       

      The application in the /angelasaria-seo-swfaddress/ directory has a .htaccess file of:

       

          <IfModule mod_rewrite.c>

       

       

       

          # Enables mod_rewrite
          RewriteEngine on
         
          # Sets the base folder of the SEO sample
          RewriteBase  /angelasaria-seo-swfaddress
         
          RewriteCond  %{REQUEST_FILENAME}    !-f
          RewriteCond  %{REQUEST_FILENAME}    !-d
          RewriteRule  .*                     index.php
         
          </IfModule>

       

      Can you please help me by sheding some light on this problem as I have tried many things and cannot work out how to make this work in my root directory!!

       

      Many thanks in advance for any help you may be able to give me.

       

      Angela's ARIA