8 Replies Latest reply on Mar 10, 2011 2:05 PM by Nodgerelli

    Adobe Reader for Mac OS 10.4.11

    Nodgerelli

      I need to download a PDF off of my health insurance website (Anthem) and it is requiring that I have the latest version of Adobe Reader in order to do so.  I do not see a solution on here for how to get the latest Adobe Reader while running Mac OS 10.4.11 Intel.  What can I do?  Why won't it just let me download the form?  I don't even need to open it.  I just need to forward it to my dentist so I can get my medical insurance to pay for the teeth I broke in an accident.  Please help me.