5 Replies Latest reply on Feb 28, 2011 12:30 PM by johnstst

    RoboHelp 9 Closing while building AIR

    NRKinematics

      Hello,

       

      I've been pulling my hair out trying to fix this, and I'm getting dangerously close to switching to that other app that rhymes with Glare, so hopefully someone can save us.

       

      When we try to build the AIR version of our project, RoboHelp starts the build process, then just closes.  No error message, doesn't appear to be a crash...just exits.

       

      It worked fine in this same project a few hours ago.  Tried it again just now and no luck.

       

      This happened to me earlier on a different project and I started the project over, which fixed it again for awhile...until I encountered it yet again.

       

      I've put the entire project into a zip folder and uploaded it to ftp://ftp.kinematics.com/pub/SA/Install/SA%20Roadmap/Roadmap.zip.  Can someone help?

       

      Here's the output from the log right before it closes:

      log.png

       

      Using RoboHelp HTML (RH9) with Windows 7, 64-bit.

       

      Thanks,

      Todd

        • 1. Re: RoboHelp 9 Closing while building AIR
          NRKinematics Level 1

          Just a little additional information: Installed the RH9 trial on another computer, tried it out...had the same problem

          • 2. Re: RoboHelp 9 Closing while building AIR
            NRKinematics Level 1

            I found that checking "Exclude Unreferenced Baggage Files From Search" fixed the problem...although I don't know why.  Adobe: Is this a bug?

            • 3. Re: RoboHelp 9 Closing while building AIR
              Jeff_Coatsworth Adobe Community Professional & MVP

              Nope - don't think so. I'm building locally-installed AIRHelp for a current project and I don't bother with that flag at all. Nothing crashing on me. I'd say there's something in one of your baggage files that causing the Full Text indexing to go tilt. You could try removing each file one by one to see which one it chokes on & why, but it sounds as if you don't need them included in the search anyway.

              • 4. Re: RoboHelp 9 Closing while building AIR
                NRKinematics Level 1

                Jeff, thanks for the feedback.  I figured out what was happening and do believe it is a bug.

                 

                Since printing from AIR looks awful, we were generating individual PDFs for each chapter in our project, then including hyperlinks to those PDFs in our AIR project (via the file: type hyperlink).

                 

                Steps would be:

                 

                1) Create the Individual chapter PDFs.

                2) Create the AIR, which would link to the latest version of the PDFs.

                 

                This works fine initially (works like a charm in fact).  However, if I would update a topic and re-build the PDF files, that's what would introduce the problem.  After the PDF files were updated, building the AIR output caused RoboHelp to close.  The PDF files themselves did not change file names or directory locations--just the content of the PDF was updated.

                 

                This is a bug that should be fixed, since this is the only viable solution I've found to circumventing the terrible printing from AIR.

                • 5. Re: RoboHelp 9 Closing while building AIR
                  johnstst Level 1

                  I am experiencing this issue as well when modifying links to pdf files and have therefore not created a new thread. I am using a trial version of TCS 3.0 and am utilizing a project created in TCS version 2.0. Similar to the first post, this problem only manifested itself after updating the hyperlink reference to a pdf file. I have tried the suggestions to exclude unreferenced baggage files from search and have also set my project to clear cpd files before opening projects. In theory I have narrowed the issue to one specific pdf but here's the thing - I just made the exact same updates in the original TCS version 2.0 project and it publishes without any issue whatsoever. Let's just say I'm glad I haven't upgraded yet!

                   

                  Any thoughts?