8 Replies Latest reply on Oct 18, 2010 10:28 AM by Sue.Andrews

    unhandled win32 exception

    ehoran
      For some reason, I've been getting this strange error when I start RoboHTML, or when I try to generate my .chm file:
      "An unhandled win32 exception occurred in RoboHTML.exe [5044]." It then asks me if I want to debug using Visual Studio. When I click No, I'm dumped out of RoboHelp (I'm using version 6). Sometimes I can restart, and it will load my project, other times I'll get an error that my PBHELP.cpd file is corrupted and must be deleted. (PBHELP is the name of my project.) I delete the file, open the project again, and it seems to work. Does anyone know what could be causing this? The project was started with an old version of RoboHelp 2002, so I'm not sure if converting it into version 6 somehow messed something up.
      Now I'm not able to generate a .chm file at all, and with a release date coming next week, I'm anxious to solve this problem.

      Thank you!

      Erin
        • 1. Re: unhandled win32 exception
          Peter Grainge Adobe Community Professional (Moderator)
          Is your project on a local drive and are you generating to a local drive?

          Are you using a build expression when you generate? If you are, do you get the same problem if you generate without a build expression?

          • 2. Re: unhandled win32 exception
            ehoran Level 1
            Thanks for responding, Peter. Yes, my project is on a local drive and I publish it to that drive as well. I'm not quite sure what is meant by using a "build expression" (sorry I'm kind of new to all of this and learning as I go); however, I haven't changed any settings when I generate my .chm file.
            • 3. Re: unhandled win32 exception
              Peter Grainge Adobe Community Professional (Moderator)
              There is a build expression dropdown in the first page of the wizard. As you are not familiar with that term, it is unlikely to be set to anything other than None. There is a bug that involves build expressions in RH6. However it will not affect you if no build expression is involved, or you are using an earlier version.

              Not sure what to suggest. I am not familiar with the offer to debug using Visual Studio. Anyone else on that?

              Can you create a new project with a few topics and generate OK from that?

              Handing over to US support now as it's bedtime in the UK. Night all!

              • 4. Re: unhandled win32 exception
                Brian.Mccaffery Level 1
                If you go to the Control Panel and select Administrative Tools then event viewer and select application, is there an Error registered about the time the problem occurred? If there is, Right click on the error and select properties. If you can get any details from that, please copy and paste into your post.

                Having searched on Google, there are many applications that throw this exception measage, but no one solution.

                Also found a tech note relating to a similar problem, read it HERE . It may give food for thought.

                Brian
                • 5. Re: unhandled win32 exception
                  ehoran Level 1
                  I checked the event viewer, but don't have any errors there. I started to follow the fix on that tech note, but the link to the zip file is broken. Does tech support have another link to the kb401651.zip file? It's still been crashing on and off all day...
                  • 6. Re: unhandled win32 exception
                    Brian.Mccaffery Level 1
                    Sorry, I didn't check the link.

                    I have reported this to Adobe Support.

                    Brian
                    • 7. Re: unhandled win32 exception
                      ehoran Level 1
                      I'm still having this problem and Adobe hasn't yet fixed the broken link to that .zip file (I also reported the page error to Tech Support). Does anyone else have any ideas? If not, hopefully that link gets working soon...

                      Thanks.
                      • 8. Re: unhandled win32 exception
                        Sue.Andrews

                        Hi - I am getting this same issue on RoboHelp 7. I have the same project

                        - with 2 outputs - an EN version and a US version. I use build tags and variables to separate content. I tried downloading and installing the RoboHelp dll for RH 6 from that posting, but then could not open any projects at all. The EN version compiles WebHelp fine. The US version crashes every time at the point where it says "Updating files".

                         

                        It sometimes crashes as I close a saved file too, with the same error.

                         

                        I have tried eliminating spans within tables in my content, but the US version is still crashing.

                        Working over XP.

                         

                        I am completely flumaxed.

                        Sue