17 Replies Latest reply on Feb 28, 2012 1:42 PM by blahblah99

    PDF won't display (please wait...)

    Don Coyote Level 1

      I am trying to get a tax form to show with Adobe Reader. The form is available at https://ww2.revenue.wi.gov/Internet/wi_efile/2010/Form1-2010.pdf . The site says Reader 9.0 or above is needed. I have installed 9.4.2, the latest version available for Debian. When I attempt to open it, I just get a page that reads "Please wait... If this message is not eventually replaced by the proper contents of the document, your PDF viewer may not be able to display this type of document." Am I missing something?

        • 1. Re: PDF won't display (please wait...)
          jgribbin Level 1

          I have a very similar, may be same, problem w/ 9.x Reader on Fedora 14.


          I use Reader to access and print MLS forms. Since the 9.x series, I am able to view, at most, 2 PDFs per browser session useing the Reader plugin in Firefox. After 2 documents, I get a brief message, "Generating PDF ...", then a blank frame forever. It generally takes at least 6 documewnts to make up a complete contract.


          I also attempted opening the IRS PDF linked in the previous post. Same thing, blank browser window. I had already reached my limit of 2 before trying it.


          Jim G

          • 2. Re: PDF won't display (please wait...)
            Don Coyote Level 1

            It turns out there is something wrong with the package for Reader in Debian. Apparently it will not display documents that have certain types of forms. The IT tax guy said they tested with Ubuntu, so I'm surprised that it didn't go with Debian. I switched over to my notebook and installed Reader on its Arch system, and the forms displayed and calculated properly. However, now I have been unable to confirm my bank routing number or to submit the whole form at all. Does anyone have any idea how Reader would be communicating to submit this data so I could have a starting point to troubleshoot from?

            • 3. Re: PDF won't display (please wait...)
              faffmeister Level 1

              I have exactly the same problem with this form: http://www.hmrc.gov.uk/forms/cf10.pdf


              I can open it fine using Reader X, 9.4.2, and an earlier version 8 (not sure exactly which one) in Windows XP.


              If I try to open it in Linux Mint LMDE (based on Debian testing) using Reader 9.4.2 (the latest for Linux) or the same version 8 as above but for Linux on Mepis 8 (based on Debian Lenny) then I get the 'PDF won't display (please wait...)' message.


              It same problem Kpdf on Mepis and whatever the default pdf reader is on LMDE.


              I haven't tried it on an Ubuntu based OS yet but I'm not convinced this is just a problem with the Debian packaged Adobe Reader.


              This is a real show stopper for being able to complete tax returns etc online.

              • 4. Re: PDF won't display (please wait...)
                faffmeister Level 1

                Fixed it!


                At least on my Linux Mint LMDE 64 bit machine.


                If you install Adobe reader from the Debian testing repositories (which is where LMDE points you to) using Synaptic, when you do "Mark for installation" on Acroread you should find that Synaptic also offers "Mark suggested for installation >".


                In the drop down list if you slide right, you should find "acroread-plugins".


                Click on that and Synaptic will also install "acroread-escript".


                Click on apply and that should provide the missing functionality required to make these forms visible in Debian based Linux distributions.


                Deep joy.

                • 5. Re: PDF won't display (please wait...)
                  jgribbin Level 1

                  My problem is not with Adobe Reader itself. It opens pdf files just fine. It is the browser plugin that is giving me fits.


                  Adobe Reader is not in Fedora's repositories, I get it from Adobe's repositories. They do not seem to have separate RPMs for the reader and browser-plugin, it all appears to be in 1 package.


                  I am, however, still only alloted a few pdf openings in a browser window before it quites working.


                  Jim G

                  • 6. Re: PDF won't display (please wait...)
                    Vaibhav Padlikar Level 2

                    Thanks for reporting the issue.


                    I tried the form on Linux Reader 9.4.2  and it works for me.  Can you please try few steps, to ascertain that there is actually an issue with


                    1) Are you trying it from within browser or stand alone .  If it's former, then please try it stand alone to see if Adobe Reader is able to open it for you. Also , please check the version of Adobe Reader by doing `acroread -v`


                    2) Kindly check if your Browser plug-in for Adobe Reader got installed correctly , you can check this by doing "about:plugins" in firefox .


                    3) Try executing script /Adobe/Reaader9/Browser/install_browser_plugin in case your browser plugin is not installed properly.


                    However, I have tried this on Ubuntu , the steps above will help us to isolate the issue .


                    Thanks again.




                    1 person found this helpful
                    • 7. Re: PDF won't display (please wait...)
                      jgribbin Level 1



                      Message was edited by: jgribbin message was an accidental post. It was supposed to be an email to a private party. Be careful just what's selected when you click rely ;-)

                      • 8. Re: PDF won't display (please wait...)
                        jgribbin Level 1

                        I didn't notice this earlier as I didn't realize I had to subscribe to the forum separately.


                        I have Reader & the browser plug-in.


                        Reader itself is working OK. It's the browser plug-in I am having difficulties with.


                        If I turn off (delete) the plug-in, PDFs get downloaded and opened that way. A separate Adobe Reader window.


                        If the plug-in is active, after opening a couple of PDFs, the plug-in stops working,  I thought I had it figured out to 2 PDF opens at one time, I've since observed that something besides the PDF count since starting the browser session seems to be having an effect.


                        If I have been logged into the computer for a while and doing things, the count seems to be 2. If I boot the computer an immediately open the browser and start accessing PDFs, I seem to be able to access a couple of more PDFs before it stops working.

                        • 9. Re: PDF won't display (please wait...)
                          jgribbin Level 1

                          I see I missed answering a couple of your questions...


                          Adobe Reader 9.4

                          File: nswrapper_32_32.nppdf.so
                          The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.

                          That is copy/paste from about:pluginsin Firefox.

                          Help/About on Reader itself shows 9.4.2

                          I realize the plug-in at least seems to be working in Ubuntu, but how many successive PDFs have you atttempted? Thing don't seem to go wrong until one has opened successive PDFs in a single browsing session. Depending on the circumstances, it doesn't fail until at least the 4th or 5th.


                          Jim Gribbin
                          • 10. Re: PDF won't display (please wait...)
                            jgribbin Level 1

                            Did this ever get figured out?


                            After a long period of nobody getting back to me, I did figure out a workaround in a Firefox plugin.




                            It has an annoying tendancy or 2, but is working out for me for the most part,


                            Jim Gribbin

                            • 11. Re: PDF won't display (please wait...)
                              pbauermeister Level 1

                              I'd love to have an answer to this too.  I have had the exact same issue for years now on every version of Ubuntu 64 bit since at least 9.04.  I can view PDF's inside the Firefox browser maybe twice and then after that every subsequent attempt to open a PDF in the browser results in a blank window, sometimes with bits of screen grabbed pixels from other open windows until I click in the browser and then it just goes blank.  Then after I close and reopen Firefox I can view a couple of PDF's again and it happens all over again.


                              In about:plugins the installed file is: npwrapper.nppdf.so


                              Outside the browser, Adobe Reader works just great.  I'm on version 9.4.6, installed from Ubuntu Software Centre.


                              I'm currently on Ubuntu 11.10, 64 bit with AMD processor.  I've had this on several different machines, the common things about them are that they are all 64 bit AMD's.  Haven't tried any distributions other than Ubuntu though.  I would have thought after all the time that I've had the problem it would have bee fixed by now, but judging from the response on this thread here, it seems that it isn't that common a problem?

                              • 12. Re: PDF won't display (please wait...)
                                jgribbin Level 1

                                I don't think it's the version of Ubuntu or the 32/64 bit thing. I think it's just Acrobat Reader for Linux.


                                I have been using Linux for several years and, if I remember correctly, I didn't see this problem until about version 7. I don't recall having this issue w/ the 5.x & 6.x series.

                                • 13. Re: PDF won't display (please wait...)
                                  ecampbell1 Level 1

                                  The problem appears across all Linux versions.  I am running Fedora 15 x86_64 (Intel arch)  with Firefox 10.0 and I experience exactly the same thing.  Using the Adobe reader version 9.4.6 10/05/2011 I don't have any problems viewing PDF files, however from within Firefox I can view 2 pdf's before I have to restart my browser.  In about:plugins I have nswrapper_32_64.nppdf.so installed.


                                  This is a really irrating problem that I wish could be fixed by someone.

                                  • 14. Re: PDF won't display (please wait...)
                                    Don Coyote Level 1

                                    For me it is still the same problem. State taxes are using the same form again. If i try to load the PDF form in Debian (fully updated less than a month ago), i get the won't display message. I used my Arch install and it all worked the same up until the direct deposit part. Last year i just ended up having a check mailed. This year when i clicked to have my routing number checked, the program crashed and took the last hour of work with it. I have not updated my Reader version in Arch, however.

                                    • 15. Re: PDF won't display (please wait...)
                                      rockstaryogi Level 1

                                      No problems I've noticed on Ubuntu 11.10. That said, I tend to prefer using the default PDF viewer which is not from Adobe (Evince) and it always works like a charm. Maybe try that instead?

                                      • 16. Re: PDF won't display (please wait...)
                                        jgribbin Level 1

                                        Those of us attempting to use Acrobat Reader on Linux, pretty much anyway, started out using Evice. We went to Acrobat because Evince is very basic. There are things you need to be able to do w/ PDFs that Evince will not do.


                                        Online fillable PDF forms for instance.


                                        If you don't have a useful suggestion, ...

                                        • 17. Re: PDF won't display (please wait...)
                                          blahblah99 Level 1

                                          It is a running joke that the acroread plugin crashes on linux.  It has been that way for years and looks set to be the same way forevermore.


                                          However there is a fix and it isn't too difficult.  Locate and delete (or move) the file npwrapper.nppdf.so /usr/lib64/browser-plugins/npwrapper.nppdf.so on my system) this is the plugin that is so flaky and causes the problems.  Now you have no embedded acrobat reader? but there is a solution:


                                          mozplugger - it is a bit old and unfashionable but it works everytime.  It can use acroread, evince, kpdf, gv or okular to actually do the display of the pdf inside your browser.  Personally I use okular despite the many bugs (stupid landscape printing bug, "can't zoom much" bug in okular etc etc).


                                          mozplugger can do all sorts of other stuff such as embedded word docs via libre office etc - it is pretty cool and <just works>.


                                          Watch out for your distro though - I'm using SUSE and it stupidly insists on installing yet another buggy npwrapper.nppdf.so every time it updates flash player.  If you have installed mozplugger you just need to delete npwrapper.nppdf.so again and all will be working A-ok.


                                          If you use (k)ubuntu mozplugger is why this is never a problem!