4 Replies Latest reply on Mar 6, 2011 2:25 AM by TᴀW

    Extend Script CS5 not workign

    TᴀW Adobe Community Professional & MVP

      Strange.

       

      I usually use CS4. Now I happen to be scripting in CS5, and after a few times, ExtendScript toolkit stops running the script.

       

      I press f5 and nothing happens, go to Debug>Run and nothing happens.

       

      the only thing that seems to work is to copy the script to a new document.

       

      Has anyone encountered this? Do you know what wrong?

       

      Thanks,

      Ariel

        • 1. Re: Extend Script CS5 not workign
          John Hawkinson Level 5

          That's not how it works. The script decides whether it operates on one rectangle; all rectangles; all documents, downloads documents off the Internet, opens them all, and does something to the 7th rectangle, and then uploads the documents back to a server.

           

          So it depends on the script. Please post the script or a link thereto (or tell us which one if it's a standard script).

          • 2. Re: Extend Script CS5 not workign
            TᴀW Adobe Community Professional & MVP

            Hi John,

             

            Thanks for chipping in. I'm fairly familiar with scripting, so I know

            what should be happening. Even a simple script like

             

            a  = 5

             

            will, when you run it, return "5" in the ExtendScript console.

             

            But nothing was happening. Running the script had no result. I don't

            think the script was actually being run. Very strange.

             

            If I copied the script to a new document, and ran it, it then worked.

            But running it from the old document didn't!

             

            Anybody come across this?

            • 3. Re: Extend Script CS5 not workign
              John Hawkinson Level 5

              Wow!
              Either I or the forum software screwed up! I meant
              to post this in response to "Newbie question"
              and somehow it ended up in this thread.

               

              I'm going to bet that it was me who screwed up...

               

              Sorry!!!

               

              Anyhow, I have seen this happen, usually only after single-stepping.
              I don't know why it happens or what to do about it other than
              restarting the ESTK. But mostly when it happens, it has been after
              I've crashed InDesign, so I feel like crashing the ESTK too isn't
              so bad...not helpful, I know!    

              • 4. Re: Extend Script CS5 not workign
                TᴀW Adobe Community Professional & MVP

                That's funny. Your answer kind of fits my question.

                I'm reading this right now via email.

                 

                Thanks,

                Ariel