0 Replies Latest reply on Mar 7, 2011 10:41 AM by MikeRGray

    I finally got  search indexing to work in Windows 7, 32bit

    MikeRGray

      I'm writing this for all the poor saps out there trying to get this stuff to do its job.

       

      I just spent several hours of my time trying to get it to work on a brand new installation of Windows 7 32bit, and since it finally DOES, I might as well chronicle the experience. After installing the OS, all the updates, Office 2010, I set up the correct paths under Control Panel / Indexing Options / Modify. Under / Indexing Options / Advanced / File Types I checked, just to make sure: no filter for pdf's.

       

      What to do?

       

      First, search indexing in Adobe Read X is borked. Don't bother. It's won't work. They've removed the thing called an iFilter that makes it work. Why have they done this? Ask them. Beats me.

       

      Second, maybe somebody else has got the iFilter60 thing (an Adobe download) to work so I could keep Reader X. I haven't, and believe me, I've tried. The filter appears under/Advanced / File Types, but it still doesn't work. (The filter also appears in a program called "searchfilterview" that lists all the iFilters on your system. If you want to try it out, just google it - it's easy to find.)

       

      Third, supposedly, there's a MS program called filtdump.exe that would help you find out exactly why any given iFilter isn't working. However, I can't find it to download, anywhere. There's another program called ifilttst.exe that I did find (you download an MSDN SDK), but it requires setting up an .ini file, and I couldn't figure out how to do that.

       

      Fourth, there are all kinds of posts about varies registry keys you can change. I won't say I've tried all of them, but I've checked a whole bunch. Either they were already set correctly or adding them didn't help.

      Fifth, maybe somebody has got Foxit's iFilter to work alongside Adobe Reader or with Foxit Reader in place of Adobe. I haven't, and believe me I've tried. I have the exact same problem with Foxit that I've had with Adobe. The filter appears under/Advanced / File Types, but it still doesn't work.

       

      Sixth, by uninstalling Reader X and installing Reader v. 9.4 I got closer, I thought. However, still no dice.

       

      Seventh, by manually registering v.9.4.'s iFilter I finally hit paydirt. This involved putting "cmd" in the search box, right clicking it and choosing "run as an administrator." Then I entered the following (with quotation marks):

       

      cd "C:\Program Files\Adobe\Reader 9.0\Reader"

      regsvr32 AcroRdIF.dll

       

      After waiting a bit longer and rebuilding indexes, I finally started getting hits.

       

      BTW, I tried this dll registry trick on all the other combinations, but nothing happened. It only worked on v. 9.4.

       

      * * * * *

       

      That's my safari. Again, since it worked, I'll pass the info on to you guys. Maybe somebody else has found a better way.

       

      Alos, I don't know what it takes to use it with Windows 7 64bit. I have a 64bit machine that isn't working either, but since I'm out of time, that'll be another adventrue for another day ...

       

      For the record: I simply cannot believe that the people runnign MS and Adobe are so gigantically incompetent that it takes this much grief. It's unbelievable.

       

      Best of Luck,

       

      Mike