0 Replies Latest reply on Jun 26, 2007 8:35 AM by levancho

    Loaded Module Resize Issue

    levancho Level 3
      issue is a little complicated so I will try to explain it with some code samples
      I have a Module defined Like this :

      quote:

      <mx:Module autoLayout="true" xmlns:mx=" http://www.adobe.com/2006/mxml" xmlns:custom="components.data.*"
      xmlns:contracts="components.contracts.*"
      width="100%" height="100%">
      <mx:TabNavigator label="Contracts" id="Contracts" width="100%" height="60%">
      <contracts:ContractsMilestonesTab width="100%" id="contractsMilestonesTab" toolTip="All Milestones />
      ... some more tabs.
      </mx:TabNavigator>
      </mx:Module>


      and in main.mxml I do following :

      quote:

      <mx:VDividedBox id="DividedBox" width="100%" height="100%" enabled="false">
      <mx:TabNavigator creationPolicy="all" id="tn" width="100%" height="35%" >
      <custom:DescriptionTab id="DescriptionTab" toolTip="NPD Description"/>
      etc .. some more tabs total of 6
      </mx:TabNavigator>

      <mx:ModuleLoader autoLayout="true" id="contractsModule" url="contractsModule.swf" height="30%" width="100%"/>
      <custom:SummaryBox id="summaryBox" width="100%" height="35%" />
      </mx:VDividedBox>


      issue is as you see this dividedBox has three boxes
      one :
      top tabbar
      middle is another tabbar loaded from module and
      third is regular Panel
      Issues are following :

      when page loads middle tabbar is about 60$ width of other two top and buttom containers. so there is grey gap.

      when I move divBox handlers to resize, top and buttom parts flow with them meaning they resize, but middle one does not,
      also when page loads it does not stretch all the way. I donut understand why, if I don't load that middle tabbar with module it works fine.