16 Replies Latest reply on Sep 18, 2012 7:34 AM by nikos101

    hi complaint about coldfusion builder

    olddummy

      I do not know who to complain to directly, so I wish that Adobe had not sent me coldfusion builder.  I have had it for four or five days and have obsessively tried to add a server.  This is, according to all help files is simple.  I follow the help files and reach a point where the file does not co-respond to the installation on my machine.  The installation has followed the steps in the installation instructions so i do not know how to change anything to make it more correct than the default.  This is the most frustrated i have ever been by a piece of software and it was one i did not ask for. Now that i have it i feel i have to be able to make it work but i am wasting days getting nowhere.

        • 1. Re: hi complaint about coldfusion builder
          Adam Cameron. Level 5

          i did not ask for.

           

          I think we have a case of nominative determinism here.

           

          Firstly, if you didn't ask for it, why are you bothering wasting time with it?!

           

          Secondly, and more significantly: your compaint is very vague.  You give us no idea of your server set-up, nor are you telling us which values you're putting into CFB to configure your server connection.  So what are you expecting to achieve here?

           

          To be honest, I've found setting up a server connection to be completely straight forward, and have never had a problem with it.  This is not an attempt to show off, it's just by way of comparison of your own experiences, and also perhaps to suggest the fault does not intrinsically lie with CFB.  You might want to look at what's between your chair and your keyboard, and direct your ire there.

           

          Post your server config, and post what you're putting into CFB.  Then we can help you get it sorted.  Or discover that there is actually a problem with CFB.

           

          --

          Adam

          • 2. Re: hi complaint about coldfusion builder
            olddummy Level 1

            Adam, hi thanks for replying to my rant.

            I have already posted a question on the forum asking for help with setting up a server in coldfusion builder.  The responses that i have got were to send me to help files.  I have tried to follow the help files.

            I have just removed and re-installed CFB again.

            I selected stand alone.

            the install folder is C:\Program Files (x86)\Adobe\Adobe ColdFusion Builder

            I then extracted the files from AdminServerComponents.zip into the CFB home folder

            I then run the adminstart.bat file as an administrator.

            I then open CFB and click on add server.

            I name the server cfusion

            I leave the Application server as Jrun

            I set the host as localhost

            and the port as 8500

            While in that screen i enter an RDS user name and password.

            I click next

            In the server home i have tried a variety of things the latest is C:\Program Files (x86)\Adobe\Adobe ColdFusion Builder

            (on the adobe getting started site it suggests that with the default installation this should be coldfusionCentaur which does not exist on my machine)

            whatever value i put in here it always says "server home is not valid" so obviously i never get past this page.

            I have tried lots of permutations as i have apache server 2.2.16 on my machine and thought that it would be possible to use this but i cannot make this work either.

            I am more than willing to admit that i am probably missing something stunningly simple but i am following guides that get me to here and no further.

             

            As for why i am wasting my time with it.

             

            Before i had it i knew nothing about it.  Since getting it i have looked at some of the getting started stuff and it appears to be a fabulous tool.  Also i hate that i have it and cannot make it work.

            Thank you for your time.

            cheers

            • 3. Re: hi complaint about coldfusion builder
              12Robots Level 4

              I've been trying to explain in the other post.  ColdFusion Builder does not set up the ColdFusion server for you. ColdFusion Builder is an IDE for building ColdFusion applications.  You need to download and install ColdFusion Server separately. CFB will not do it for you.

              • 4. Re: hi complaint about coldfusion builder
                BenSmash1

                Where does one go to find Coldfusion server?  I can't seem to find it.   Can you post the link?

                • 6. Re: hi complaint about coldfusion builder
                  jvc714

                  I have the same exact problem.

                   

                  I have tried almost every combination of the following.

                   

                  • Windows 7 Professional 64 Bit
                  • Windows Vista 32 bit
                  • CF10 developer edition
                  • CF10 30 day evaluation
                  • 64 Bit version of CF10
                  • 32 Bit version of CF10
                  • multiple RDS users
                  • single RDS user
                  • Clean Windows Vista 32 bit installation
                  • Installed CF10 first
                  • Installed CFB 2 first

                   

                  The only thing I have NOT tried is the above combinations with RDS disabled.

                   

                  All of which seems to achieve the same result.

                   

                  I also posted on Adobe's forum and 75+ people looked at it but not one person responded.

                  • 7. Re: hi complaint about coldfusion builder
                    Adam Cameron. Level 5

                    I have the same exact problem.

                     

                     

                    It doesn't really sound like the exact same problem, but the problem the OP had was they didn't understand what CFB is for, and didn't understand its relationship with CF, and accordingly didn't realise they needed CF installed.

                     

                    It sounds like you have a completely different issue (given you do have CF installed), however it's impossible to say anything sensible because you don't actually detail what the problem is that you are having.

                     

                    Where's this other thread of yours?

                     

                    --

                    Adam

                    • 8. Re: hi complaint about coldfusion builder
                      jvc714 Level 1

                      Adam, thanks for replying so quickly.  I have spent countless hours in the last few days trying to get this to work with no luck.

                       

                      Yes, I do have both CF10 and CFB 2 installed on the same computer.  All symptoms are the same as "olddummy."  When I force it through by specifying "C:\Coldfusion10\cfusion" in the server home field and "C:\Coldfusion10\cfusion\wwwroot" in the document root and selecting "9.x" for the version even though it is 10 but the option does not exist, I get the result of the post.

                       

                      You can find my other post at http://forums.adobe.com/message/4541596#4541596.

                       

                      Thanks in advance.

                      • 9. Re: hi complaint about coldfusion builder
                        Adam Cameron. Level 5

                        Well you can't expect it to work when selecting CF9 for a CF10 server.  They're running on completely different architecture.

                         

                        CFB2.0 predates CF10, so does not support it.  You need CFB2.0.1, which was released specifically to support CF10.

                         

                        Anyway, this is kinda hijacking the original thread (although it's dead), because this has nothing to do with the OP's problem.  Let's continue - if needs must - on your own thread.

                         

                        --
                        Adam

                        • 10. Re: hi complaint about coldfusion builder
                          Adam Cameron. Level 5

                          Yes, I do have both CF10 and CFB 2 installed on the same computer.  All symptoms are the same as "olddummy."

                           

                          No, "olddummy" didn't have CF installed at all.  That was his problem.  Not the same as yours.

                           

                          --
                          Adam

                          • 11. Re: hi complaint about coldfusion builder
                            jvc714 Level 1

                            Alright Adam. 

                             

                            I agree with you that it is not exactly the same problem but all the symptoms with it saying "server home is not valid."  I only selected CF 9.x because 10.x was not an option in the drop down box to see if I would get something else.

                             

                            Add-Server-Step2.png

                             

                            Is there a chance you can respond to my other thread about this?

                             

                            JT

                            • 12. Re: hi complaint about coldfusion builder
                              apatan

                              Hi,

                                 The CFB you are having does not ssupport CF 10. You should have an updated version of CFB.

                              • 13. Re: hi complaint about coldfusion builder
                                konatala

                                While adding server to Builder in the Server Setting window you might have selected the Application Server value as "JRun", so for which you are getting the server versions 9.0.x/8.0.x/7.0.2

                                 

                                Change the Application Server value to "CF+Tomcat Bundle" will bring the version drop down value 10.0

                                • 14. Re: hi complaint about coldfusion builder
                                  nikos101 Level 2

                                  I just found the same issue but somehow how the error :

                                  coldfusion 10 server home is not valid

                                  disappeared after some button clicks on the above dialogue.

                                   

                                  I now am unable to select the version and continue the wizard

                                   

                                  I'm using CF10 and CFB 2.01

                                   

                                  thanks guys!

                                  • 15. Re: hi complaint about coldfusion builder
                                    MDwaipayan Level 1

                                    Are you using "CF+Tomcat Bundle" as Application Server as konatala has pointed out in the above post?

                                    What Server Home are you using?

                                    What is your platform?

                                    • 16. Re: hi complaint about coldfusion builder
                                      nikos101 Level 2

                                      it worked thx!