6 Replies Latest reply on Mar 24, 2011 9:19 AM by NDRHelp

    Error when trying to upgrade a project to RH9

    NDRHelp

      I'm attempting to upgrade a project from RH 8.0.2 to RH9. My other projects have upgraded fine but I have one particular project that is giving me the following error:

       

      Error - node %Rel_420_NeoTool_Product_Help/rhsharedresource.apj already exists.

       

      I have the source of the projects kept in RoboSource so after I click OK, I get the following message:

       

      Cannot check out all the files that needed to upgrade this project.

       

      I noticed that this file does not reside in source so I figured that RoboHelp created it so I tried to delete it but am getting the same error.

       

      Any ideas would be greatly appreciated.

       

      Thanks

        • 1. Re: Error when trying to upgrade a project to RH9
          NDRHelp Level 1

          I just found out some additional information. Other projects that are branches within RoboSource are all giving me this same error. Now I wonder if it has something to do with the fact that these are branched projects within RoboSource. Could this perhaps be giving me issues in attempting to upgrade?

           

          Thanks

          • 2. Re: Error when trying to upgrade a project to RH9
            Mona girdhar

            Hi,

             

            Try deleting the concerned files (rhsharedresource.apj & SearchOptions.xml) from RSO (both from root node and branch node) and also from your local project folder and see if this helps.

             

            If the problem still persists, can you please provide the information for the following queries:

             

            1. What are the exact steps that you followed while upgrading this version controlled project for the first time?

            Such as, did you click yes/no in the upgrade, Get latest and Checkout dialog?

             

            2. Did you open the project from your local copy or from RSO ?

            If you opened this project from RSO, did u open this project from root node or the branch node ?

             

            3. Please let us know the details of the branch properties if possible.

             

            Thanks

            Mona

            • 3. Re: Error when trying to upgrade a project to RH9
              NDRHelp Level 1

              Thank you Mona for your suggestion. Unfortunately it didn't work. The rhsharedresource.apj & SearchOptions.xml files do not exist in source in either the root or the branch but I deleted them from both local projects (root and the branch) and attempted the upgrade and received the same error message.

               

              Answers to your questions:

               

              Steps I took to upgrade

               

              1. I upgraded the root project first by opening the project on my local machine and when presented with the dialog that this project was created in an older version of RoboHelp, I selected the Upgrade button.
              2. RoboHelp automatically checked the files out of source and performed the upgrade and all was well with the root.
              3. Next I opened the branch on my local machine using RoboHelp.
              4. When I received the message that it was created in an older version, I again selected Upgrade.
              5. It churned for a short time and the bottom of the RoboHelp window says, "Adding Files(s) to Version Control Project" then I get the error message that rhshaerdresoruce.apj already exists.
              6. When I click OK on the error dialog, I get another error dialog that says "Cannot checkout all teh fiels that needed to upgrade this project"

               

              Checking out of source

              Based on your questions regarding starting from source I tried the following experiment which also unfortunately didn't work:

               

              1. I checked the entire branch project out of RoboSource before attempting to upgrade.
              2. Deleted the rhsharedresource.apj and SearchOptions.xml file from the local version.
              3. Opened it in RoboHelp and selected to Upgrade when presented with the dialog that the project was created in an older version of RoboHelp.
              4. I received the same error messages.

               

              Branch Properties

              I'm not entirely sure what you mean by Branch Properties but here is a screen capture of the Settings tab. On the Rights tab all items are checked. There is nothing in Notes. The Local Path tab has the location of my local copy. The Links tab lists my root project $/Operations Monitor_help

               

              Branch_Properties.jpg

               

              Thank you for your assistance,

               

              Nita

              • 4. Re: Error when trying to upgrade a project to RH9
                Mona girdhar Level 1

                Thanks Nita. But I am still not able to reproduce the issue. I performed the following steps. Can you please have a look at the steps and let us know how different are they from your steps.

                 

                1. Created a project in RoboHelp 8.0.2 and added this project to RSO 3.1 in a folder in Root $.

                2. I opened the RSO Explorer and created a branch via View Manager and set its property to Branch.

                3. I dragged the project from Root $ and dropped at the Branch created as Branch Link.

                 

                    Please have a look at the snapshot.

                 

                RSOExplorerView.jpg

                 

                 

                4. Now i opened the Branch project from RSO in RoboHelp 8.0.2 and close it ( At this step, copy of Project is created at my local machine).

                5. Considering that we have two copies of the project now -  Original and the Branch project, launch RoboHelp 9.0 and open the original project from the local machine.

                6. RoboHelp asks to upgrade and I clicked Yes;

                7. RoboHelp now asked to check out the files and i clicked Yes, upgradation was successul here.

                8. Now i checked in the checked out files into RSO.

                 

                Please note in RSO Explorer that Branch project is updated for rhsharedresources.apj and SearchOptions.xml.

                 

                9. Now i opened the branch project copy available at my local machine.

                10. RoboHelp 9.0 asked to upgrade for which i agreed by clicking Yes.

                11. It asked to check out the files, click Yes and the upgradation is successfully done.

                 

                Please let me know if you are using any different set of settings.

                 

                Thanks,

                Mona

                • 5. Re: Error when trying to upgrade a project to RH9
                  Tejodhar Atreya U Level 1

                  Hello

                   

                   

                  Please go to the Msconfig and  go to services

                  Select hide all Microsoft services

                  Select disable all  - click ok

                  Restart your computer

                   

                  check by doing the Upgrade

                   

                  Regards

                  TAU

                  • 6. Re: Error when trying to upgrade a project to RH9
                    NDRHelp Level 1

                    Thank you so much Mona for this suggestion. After some additional work with RoboSource the files became visable in the source directories. After deleting them there and on my local drive it worked with two of my projects. The third project however was stubborn and didn't work giving me the same error even though I had deleted the files from source and local copies. I finally disconnected that project branch from RoboSource, upgraded it, and then reconnected it and committed it. So, all is well now. Thanks so much for your help.

                     

                    Nita