7 Replies Latest reply on Jun 21, 2007 8:09 AM by HKabaker

    RoboHelp X5 - No Whdata Folder?

      I am creating Web Help using RoboX5 - My settings in the Web Help options dialog are:

      Java Applet: DHTML > Java Applet > Pure HTML
      Optimize Speed for: Web Site (internet)

      However, when I check the !SSL folder, the Whdata, Whgdata, Whxdata folders are not created.

      1) Is this something new with X5?
      2) Is there something wrong with my settings?

      ANy help would be appreciated. THANKS
        • 1. Re: RoboHelp X5 - No Whdata Folder?
          RoboWizard Level 4
          Hi catefla

          Maybe you typed it wrong or maybe I'm misunderstanding. But you should never see these folders in the !SSL! folder.

          Why? It's quite simple really. This !SSL! folder should contain other folders. One for each layout you have created. So if you created a WebHelp layout, you should see !SSL!/WebHelp. And inside THAT folder is where you would find the three folders you mentioned. So it would look like this:

          ---> WebHelp
          ------> whdata
          ------> whgdata
          ------> whxdata

          Now if you just forgot to add the correct pathing when typing your post and you actually are looking in what you think is the right place, I would then advise you to look more closely at the first dialog you see when editing the WebHelp properites. Scrutinize the field that says: Output folder and start page. It might just be that you aren't looking in the correct location.

          Cheers... Rick
          • 2. Re: RoboHelp X5 - No Whdata Folder?
            catefla Level 1
            Hi Rick,

            Thanks for the reply....

            1) Yes, I typed the path incorrectly. I know that these subfolders are supposed to be in the <B>.../!SSL!/WebHelp</B> folder.
            2) Yes, I am looking in the correct location based on the settings for my WebHelp output.
            3) And, I have triple-checked everything and even run a Search on the whdata (etc) folder names... they are NOWHERE to be found!

            Current Help project - Folder Contents: My <B>.../!SSL!/WebHelp</B> folder for the project contains .htm files, .css files, a project .ALI file, eHelp.xml, RoboHHRE.lng, ehlpdhtm.js, related image files, and an IMAGES subfolder. No other subfolders.

            Old Help project - with Whdata(etc) Subfolders: I found an old project, verified that the WebHelp folder had the Whdata (etc) subfolders, made no changes to the layout's settings (Note that they are the same settings as in my current Help project), and then created the WebHelp. Now, THIS project does NOT have the Whdata (etc) subfolders.

            So, does it sound like there is something wrong with my RoboHelp installation?
            • 3. Re: RoboHelp X5 - No Whdata Folder?
              HKabaker Level 2
              If you deselect the TOC, Index and Search options in the output setup, you won't see a navigation frame at the left. But even then, RH puts the three wh.... folders in the WebHelp output directory. The basic files are there, but with no data.

              Before you go to the trouble of uninstalling and reinstalling RH5:

              Have you tried starting with a completely fresh WebHelp output layout? If you've been working with the default layout only, back up the entire project, open it in RH and trash the WebHelp layout. Close and relaunch RH. It will re-create the default WebHelp layout .

              When you say "old project," was it done with RH X5 or an earlier version? When you installed X5, did you uninstall any previous versions? Did you install the X 5.0.2 upgrade?

              I just had this flash: You say you have a project .ali file. Isn't that a project source file?

              The output folder also should have project .log, project_csh.htm and project_rhc.htm files.

              • 4. Re: RoboHelp X5 - No Whdata Folder?
                RoboWizard Level 4
                Hi catefla

                If what Harvey offered doesn't help, there are another couple of things to check.

                1. If you have recently re-imaged your PC and RoboHelp has been re-installed fresh, it could be that it wasn't correctly installed. What I mean by this is that if your IT folks re-installed it and was not logged in as you with full admin rights, it's probably not correctly installed. Being unable to generate WebHelp is a definite symptom of this. I'm working with a class at the moment that has at least three users with this very issue.

                2. Assuming RoboHelp has been correctly installed, the problem could be related to something called your "XML Parser". I once had this issue and was suddenly unable to generate WebHelp. To re-install the parser, try clicking here and investigating some of the links.

                Hopefully something here helps... Rick
                • 5. Re: RoboHelp X5 - No Whdata Folder?
                  MergeThis Level 4
                  The RH default location for output files is, indeed, the !SSL!\WebHelp directory. If someone before you has configured a different path for the output, however, that's where the output is being generated to.

                  Please verify that the path in the box under "Select Output Folder and Start Page" panel of the first window of the generate process remains the default for this layout, or that it's been changed.

                  Good lick,

                  • 6. Re: RoboHelp X5 - No Whdata Folder?
                    catefla Level 1
                    Thank you all for your input.

                    Per my previous emails, I have verified the output location (many times) - no whdata (etc) folder. I have created new projects and used the RH default layout - with the same result. - no whdata (etc) folder.

                    Re: the RH install. Machine was clean before installing RH. I was the Admin on my PC. The 5.02 upgrade is installed. And, I am NOT generating Help across our corporate network.

                    So... Rick, I'm going to check out your XML parser idea.

                    I will post the results.

                    Thanks - Cate
                    PS - I have been using RH for more years than I care to say - :) - this is the first time I have experienced this situation!
                    • 7. Re: RoboHelp X5 - No Whdata Folder?
                      HKabaker Level 2
                      Hi, Cate,

                      You say your PC was clean before the RH install.

                      If that means what I think it means, you started with a clean slate, maybe with a disk image configured in your IT department.

                      Is it possible that your personal user profile is missing some permissions for writing to the hard drive?

                      (Grasping at straws here.)