2 Replies Latest reply on Jun 11, 2007 1:27 PM by RiOrius2

    Help getting started

    RiOrius2
      So, I'm trying to get started working with Flash using ActionScript. I've read some tutorials, browsed through some code, and feel like I have enough resources to do what I want, with one exception: I can't figure out how to get the actions I put on my first frame to run. I've downloaded examples, and they all seem to work; I feel like I've mimicked their syntax precisely, but it appears I'm missing something, because my script isn't running.

      Here's what I'm doing, step-by-step (using Macromedia Flash MX Professional 2004, Trial):

      -Create new Flash Document
      -Import to Library: 1.jpg (picture of a panda bear)
      -Window->Library to view library, drag 1.jpg onto canvas
      -Right-click picture, Convert to Symbol: Movie Clip named PandaClip
      -Insert new layer above Layer 1, name it "actions"
      -In the Actions window, with "Current Selection" reading "actions : Frame 1", type:

      PandaClip.onRelease = function() {

      PandaClip._alpha = 0;

      }


      which, from my understanding, should mean that, when I click on the picture, it'll disappear.

      -Ctrl+Enter to test movie.

      When I test the movie, I see the picture, but clicking on it does nothing (I don't even get the finger pointer indicating it's clickable).

      So... can anyone see where I went wrong? 'Cause it's been driving me nuts. If I attach an action to the PandaClip itself using on(release), it works fine and dandy, but I'd really like to be able to have some script run in the first frame...