4 Replies Latest reply on Mar 20, 2011 10:30 AM by the_wine_snob

    webDVD

    sgurvey

      My webDVD project runs just fine when I click on the Play... html file on my computer. Runs from drive in browser after I OK scrpts and Active-X.

       

      But it fails when I load the entire directory to my web site and try to run it from there. Menu comes up, but when you click buttons to play the videos it does something but the playback window does not come up and it returns to the menu. This must have something to do with permissions either in IE or on the web site, but I'll be darned if I can figure it out. Made it a trusted site but that didn't solve problem. Can anyone help? Thanks.

        • 1. Re: webDVD
          Steve Grisetti Adobe Community Professional

          Have you tried using the FireFox or Chrome browsers to see if they can access the site? That would tell you if IE's settings are the problem.

           

          If you don't mind, you could also post a link to your WebDVD on this forum and we can try to access it ourselves to see if we're experiencing the same problem.

          • 2. Re: webDVD
            sgurvey Level 1

            Thank you for your suggestions. I was encouraged to spend the better part of yesterday investigating.

             

            The link to the site is:

             

            http://gurvey.name/ScottResume/Play_webDVD.html

             

            and yes, both Firefox and Chrome exhibit the same behavior. What I have discovered is that this is not a problem in getting Flash to run. In fact, I have another site using a template generated Flash slideshow which works just fine at:

             

            http://gurvey.name/poochinigurveyname/index.html

             

            I finally found that in Firefox you can get a log of error messages through its developer feature. There may be something similar in IE and Chrome but I could find it. What I can see in Firefox is that each time you push a button to start a video playing, a "GET" is issued to retrieve the file. These GETs are failing with a 404, file not found, although they are of course present in the directory.

             

            GET http://gurvey.name/ScottResume/Movie1.f4v

            GET http://gurvey.name/ScottResume/Movie1.f4v

            GET http://gurvey.name/ScottResume/Movie2.f4v

            GET http://gurvey.name/ScottResume/Movie2.f4v

             

            Interestingly, when run right from the file system on the local machine there is no problem. But when the protocol is http: rather than file: it fails, even if the directory is simply mounted as a site in IIS Express and addressed as http://localhost.

             

            I assume this all has something to do with my failing to set the right permissions or access rights on the web server.

             

            I appreciate your help. It is especially kind since I know this is not a problem with Adobe Flash. I have been a Photoshop, Premiere and Acrobat user for many years and am not a bad programmer. But my experience is almost entirely with desktop apps and I only have a cursory idea of how web servers work and know nothing about how one goes about configuring them!

             

            Thanks,

            • 3. Re: webDVD
              sgurvey Level 1

              Finally decided to solve this problem, or go crazy trying.

               

              Turns out the F4V file type, the new and preferred type for flash video, was not listed among the MIME types authorized for the server. Adding it solved the problem.

               

              And so it goes....

              • 4. Re: webDVD
                the_wine_snob Level 9

                That is good info, and thank you for reporting.

                 

                The F4V (a variant of H.264) has gained popularity, and PrPro has added it. The biggest limitation (when everything is set up properly) is that it does not support Transparency, so for sprites, etc., one would still use FLV.

                 

                Good luck,

                 

                Hunt