8 Replies Latest reply on Mar 18, 2011 2:01 AM by Peter Grainge

    Missing Topics on Opening

    Jeff Kersh

      I'm using RH 8 in Windows 7.

       

      I opened a project this morning, and only a handful of topics are appearing in my Topic List.  All the topics are where they should be; the Topic List just isn't reading them.  When I open the CHM, though, I have images missing (images that aren't showing up in the topic list.  Could I have something set wrong?  I haven't changed anything "under the hood," so this was a real shock.  Any idea what might be going on?

       

      Thanks,

       

      Jeff Kersh

      American HealthTech, Inc.

        • 1. Re: Missing Topics on Opening
          Jeff Kersh Level 1

          One more thing...could I create a new project and import my files into that?  Would my TOC survive?  I have an uncorrupted CHM, which is now backed up everywhere I could put it , but I've restored from the HHP file before and every time I've had to rebuild the TOC - with roughtly 2500 topics, that's not something I want to do unless there is absolutely no alternative.  I'd rather fix it somehow, but we do what we must...

           

          Jeff Kersh

          American HealthTech, Inc.

          • 2. Re: Missing Topics on Opening
            Willam van Weelden Adobe Community Professional & MVP

            Hi,

             

            Hi, You do not want to import output files if there is any other way of restoring your project. Importing output files is a last, desperate measure.

             

            First off, have you installed both patches. Patch 8.0.2. fixes a problem with disappearing files and folders. Install both patches before doing anyting else.

            Secondly, is your project on a local disk or on a network drive. A network drive is a one way ticket to misery.

             

            Now, follow the post: http://forums.adobe.com/message/3548482#3548482 My guess is that you have the exact same problem as described in this thread. See if that helps you. And to be on the safe side: Create a backup.

             

            Greet,

             

            Willam

            • 3. Re: Missing Topics on Opening
              Jeff Kersh Level 1

              I did everything in the post you referenced, and now I have no topics at all.  Are we supposed to troll the Adobe website for service releases?  Some of us have jobs that prevent us from hanging out. I installed the service release, deleted the CPD and FPJ files, and now I have nothing.  Your "fix" made things worse.  Can somebody please help me? 

              • 4. Re: Missing Topics on Opening
                Willam van Weelden Adobe Community Professional & MVP

                Hi,

                 

                You did of course make a backup as mentioned in both posts before deleting those files, didn't you? The .fpj-files hold the directories and topics in your project. Deleting them will clean up your project very efficiently indeed. Restore the backup and try again. Did you follow the link to Peter's site? To be sure: http://www.grainge.org/pages/authoring/opening/opening_projects.htm

                 

                RoboHelp has an autoupdate feature. Look under Help > Updates. Be sure to install both patches first thing!http://www.grainge.org/pages/authoring/opening/opening_projects.htm

                 

                Greet,

                 

                Willam

                • 5. Re: Missing Topics on Opening
                  Jeff Kersh Level 1

                  I did everything, step by step, and I went from a dozen categories to nothing.  That's where I am. 

                  • 6. Re: Missing Topics on Opening
                    Peter Grainge Adobe Community Professional (Moderator)

                    Jeff

                     

                    The people trying to help you also have jobs to do. You don't have to hang around the Adobe site or these forums to learn about updates. First RoboHelp should advise you an update is available and second it is easy enough to go to the Help menu say once a week to check if you don't trust notifications.

                     

                    No one has lost any topics as a result of following the steps on my site. They were carefully verified with Adobe as well. The thread you looked at did have a post recommending uninstalling 802. That was incorrect advice and now that I have had the chance, I have deleted it.

                     

                    If you have looked at the project in Windows Explorer and the topics are missing there and you have no backup of that you can use, the only thing I can suggest now is to use the CHM and see the Reverse Engineering topic on my site.

                     


                    See www.grainge.org for RoboHelp and Authoring tips

                     

                    @petergrainge

                    • 7. Re: Missing Topics on Opening
                      Jeff Kersh Level 1

                      Please don't misunderstand me; I know we all have jobs to do.  If I implied otherwise, it was totally unintentional.  All my files are where they should be; RH is just not reading them. 

                      • 8. Re: Missing Topics on Opening
                        Peter Grainge Adobe Community Professional (Moderator)

                        So they are not showing in Project Manager but are present on the hard disk. Is anything showing under Broken Links?

                         

                        If yes, repair as instructed on my site.

                         

                        If no, it sounds like you need to import them back in.

                         


                        See www.grainge.org for RoboHelp and Authoring tips

                         

                        @petergrainge