15 Replies Latest reply on May 31, 2011 7:14 PM by prm620

    Issues with Calling WebHelp Pro

    MeWrite Level 1


      We are creating WebHelp Pro using RH8 and the client is running IE7.  We decided on this format mainly because the search feature for FlashHelp Pro does not work.  Now we are finding issues in WebHelp Pro that are stumping us.  I think this may be mainly that we are calling for the incorrect URL.


      In the end this will be Context Sensitive Help, however, due to development issues, I have built a landing page (htm page) with links to each departments help.  The user is saving the landing page in favorites and then calls the help from that page.


      We have 3 projects total.  In RoboServer I have some helps with automatic merging and in others I have it off.  Since I have structured the project via the Parent/Child approach, the auto merge or not auto merging of the projects on the RH Admin side seem to have not discernable effects.  The Parent Project auto redirects to an Intro topic in the main help.  There are 3 child projects (Main, training, activities).



      Depending on the URL we use, depends on the issues:


      1)      http://{SERVERNAME}/robohelp/server?%26area%3D{DEPARTMENTNAME}%26mgr%3Dagm%26agt%3Dwsm%26wnd%3D{D EPARTMENTNAME}ParentProject%7COnlineHelp%26tpc%3D%2Frobohelp%2Frobo%2Fserver%2F{DEPARTMENT NAME}%2Fprojects%2F{DEPARTMENTNAME}ParentProject%2Fparent_redirect.htm%3FRINoLog28301%3DT% 26ctxid%3D%26project%3D{DEPARTMENTNAME}ParentProject

      Skin displays correctly with the merged TOC, with Contents, Glossary, Search, Print buttons.  This URL seems to be calling the window.  Windows are defined identically and we use only one. 

      Search button – search works correctly.

      ISSUE 1:  The main TOC does not display correctly.  The 2nd project has a TOC with baggage folders redirecting to PDFs.  IF we remove the 2nd Projects TOC the merged TOC displays correctly.


      2)      http:// {SERVERNAME}/robohelp/robo/server/{DEPARTMENTNAME}/projects/{DEPARTMENTNAME}ParentProject /Help_Parent_Project.htm –



      ISSUE 1:  Skin displays incorrectly:  The merged TOC, with Contents, Index, Glossary, Search, Print buttons, and Search in the Toolbar. This url does not seem to be calling the window.  Windows are defined identically and we use only one. 

      Search button – search works returns PDFs prior to topics and in some case does not return valid topics correctly.

      The main TOC does display correctly even with the 2nd project of baggage folders redirecting to PDFs.


      NOTE:  The search is set to the default where the search is being on client not the server. 


      ISSUE 2:  When I add a new button to link off to Reports it places it to the left of the Search in Toolbar instead of between the Glossary and the Print button as indicated in the Windows dialog box.



      ISSUE 3:  Redirecting from a web page to a PDF does not work in either layout above.  I can redirect from web page to web page automatically, however, I cannot get a web page to redirect to a PDF.  I can link from a topic to a PDF and it does open in a new browser window in PDF, however, I would prefer to have 1 topic in the TOC that when click redirects to the PDF.  I have done this with older versions of RH, but for RH8 it does not seem to work as it used to. 


      ISSUE 4:  We uploaded 2 baggage folders and added them to the TOC.  They are PDF files, unlike the other PDF files, these files do not ever return in a search, even when we search for the exact name on the PDF.  There is nothing special with them and they are no different then the training manuals PDFs, just a different help project and folder.  Any reason these PDFs are being blocked from the search engine?



      I hope this makes sense cause I'm more than a little overwhelmed and frustrated with all the troubleshooting.




        • 1. Re: Issues with Calling WebHelp Pro
          RoboColum(n) Level 5

          Hi CJ.


          You say that you have some projects using the auto-merge option and some that don't. Can I assume that the three projects you refer to are in an area with no auto-merge option and that they use the mergedProjects directory solution outlined here. Assuming you do, try the following URL:




            The RoboColum(n)   @robocolumn   Colum McAndrew
          • 2. Re: Issues with Calling WebHelp Pro
            MeWrite Level 1

            Colum -- I tried the path you suggested but it comes back with an Apache error that the path cannot be found.  Current structure is this:


            1)  Manual MergeHelp (yes I'm using the structure as outlined on Peter's site) and this test project is not auto merging projects of the same type.  Parent Project with merged TOC to 3 children project and 1 topic redirecting to the main topic in the 1st Child Project.


            Parent Project redirects to <meta http-equiv="refresh" content="0; url=./mergedProjects/Child_1/Introduction/SoftwareOverview.htm" />

            Parent Project TOC is merged Child_1, Child_2, Child_3

            Parent Project defines the window which has no index button.


            2)  Files are generated to local Generate folder:


            Parent Project

            Parent Project/mergedProjects/Child_1

            Parent Project/mergedProjects/Child_2

            Parent Project/mergedProjects/Child_3


            3) Parent Project is published to the server and it publishes all the Child projects with it:


            http://{IPADDRESS}:8080/robohelp/robo/server/TestHelp/projects/TestParentProject/Parent_Pr oject.htm


            If I remove the :8080, the robo, or projects in the above url I get the error that the path cannot be found.  I tried entering the parent_redirect.htm instead of the Parent_Project.htm, however that redirects into Child_1/Introduction/SoftwareOverview.htm and then you have to click the SHOW link to display the TOC. The skin still shows all the buttons, including the Index.  I even went so far as to create the same window minus the Index button in all children projects, but it still shows up.  Even calling the Child_1 help directly still displays the skin with the Index button and (obviously) no other child TOCs.


            I feel like I'm missing something small, but can't figure it out.



            • 3. Re: Issues with Calling WebHelp Pro
              RoboColum(n) Level 5

              Double check the spelling and case sensitivity of the path you specified in step 3 as it should work provided the area name is "TestHelp". I notice there is a space in the parent project directory "TestPar entProject". Could that be the cause?

                The RoboColum(n)   @robocolumn   Colum McAndrew
              • 4. Re: Issues with Calling WebHelp Pro
                MeWrite Level 1

                The URL has no spaces.  That's just my fingers going wonky.  The URL I call has no spaces or odd characters, including underscores.


                The URL I posted does display the Help, however, it does not display it correctly.  I have 2 windows defined:  Help and Reports.  Help should display for the Processors, while Reports should display for Secondary.  Regardless of which role they are in they all see this:




                Processors should see the above minus index and reports.


                Secondary should see the above minus index with Reports showing between Glossary and Print.




                • 5. Re: Issues with Calling WebHelp Pro
                  RoboColum(n) Level 5

                  OK I think I see what you are trying to achieve. It wasn't clear to me that you had two windows each of which is to be displayed for specific sections of the help.


                  What you need to know is that the window called is defined inside your WebHelp SSL. As you are using the mergedProjects approach the window being used is taken from the master project. You can't specify a window in a child project and expect the master to know to override its window with that one.


                  I think you best approach is to ditch the mergedProjects approach. Just add the child projects to the parent project's TOC. Then generate and publish each project (inlcuding the children) to the required RH Server area. Make sure that the "Automatically merge projects of the same type" option is set on the area. You'll have to change any inter-project links but other than that, you should be OK.


                  I personally haven't tried this but there is no reason why it shouldn't work. Let us know.


                    The RoboColum(n)   @robocolumn   Colum McAndrew
                  • 6. Re: Issues with Calling WebHelp Pro
                    MeWrite Level 1

                    Colum -- sorry other priorities bumped this down in the list.  So, just to clarify, instead of a mergedProject, you're suggesting that I ditch the Parent Project since it has no topics.  Take the main project (aka now the new Parent Project) and add the children TOC to this project.  The Main project would have the windows defined then publish the main project to the RH server with auto merge on.


                    In theory after all 3 projects are published to the area the help toc would automerge with the correct skin.


                    FYI – I believe that is how we started, but I will double check.  The problem with this output is that the skin showed correctly, but the TOC did not.  Child 2 is a TOC of baggage links to PDF files.  Once Child 2 was published the Main Project TOC hid (randomly) books and topics, as well as moved some books under another book.  Near as I can tell when I look at the code, there are no end tags for the TOC so it is getting confused on when to start and stop a book and it’s topics.


                    We also tried Rick’s suggestion of making topics that redirected to the PDFs for the TOC, however, the page never redirected, it would just spin around and around. 


                    Interesting note:  This does not happen when we output to FlashHelp Pro.  The skin and TOC work as defined in the project.  So I’m confused as to how the FlashHelp Pro can merge correctly, but the WebHelp Pro cannot.

                    • 7. Re: Issues with Calling WebHelp Pro
                      MeWrite Level 1

                      April 4 test:


                      1.       Created a new area on the RH Server in WebHelp Pro layout (Apr4Test)

                      2.       Created a New TOC in the Main project (TestLO).

                      3.       Added a merged TOC (TrainingManuals).

                      4.       Generated Main Project and published to Apr4Test area with Auto Merge projects of same type checked.

                      5.       Launched help:

                      a.       URL:  http://{IPADDRESS}/robohelp/robo/server/Apr4Test/projects/HelpTest/helptest.htm

                      b.       Skin results:  Shows all buttons even though the window is defined without Reports, Web Search, and Index.



                      c.       TOC results: Correct.





                      6.       Removed the Merged Help TrainingManual TOC from the Main Project.

                      7.       Republished Main Help.

                      8.       Launched help:

                      a.       URL:  http://{IPADDRESS}/robohelp/robo/server/Apr4Test/projects/HelpTest/helptest.htm

                      b.       Skin results:  Shows all buttons even though the window is defined without Reports, Web Search, and Index.

                      c.       TOC results: Correct.


                      9.       Supposition based off 1-8:  Calling the help with this path negates any windows definition.

                      10.   Opened RH Admin.

                      11.   Selected Apr4Test area.

                      12.   Selected the project.

                      13.   Clicked View Project.

                      14.   The Help opened via this URL:

                      http://nn.nn.nn.nn:8080/robohelp/server?%26area%3DApr4Test%26mgr%3Dagm%26agt%3Dwsm%26wnd%3 DCitizensOnlineLibraryTest%7CCitizensHelp%26tpc%3D%2Frobohelp%2Frobo%2Fserver%2FApr4Test%2 Fprojects%2FCitizensOnlineLibraryTest%2FIntroduction%2FEmpower_Online_Help_Overview.htm%3F RINoLog28301%3DT%26ctxid%3D%26project%3DCitizensOnlineLibraryTest

                      a.       Skin results:  Displays as defined in the correct window (no index button, no web search).



                      b.       TOC results: Incorrect.  When a book is clicked it opens the topic above it.  The TrainingManual toc is not included.  Apparently, the last book in the TOC is a baggage folder linked to a PDF.




                      15.   Supposition based off 9-14: Despite the long URL it calls the window correctly, but the when the TOC has links to a baggage file instead of a Topic it breaks the TOC.  In fact it even moves a main book under another book.

                      • 8. Re: Issues with Calling WebHelp Pro
                        RoboColum(n) Level 5

                        Personally I still keep the mergedProjects structure even though technically it is not required if you have the automatic merge area option set. So keep the parent project and the various children and publish in the same way as you would for WebHelp output.


                          The RoboColum(n)   @robocolumn   Colum McAndrew
                        • 9. Re: Issues with Calling WebHelp Pro
                          MeWrite Level 1

                          It doesn't matter if we use mergedProjects or not, with or without auto merge set in the admin.  We found only 2 paths that work, both described in the previous reply.  The short path does not give us the correct skin and the long path does not give us the correct TOC.  We are at an impasse.


                          I tried using a different web site per role, however, WebHelp Pro does not allow us to specify the folder to publish it.  It publishes only to the main server and to the areas defined in that server.  Since the ipaddress is the same, there is no logical way to publish to another web site on tomcat.  (i.e., http:{IPADDRESS}/role/contextarea).


                          We cannot use ftp as this is a security issue so that option is closed for us.


                          I tried the command line, but that option returns rhcl is not a recognized command or the project path is not valid.


                          I don't see any other options and have to admit this is the 1st time RH has truly stumped me.  Usually I can find a work around, but if I'm limited to the 2 urls then this is a very big problem.


                          I'm going to test the WebHelp option to see if we have the same window issue since I can publish via the file system option, but that is not really a solution since my client wanted Pro so we can run reports and see where training needed to train and complete gaps for issues that were recurring.  Not to mention publishing via the file system takes a significantly longer amount of time.


                          Thanks for your help Colum, I appreciate it.  Just seems like I'm at a stalemate here.




                          • 10. Re: Issues with Calling WebHelp Pro
                            Jeff_Coatsworth Adobe Community Professional & MVP

                            Not quite sure why you think FTP is a security issue since that's exactly what RH is doing in the background when it publishes to a web server.

                            • 11. Re: Issues with Calling WebHelp Pro
                              MeWrite Level 1

                              Jeff -- LOL, I didn't say I thought it was a security issue.  I said the IT deparment thinks it's a security issue.  Something about the port and when I suggested just changing the port # they said that took software they would need to purchase or something to that effect.  I'm not sure how FTP ports work, I personally use CUTEFTP and have never has any issues with it.  But that's over my head.  I'm just trying to find a solution since WebHelp Pro won't allow me to point to a specific path on the server.



                              • 12. Re: Issues with Calling WebHelp Pro
                                Jeff_Coatsworth Adobe Community Professional & MVP

                                I hope you explained to them that RH has a tiny FTP client already working inside of it? The same port and credentials you provide to the WebHelp Pro SSL would be the same used in any freebie FTP client (Filezilla, CuteFTP, etc.), so you already have a "security issue" currently (LOL)!

                                • 13. Re: Issues with Calling WebHelp Pro
                                  MeWrite Level 1

                                  So I took the test down to the bare basics and it's still not displaying the skin correctly.  I created a new area called Unmerged.  I published 1 WebHelp Pro project.  I assigned a window called WebHelp Basic.  I turned off the Index and the Web Search in the WebHelp Basic window.  I published the help to the new area (UnMerged).  I lauched the help:  {ipaddress}\robohelp\robo\server\UnMerged\projects\UnMergedEmpower\maintopic.htm


                                  The skin displays all the buttons including the Index and Web Search.  Nothing I do to the window displays only the selected buttons.  It's like it's stuck in default window mode.


                                  Does anyone know how I can call the window correctly for RH 8?  Or does the RH Sever have something to do with it calling all button options instead of the selected ones?




                                  • 14. Re: Issues with Calling WebHelp Pro
                                    MeWrite Level 1

                                    We found a thread in 2006 that stated the WebHelp Pro didn't allow for the buttons on the skins to be turned on or off.  Is this still the case?  Does turning the buttons on an off in the Windows Property not change the WebHelp Pro skin?  I noticed that even after I label my window it does not pull in that caption either.  It seems like other than taking on the color of the skin WebHelp Pro does not allow for any changes using the Windows screen.




                                    • 15. Re: Issues with Calling WebHelp Pro

                                      Hi CJ -

                                      The last part of this thread posted on May 4th is the exact same problem I am having with WebHelp Pro.  I removed buttons in the New Window then created another custom window and it continues to point to the default window setting with all buttons displayed.  It works for the WebHelp output but not Pro and like your customer, we want to track usage and reporting with Robohelp Server.  Any insight on whether this is still a problem would be helpful as Robohelp Server analytics was a big deal for us with our training and support groups.