3 Replies Latest reply on Mar 21, 2011 3:01 PM by MorroNZ

    Workbench error "Unable to access UserTransaction in DataService"

    MorroNZ Level 1

      Hi

       

      Basically, if I remote onto the server and run the locally installed version of the workbench everything works fine.  But, if I use my locally installed client then all looks good after signing into the server but then errors start occurring in the error log etc.

       

      [FaultEvent fault=[RPC Fault faultString="Unable to access UserTransaction in DataService." faultCode="Server.Processing" faultDetail="null"] messageId="32C07437-850C-057F-1900-4AB18886AC9E" type="fault" bubbles=false cancelable=true eventPhase=2]

       

      These errors occur when opening a Guide - end up with a blank screen.  When opening a PDF solution all seems ok.

       

      If I then try to open it again (doesn't seem to matter how long I wait) I get the following error:

       

      [FaultEvent fault=[RPC Fault faultString="Attempt to begin a DataServiceTransaction when an existing transaction was already in place." faultCode="Server.Processing" faultDetail="null"] messageId="32D7E1C7-7F0A-6A9C-D006-E5AAE3BD2513" type="fault" bubbles=false cancelable=true eventPhase=2]

       

      I've taken a look in theb JBoss server.log file and nothing shows up there

       

      Anyone got any ideas?

       

      Environment:

       

      Client: Windows XP SP3 running 9.5 of the Workbench

      Server: Windows Server 2008 running latest turnkey release incl. SP2 etc

        • 1. Re: Workbench error "Unable to access UserTransaction in DataService"
          gareth_faulkner Level 1

          Update....

          This error is occuring when previewing a guide from Workbench.  Opening the guide builder is working fine.

          Also, if the user logs onto XP as an admin, then the error does not occur when previewing.

           

          Suggestion....

           

          Can you ensure you have checked in any apps. Then I would shutdown workbench *move* all the contents of this directory [C:/Documents and Settings/All Users/Workbench ES2/logs/atomikos/transaction_info] out (they should work as temp files) and restart workbench. It should start as a virgin environment as far as the process designer and LCDS are concerned.

          1 person found this helpful
          • 2. Re: Workbench error "Unable to access UserTransaction in DataService"
            Ernest Ruppenthal Level 1

            When you open the guide inside Guide Builder, does the status bar indicate that anything is happening?  It should indicate that the data model is being compiled.

             

            One thing you can try is to

            1. Close Workbench

            2. Rename or move C:\Documents and Settings\username\Application Data\Adobe\LiveCycle\ES2\Guides

            3. Restart Workbench and open the guide.

             

            Ernest

            1 person found this helpful
            • 3. Re: Workbench error "Unable to access UserTransaction in DataService"
              MorroNZ Level 1

              Ok - tried all the suggestions - now I get actually get an error when opening the guide.

               

              Says it can't compile the model so won't open the guide.

               

              When I run with local administrator account the guides work - so must be more authorities needed.

               

              I have tried to change the access rights in all places I can find anything to do with LiveCycle to full access.

               

              C:\program files\Workbench ES2

              Note: Not sure why the workspace is there

               

              c:\document and settings\admnmz144\adobe\*

              c:\document and settings\nmz144\adobe\*

               

              etc

               

               

              Here's the error I get regards the failed to compile model:

               

              Error compiling the data model: C:\Program Files\Workbench ES2\t0449914\NZPolice\1.0\Data\IncidentData.fml java.lang.NullPointerException : null