0 Replies Latest reply on Mar 18, 2011 8:34 AM by i_bullock

    Burrito DataService Problem

    i_bullock

      Hi all,

       

      Hopefully some of you know a thing or two about Burrito and can help me out with a strange issue I'm having.

       

      I've connected a few PHP dataservices to my app and have been using them without problem.

       

      Today I auto-generated one to interact with a another different table "tbl_locations".

       

      The service has no problem getting all records from the table, but the delete and add events don't do anything.

       

      When I run a test operation they run fine, but when calling them from the app they just don't do anything.

       

      I get no fault events, or result events for either call.

       

       

      The strangest thing is that if I run the delete event, then run "getAll" again, it seems like the record is deleted.

       

      But when I look at the database it's still there! And if I close the app, then run it again it seems to show all the records again too.

       

       

       

      Anyone know what's going on here? I've checked the PHP and it all seems ok to me. Maybe tbl_locations or some other valure I'm using is reserved?

       

      Any help is greatly appreciated!