0 Replies Latest reply on Mar 21, 2011 10:50 PM by moncul7

    OOM error using FB 4

    moncul7 Level 1

      Hi, getting OOM error when doing a build of a project using

      flash builder 4 standalone (on windows 7, 64bit).

       

      I've tried all manner of increasing the heap size. Below is the stack trace from the log file (in .metadata/.log). One thing i did notice is the java.version. This jre is not one i have installed, so it must be the one which is installed with the product (in FLEX_HOME/jre). Now, how does one control the vmargs for this invocation? I tried messing with FlashBuilder.ini, as well as jvm.config in the sdks directories; to no avail.

       

       

      !SESSION 2011-03-21 18:20:55.867 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.6.0_16
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments:  -os win32 -ws win32 -arch x86

       

      !ENTRY org.eclipse.core.jobs 4 2 2011-03-21 18:34:47.120
      !MESSAGE An internal error occurred during: "Building workspace".
      !STACK 0
      java.lang.OutOfMemoryError: Java heap space
          at flash.swf.TagDecoder.decodeDefineBitsLossless2(TagDecoder.java:1199)
          at flash.swf.TagDecoder.decodeTag(TagDecoder.java:301)
          at flash.swf.TagDecoder.decodeTags(TagDecoder.java:179)
          at flash.swf.TagDecoder.parse(TagDecoder.java:127)
          at flex2.compiler.swc.SwcLibrary.parse(SwcLibrary.java:157)
          at flex2.compiler.swc.SwcScript.getDoABC(SwcScript.java:60)
          at flex2.compiler.swc.SwcGroup.updateMaps(SwcGroup.java:273)
          at flex2.compiler.swc.SwcGroup.<init>(SwcGroup.java:52)