2 Replies Latest reply on Mar 24, 2011 7:45 AM by sogique

    Winhelp 4, problem compiling

    sogique

      Hy everyone,

       

      I try to investigate on a problem that  one of our user have with Robohelp 8. I don't know if i'm giving the  right information about my problem, so let me know if you need any other  information. The computer is a Windows XP SP3 with 2 Gb of RAM.

       

      Robohelp 8

      Winhelp 4

      Language: FR

      Message:

      Winhelp compiling problem.jpg

      Sorry but i can only have the message in french. Here is the traduction:

      Result: Winhelp generation failed

      Layout: WinHelp 4

      Launching of the compilation

      Preprocessor winhelp 8.0.0.203

      Compilation of.....

      Preparation of creation Winhelp...

      Clearing the output folder...

      Conditional text filtering...

      Treatment of RSIPA V.rtf...

       

       

      I  got this message when I try to "compile" my .doc file. The long line  starting with W:\02 - Biens..... is only the emplacement of the file in  the network. I tried locally on the computer (i copy the folder  completely, then open it as usual. The only difference is that it's  faster to open this way). I also climbed the memory of the computer to 2  GB just in case. I also tried to delete the .rtf files, and remake it,  but its the same. Another interesting thing, is that the user have  sucessfully compile the file in the past (like 6-7 days ago). But he  probably did a bad manipulation, and now it doesn't work anymore... I also made a new blank project, create 2-3 things on it, save it and  compile it, and it worked (so i assume the software is correctly  installed).

       

      My question are:

       

      Is there any log files that can bring me more information of why the compilation didn't work?

      Is the reinstallation of the software can resolve (for this time) the problem?

      Is  there anyway to restart, if i can say this, the project, but keeping  only the doc file? (the project is about 150 pages, so if its possible  to not restart it all over...)

       

      Thanks if anyone can bring me some tips/help, and if i'm not clear, say it (i'm just a poor french guy ^^ )

       

       

      Jimmy

       

       

       

       

        • 1. Re: Winhelp 4, problem compiling
          RoboColum(n) Level 5

          Hi Jimmy.

           

          I'd be tempted to find a backup of the help file before any of the recent changes were made (i.e. after the last successful compile) and see if that compiles correctly. If it does, you know that something in the project is at fault. What I'd then do is gradually add content compiling as you go until you hit the problem. I doubt whether text would be the cause. Much more likely would be an image or some other interactive element (e.g. image map).


            The RoboColum(n)   @robocolumn   Colum McAndrew
          • 2. Re: Winhelp 4, problem compiling
            sogique Level 1

            Hi,

             

            Thank you for your answer. We tried to restore the file the days it started to not compiled, but it makes no change. But I did not try to recover one a couple of days before the incident.

             

            Finally, the user found a workaround. She just started a new project, create her heading and she was able to copy the content of her old file into the new one. She saved it and the compilation worked perfectly!

             

            So for now, i'll just hope it will not happen again

             

            Thanks you for your help!

             

            Jimmy