5 Replies Latest reply on Jun 8, 2012 11:13 AM by cepharum

    PHP Server in Windows 7 Home x64

    cepharum

      Hi,

       

      though I found some related posts on google and obeyed solutions given there I'm still stuck with starting PHP-server-based Flex project in Flash Builder 4 on Windows 7 x64 host.

       

      I'm using VM for linux-based local web server. There is a folder in host's filesystem to be shared with VM. That folder is mapped document root of Apache server inside VM. I've tested this mapping by trying to write HTML file into folder and requesting in browser using HTTP to service in VM.

       

      I'm used to work as a normal user with Flash Builder installed in usual location for programs "C:\Program Files (x86)", thus I had to grant administrative access to installer before. I successfully tried to use a separate editor application installed that same way for writing into host folder shared with VM. In addition I extended permissions of Users group on shared folder's node as described in related posts I found on google. After that I checked to have those permissions implicitly derived by existing descendants in folder.

       

      Nevertheless Flash Builder keeps complaining about web root and root url being invalid. The path has been selected using file browser, thus typos can be excluded. The URL has been copy'n'pasted several times from Flash Builder to browser for double-checking, as well.

       

      Help on that issue is appreciated.

       

      Best Regards.

        • 1. Re: PHP Server in Windows 7 Home x64
          SujitG Level 2

          Hi,

           

          Can you please make sure the web root and root URL are pointing to the web server root and not the web application root. For example:

           

          Web Root: c:\apacheserver\htdocs

          Root URL: http://localhost

           

          Hope this helps.

          • 2. Re: PHP Server in Windows 7 Home x64
            cepharum Level 1

            Thanks for the response,

             

            I tried that as well of course as it was mentioned in other threads I found on the net before. But it doesn't change anything. Aren't there any logfiles or similar in Eclipse useful for debugging this problem. How do I find out why on earth that project creation wizard is considering my setup to be wrong?

             

            Basically the whole problem is ridicilous. There is an app that can't write to a folder the user running that app is actually permitted to write into. And even if it's capable to write there is something considered mismatching though any other application is proving that selected folder and used URL both pointing to the same set of files. According to the posts related to this topic there seems to be no insight by anyone in what's going on in there.

             

            I don't like Eclipse as it is an inconvenient monster (e.g. making it impossible to create a new simple text file for editing just to test writing into some folder without requiring me to start a full project first). And, again paying for some app that's built upon Eclipse has proven to be an expensive sort of Open Source software, that's neither working in any way. That's true for Flash Builder as it is for Zend Studio or similar tools. So, I consider paid money wasted ... thanks Adobe.

             

            Well, I keep on preferring the all-free opportunity of using Netbeans to code in HTML5, CSS3 transitions, jQuery or mooTools over any Flex/Flash stuff ... R in RAD is for rapid, but struggling with the RAD IDE just to have it running on a quite common operating system makes me doubting that R in RAD. Wasted money, wasted time ...

            • 3. Re: PHP Server in Windows 7 Home x64
              cepharum Level 1

              Maybe this problem is fixed in 4.0.1, but what a fun, I can't upgrade ... man, is there anyone doing QA at Adobe?

               

              Dropped any AAMUpdater folder, tried AAM and it tells me that everything is uptodate. However, Flashbuilder info screen says it's "4.0 (Build 272416)" ...

              • 4. Re: PHP Server in Windows 7 Home x64
                Ether-x Level 1

                Did you managed to solve your problem ?

                 

                I am having same problem under Win7 (64) with Flash Builder 4.6 on a VM shared folder.

                 

                I am pointing on a VirtualHost if that's help.

                 

                Any help is appreciated.

                • 5. Re: PHP Server in Windows 7 Home x64
                  cepharum Level 1

                  Haven't tried again since then. This software was too frustrating to keep on using it. And there wasn't any opportunity requiring me to use it for something essential.