8 Replies Latest reply on Apr 14, 2008 10:56 AM by maniac9999

    Help Contents gives Script error

    RSingletary
      I have Robohelp for HTML installed and when I go to Help/Contents I get a script error and the contents does not display. I have the most recent version of JAVA installed. Robohelp for Word and Starter Help/Contents work and display fine. I have IE6 SP2 and run out of ideas.
        • 1. Re: Help Contents gives Script error
          Brian.Mccaffery Level 1
          Hello RSingletary

          Welcome to the forums.

          I am afraid that we need a bit more info to go on. Could you give us the details of the script error?

          Brian
          • 2. Re: Help Contents gives Script error
            Birgit1020
            Thats my problem too.

            I use RoboHelp 6 Build 099 (german version).

            These 2 errors occure:

            'gaProj[...]s PPath' is null or not an object
            Code: 0
            URL: file://D:\Studio\html\whskin_pdhtml.htm

            and then

            Access denies
            Code: 0
            URL: file://D:\Studio\html\whskin_pdhtml.htm

            I got these errors on different browsers e.g. IE 6, IE 5

            Is it possible that the security settings are wrong or anything like this?

            Formerly the project was a Robohelp 5 project. And we didn't have any problems. Is there a bug in V6?

            Birgit
            • 3. Re: Help Contents gives Script error
              Birgit1020 Level 1
              Isn't there anybody who can help me?

              Birgit
              • 4. Re: Help Contents gives Script error
                RoboWizard Level 4
                Hi Birgit

                Is this for RoboHelp's own Help? If so, try clicking Tools * Options * General tab and enabling the 'Use Offline Help' check box. Then close and restart RoboHelp.

                Cheers... Rick
                • 5. Re: Help Contents gives Script error
                  Ben Minson Level 2
                  Birgit,

                  See if switching from online to offline help changes anything, if you're not already using offline help. In RH, go to Tools > Options > General tab, and click the Use Offline Help checkbox. I don't know if this is related, but it's worth a shot. (I used RH7 to get these steps, but they should be similar or the same to RH6.) Let us know how it goes.

                  --Ben
                  • 6. Re: Help Contents gives Script error
                    Ben Minson Level 2
                    Is there an echo in here?
                    • 7. Re: Help Contents gives Script error
                      jb1962
                      When I go to the Robohelp HTML help contents (Contents and Index) I get an Internet Explorer script error message "Automation server can't create object", and then the message "do you want to contiunue running scripts on this page?"

                      I am using IE 7 and Robohelp 6. It was working fine before.

                      Anyone have an answer for this.
                      • 8. Re: Help Contents gives Script error
                        maniac9999 Level 1
                        We had a similar situation. We installed our RH X5 a few years ago, then within the last several months, every author (except me) couldn't see the Contents pane at all on their local machine or if they were viewing the output only (outside of the project) on one of our network drives. They also saw the "whskin_pdhtml.htm" error also whenever they tried to access the skin editor.

                        I suspected, but was never able to prove, that the issue was related to how IE interpreted Javascript and/or various add-ons based on a user's permissions. I even tried to find out if a recent Microsoft security patch was the culprit, but still couldn't be 100% sure.

                        Our solution was to uninstall RH X5, get local box admin rights granted permanently to the user of the PC, then reinstall RoboHelp X5. We've done three of these in the last two weeks and no one has had an issue since. We've found that having local box admin rights granted to the user permanently rather than temporarily seems to work.

                        Look for an Adobe Knowledge Base article on Uninstalling RoboHelp. I would include the link to it here, but the Knowledge Base search feature seems to be on the fritz today. I copied the uninstall info into a Word doc a while back and I have it on file if you need it. Let me know - my email is jreinhard@paychex.com.

                        Jim