0 Replies Latest reply on Jun 11, 2007 3:49 PM by krcain

    Null pointer exception when using CFCs on Solaris

    krcain
      I am running Apache 2.0.52 and my web root is /htdocs. I have a multi-server installation of CF 7.0.2 on another partition: /apps/jrun4. Regular CFM files work fine; however, I receive the "The system has attempted to use an undefined value..." (null pointer) error whenever I attempt to use a CFC from within a CFM file or if I try to use Application.cfc -- Application.cfm works fine.

      For instance...I created two files in /htdocs/test: Test.cfc and tester.cfm

      Test.cfc contains:

      <cfcomponent>
      <cfset str = "Test">
      </cfcomponent>

      tester.cfm contains:

      <cfset temp = createObject("component", "Test")>

      When I run tester.cfm I get the error. I had some success when I created a mapping in CF Admin called /tester, pointing to /htdocs/test. I then changed the code in tester.cfm to:

      <cfset temp = createObject("component", "tester.Test")>

      And it worked! I also tried creating a CFC on the same partition as the CF install (/apps) and then referencing it in the tester.cfm code. That works too! However, that's a bandaid solution and half of one at that. If I try to use Application.cfc anywhere within /htdocs (web root), I get the null pointer error.

      Additionally, I have another server setup identically except for one difference: the web root is /apps/htdocs (same partition as CF). Everything works fine on it. Has anyone experienced this behavior before? Any ideas besides moving /htdocs to /apps/htdocs? Is this a known issue that the web root must reside on the same partition as the CF install?