2 Replies Latest reply on Mar 26, 2011 12:40 PM by DJ Gecko

    Help with a possibly corrupted FLA file

    DJ Gecko Level 1

      I have a FLA file that when I open it and I rollover any title in a pallette window all the text in that and every window dispapears.  For instance the title "Timeline" will vanish.  And most of the text in the pallette vanishes, for instance all the text in the properties pannel disapears like "Position and Size".

       

      This does not occur with any of my many other FLA files.  I have had some issues with fonts lately.  After deleting some bad fonts, my FLA ask me to remap some fonts, which I do.  Everything in the FLA appears to be working find.

       

      any ideas?

       

      Thanks!

        • 1. Re: Help with a possibly corrupted FLA file
          *Q Level 3

          Have you tried rebooting your machine? Some times a reboot would help after deleting bad fonts. If it doesn't help, please let us know which platform (mac or window) and which Flash version you're running.

          • 2. Re: Help with a possibly corrupted FLA file
            DJ Gecko Level 1

            Hi,

             

            I'm on a Mac (OS X 10.6.7) and using Flash pro CS5 (and Flash Builder).  I started to get a warning in Flash about jagged fonts.  I used Mac's font book to validate and clean up my fonts.  After that, whenever I open this one FLA, it ask me to map some fonts, which I did, then it opens.  After opening, the Flash IDE becomes unusable, most of the text in the palletes disapear and I can not tell what most things are.  I also tried setting the fonts to defaults, same issue, although that did fix the issued for half day, it's now not working, and often crashes when I just click on a text field. I started my Mac up in safe mode, the FLA does work fine in Safe Mode, but I can't remap the fonts 'cause all none system fonts are dissabled in safe mode.

             

            I was getting a lot of crashes when trying to use Mac's Font Book.  After validating fonts, opting to remove bad fonts would crash font book.  It took about two hours to clean up my fonts.  At least I think they are good now...

             

            I think I'm going to go through every text field in the FLA in safe mode and change them to a system font (and write down what font I wanted the text field to be), then restart the Mac in normal mode and see if I can remap the fonts in the Fla.  Unfortunetly this Fla is huge with many text fields : (