2 Replies Latest reply on Jun 19, 2007 4:53 AM by DeadMansFriend

    XML video playlist

    DeadMansFriend
      HI,

      I'm trying to make an XML video playlist and I'm getting the following error:

      1000: Unable to make connection to server or to find FLV on server

      The XML file, swf and videos are all in the same directory and I've checked the names to make sure.

      The swf is reading the XML file fine, the descriptions from the file are showing up in the list box which is named "videoList"

      here's the code:

      var vlist:XML = new XML();
      vlist.ignoreWhite = true;

      vlist.onLoad = function() {
      var videos:Array = this.firstChild.childNodes;
      for(i=0;i<videos.length;i++) {
      videoList.addItem(videos .attributes.desc,videos.attributes.url);
      }

      ns.play(videoList.getItemAt(0).data);
      videoList.selectedIndex = 0;
      }

      var vidList:Object = new Object();

      vidList.change = function () {
      ns.play(videoList.getItemAt (videoList.selectedIndex).data);
      }

      videoList.addEventListener("change",vidList);

      vlist.load("videos.xml");


      Here's the XML:

      <?xml version="1.0" encoding="iso-8859-1"?>
      <videos>
      <video url="video1.flv" desc="Background to the Standards"/>
      <video url="video2.flv" desc="The Role of the Standards"/>
      <video url="video3.flv" desc="The Information and Advice Process"/>
      </videos>

      Hope someone can help, probably a school boy error.

      Cheers,
      Malcolm
        • 1. Re: XML video playlist
          shovavnik
          I have the same error.

          I've used the Video and FLVPlayer controls and both produce this error.

          I've tried assigning the path to the video in code, in the "source" parameter, and using a SMIL file.

          I've verified that the file is indeed in the proper location on the server. I've also made sure the spelling and letter-casing is identical in all places, just in case.

          I've tried assigning relative paths (always in the same folder as the swf file) as well as absolute paths.

          I've tried adding the video/x-flv mime type to the server (it's a shared hosting server).

          In all cases, it works locally but never works when uploaded to the server.

          I've even tried setting the "Local access security" to "Access local files only" as well as "Access network only."

          Here is the stack trace I receive when loading the html file published by Flash and also when simply accessing the swf file directly.

          VideoError: 1000: Unable to make connection to server or to find FLV on server
          at fl.video::VideoPlayer/play()
          at fl.video::FLVPlayback/ http://www.adobe.com/2007/flash/flvplayback/internal::showFirstStream()
          at fl.video::FLVPlayback/ http://www.adobe.com/2007/flash/flvplayback/internal::handleVideoEvent()
          at flash.events::EventDispatcher/flash.events:EventDispatcher::dispatchEventFunction()
          at flash.events::EventDispatcher/dispatchEvent()
          at fl.video::VideoPlayer/ http://www.adobe.com/2007/flash/flvplayback/internal::setState()
          at fl.video::VideoPlayer/ncConnected()
          at fl.video::NCManager/helperDone()
          at fl.video::SMILManager/ http://www.adobe.com/2007/flash/flvplayback/internal::xmlLoadEventHandler()
          at flash.events::EventDispatcher/flash.events:EventDispatcher::dispatchEventFunction()
          at flash.events::EventDispatcher/dispatchEvent()
          at flash.net::URLLoader/flash.net:URLLoader::redirectEvent()
          • 2. Re: XML video playlist
            DeadMansFriend Level 1
            Still not having any luck with this.

            I have made sure the files are in the right place on my hard drive and have even tried putting the URL of an online flv file in my XML file.

            I can't get it to play anything.

            Please help