1 Reply Latest reply on Jun 14, 2007 10:09 AM by damartman

    Errors Installing on Windows Vista

    damartman
      It looked like Flex Builder 3 installed correctly on my new Windows Vista machine, but then I go to run the program (Adobe Flex Builder 3) as an administrator, see the black splash screen come up, but then receive the following message:

      ---------

      FlexBuilder [title]

      An error has occurred. See the log file
      C:\Users\My User Name\My Documents\Flex Builder Moxie\.metadata\.log

      ---------


      Then in that log file, (very full of errors), the top-most lines are the following:

      ---------

      !SESSION 2007-06-14 02:43:27.779 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.5.0_11
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.update.configurator 2007-06-14 02:43:28.901
      !MESSAGE Cannot backup current configuration

      !ENTRY org.eclipse.update.configurator 2007-06-14 02:43:28.975
      !MESSAGE Could not rename configuration temp file

      !ENTRY org.eclipse.osgi 4 0 2007-06-14 02:43:32.160
      !MESSAGE Application error
      !STACK 1
      java.lang.UnsatisfiedLinkError: no swt-win32-3235 in java.library.path
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.loadLibrary0(Unknown Source)
      at java.lang.System.loadLibrary(Unknown Source)
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
      at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
      at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
      at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:433)
      at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
      at com.adobe.flexbuilder.standalone.FlexBuilderApplication.run(FlexBuilderApplication.java:4 5)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:92)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:68)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
      at org.eclipse.core.launcher.Main.run(Main.java:977)
      at org.eclipse.core.launcher.Main.main(Main.java:952)

      ---------


      Might this have something to do with Windows Vista's file security that makes you authorize every little file manipulation or directory change? I'm just basing this theory on the first 2 errors in the log file:
      1 - !MESSAGE Cannot backup current configuration
      2 - !MESSAGE Could not rename configuration temp file

      Thanks! Can't wait to get it working.
      - Marty McGee