2 Replies Latest reply on Apr 4, 2011 5:30 PM by EGinM

    Error message after replacing file BaseLibrary.dll

    EGinM Level 1

      I'm using RoboHelp 8 and I've just downloaded the file BaseLibrary.dll to fix the problem of jpeg files not displaying (see http://kb2.adobe.com/cps/859/cpsid_85901.html).

       

      When I restarted RoboHelp the following message displayed:

       

      "Unable to open the file C:\Documents and Settings\[my name]\My Documents\[my project name]\$rhvariable$.htm. Out of memory starting the editor services."

       

      When I clicked OK in the message my project opened and it seemed to be working OK (compiled OK etc.). I then closed the project, renamed the new .dll file, reverted to the old .dll file and re-opened my RoboHelp project. No message displayed.

       

      I checked another of my projects. Same result. The message displays when the new .dll file is used; doesn't display when the old .dll file is used.

      Only one of my two projects actually has the file $rhvariable$.htm in it, and I've read elsewhere on this forum that the file can be deleted if you want to.

       

      My questions are:

      • Why is the message displaying?
      • Does it indictate a real problem?
      • Would I be better off reverting to the old .dll file?  (I guess I can cope with the occasional problem jpeg file.)

       

      Thanks,

      E.

        • 1. Re: Error message after replacing file BaseLibrary.dll
          annimi

          Did you save the download to your installation file? Also, I realize this may be an obvious question but did you close RoboHelp before downloading the .dll file?

           

          If you answered yes to the above questions then have you tried to register the .dll file?

           

          Go to Start > Run and enter regsvr32 BaseLibrary.dll

           

          To unregister enter regsvr32.exe /u BaseLibrary.dll

          Good luck!

          • 2. Re: Error message after replacing file BaseLibrary.dll
            EGinM Level 1

            Thanks for your feedback.

             

            I had put the new .dll file in the same folder as the old dll file, without

            RoboHelp being open at the time.

             

            I've now tried registering the dll using the following command:

            regsvr32 "C:\Program Files\Adobe\Adobe RoboHelp 8\RoboHTML\BaseLibrary.dll"

            and I got the following message:

            'LoadLibrary("C:\Program Files\Adobe\Adobe RoboHelp

            8\RoboHTML\BaseLibrary.dll") failed - This application has failed to start

            because the application configuration is incorrect. Reinstalling the

            application may fix this problem.'

             

            So no luck there. I think I'll give up and revert to the old dll file!