12 Replies Latest reply on May 18, 2011 9:27 PM by CF-AXL

    '/mt/.rdsTempFiles/RDS Query Viewer' does not exist

    mecase

      Hi,

       

      I'm returning to ColdFusion after a long break.  I used  <>  and am at the point where I'm looking at the artistscfcs stuff.  When I click on the RDS Query Viewer I get:

       

      Resource '/mg/.rdsTempFiles/RDS Query Viewer' does not exist.

       

      I have tested the RDS connection and it says it is fine.

       

      Can someone suggest something that I'm missing?  Should I re-install?

       

      This is on a Windows Vista machine that might have (pretty sure) a web service set up for my wife's user account.  I did not get anything out of the ordinary related to the web page mentioned above during install.  However, the first time I ran ColdFusion Builder beta I could not create .project files and after some searching, I now run ColdFusion Builder as administrator.

       

      I could move to my mac laptop but would like to understand this problem anyway.

       

      Thanks for your help.

        • 1. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
          mecase Level 1

          oops... forgot <> is : http://www.adobe.com/devnet/coldfusion/articles/setup_dev.html

          that is the page I am working through.

          thanks again.

          • 2. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
            charlie@carehart.org Adobe Community Professional & MVP

            You're using the new CFBuilder beta on labs, right? This functionality is known (by Adobe) to be currently broken. I'm sure it will be fixed in any next build.

             

            /charlie

            • 3. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
              PegasusT4

              I occasionally run into this too. What has sometimes worked for me is to rename the project, so if the name is "My Project", change it to "mypoject". On one computer that works, but on my laptop not so much. Just try different names for the project and see if you can get it working.

               

              Doug

              • 4. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
                DFBurns Level 1

                FWIW, I upgraded to the official release of CFB2 yesterday and still hit this. My steps:

                 

                - Go to RDS Dataview

                - Drill down to a table in one of the data sources.

                - Right click on a table and choose 'Show Table Contents'

                - The RDS Query Viewer opens up in a new tab but it contains the error message you describe. Slightly different for me though: change /mt to the name of my current project: /blah/.rdsTmpFiles/RDS Query Viewer.

                 

                I didn't see this listed in the known issues in the release notes. I want to verify that others still see this before I file a bug report.

                 

                db

                • 5. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
                  Kiran Sakhare

                  Hi

                   

                  Try this steps, may help in resolving..

                   

                  1. Restart the builder

                  2. Have atleast one project in navigator/project explorer or have one file opened from project in editor

                  3. Now browse through RDS and open query viewer.

                  4. This should open Query viewer.

                  5. If not delete .rdsTmpFiles folder from all projects then repeat steps 1 to 4

                   

                  Hope this solves the problem

                   

                  Thanks

                  Kiran Sakhare

                  • 6. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
                    DFBurns Level 1

                    Kiran -

                     

                    Tried 1-4 with same results. Tried 5 and then 1-4 again with same results.

                     

                    If it helps:

                    - I never had the beta installed. I did an upgrade from CFB1 to CFB2. The Query Viewer was working in CFB1.

                    - Some directories and files are created after those steps (if CFB1 did this, I never saw it happen):

                     

                    Before the test, all I have is:

                     

                    /trunk/ (plus of course my entire source tree within it)

                     

                    After the test, I see these additions:

                     

                    /trunk/.rdsTempFiles/

                    /<newDirWithMyProjectName>/

                    /<newDirWithMyProjectName>/.rdsTempFiles/

                    /<newDirWithMyProjectName>/.rdsTempFiles/RDS Query Viewer (0 byte file)

                     

                    The 'trunk' directory is my project root dir.

                     

                    Thanks.

                    • 7. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
                      Kiran Sakhare Level 1

                      Hi

                       

                      Try using the new workspace and create sample project. I doubt some issue with workspace or permission.

                       

                      Thanks

                      Kiran Sakhare

                      • 8. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
                        DFBurns Level 1

                        With a brand new workspace and project defined, things work as expected. What does this mean though: is there some way to salvage my existing environment and settings from CFB1 or do I have to recreate everything for CFB2? Pretty painful if the latter.

                        • 9. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
                          CF-AXL Level 1

                          I had the same problem, but I found a way to solve it.
                          Check the project name in the "Navigator" and the folder name in the project location.
                          It seems that these need to be matched.

                           

                          For example, if you have a project called "MyProject" in the "Navigator" and all of the project files are in the folder named "Project1," check the directory that the "Project1" folder resides after trying "RDS Query Viewer."  There should be a folder named "MyProject," which contains ".rdsTempFiles" folder and "RDS Query Viewer" file in it.

                           

                          These should be created in the "Project1" folder instead, but.....
                          (".rdsTempFiles" folder is created, but not "RDS Query Viewer" file in the "Project1" folder.)

                           

                          So if you match the names, the "RDS Query Viewer" file will be created in the proper location and "RDS Query Viewer" will work properly.

                          • 10. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
                            Armor Bearer

                            The solution present by CF-AXL works!!!

                             

                            Go to your project folder then right click or control click for OSX, then select properties.  This will give you the name of the folder that your files are being stored under.  If it is different than the name in the Navigator then change the name in the Navigator by using your right click.

                            • 11. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
                              DFBurns Level 1

                              This works but now your project name has to match the root folder on disk of the project's files. This wasn't the case with CFB1 and seems like a bug since the two should be decoupled. I have a directory structure like so:

                               

                              projectname

                              projectname/trunk

                              projectname/trunk/wwwroot

                               

                              My project's name is "Foo" and that's how I want to find it in my list of projects in my workspace. But the project's location in CFB is defined as "Foo/trunk". The workaround right now is to rename my project in CFB to be "trunk" which is not descriptive. The alternative is to set my project's location to the Foo directory and have the directory "trunk" appear in the hierarchy. This isn't the end of the world but it is irksome.

                              • 12. Re: '/mt/.rdsTempFiles/RDS Query Viewer' does not exist
                                CF-AXL Level 1

                                If you like to keep your current project settings(project name and location), it's a little messy but do this.

                                 

                                - Open your project location directory ("trunk" in your case) and create a ".rdsTempFiles" folder if it's not already there.
                                - Open the ".rdsTempFiles" folder and create a "RDS Query Viewer" file with no extension.

                                 

                                That's all.

                                 

                                What I mean by "messy" is that there will be an extra folder whose name is the project name created in the same directory as your project location.
                                So, if you do this workaround, don't forget to delete the extra folder when Adobe releases the fix.