0 Replies Latest reply on Apr 3, 2011 12:26 PM by AVoytas

    SecurityError: Error #2148: SWF file http://www.path/folder/TestFour.swf  Only local-with-filesyste

    AVoytas

      OS: Windows 7 Professional

      App: Flash CS4 Professioinal Version 10.0.2

      Suite: Abode Web Premium CS4

      URL: http://www.mywebworldnow.com/VideoTestFour/VideoTestFour.html

       

      Error:

      SecurityError: Error #2148: SWF file http://www.mywebworldnow.com/VideoTestFour/VideoTestFour.swf cannot access local resource C:\Users\Andrew\Documents\WebSites\Projects\VideoTestFour\HuffinesOnline.f4v. Only local-with-filesystem and trusted local SWF files may access local resources.
      at flash.net::NetStream/play()
      at fl.video::VideoPlayer/http://www.adobe.com/2007/flash/flvplayback/internal::_play()
      at fl.video::VideoPlayer/http://www.adobe.com/2007/flash/flvplayback/internal::_setUpStream()
      at fl.video::VideoPlayer/http://www.adobe.com/2007/flash/flvplayback/internal::_load()
      at fl.video::VideoPlayer/load()
      at fl.video::FLVPlayback/doContentPathConnect()

       

      Issue:

      I am trying to play videos online. ( In IE8) All I see is the skin. No Video, No Audio. (In Firefox) I keep get the error message above.

       

      What I've Tried:

      -I have tried manually changing the source in the FLVPlayback Parameters to http://www.mywebworldnow.com/VideoTestFour/HuffinesOnline.f4v  but Flash will not let me make the change.I get another error: NetStream.Lay.StreamNotFound: Adobe Flash tried to play a live or recorded that does not exist. Source can't be found. I clicked Okay and it showed the change in the source so I saved and uploaded the doc. No change.

       

      -I mapped the ftp location to my computer , browsed for the file and Flash froze up then put the file in a temp folder C:\Users\Andrew\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\6P8YYDCD\HuffinesOnline[1].f4v

      I did not save it because if it is looking for the file on C(like the message I am getting above) I don't see how it would help my situation.

       

      Process I am using:

      1. Open Flash CS4

      2. Select Create New Flash File (ActionScript 3.0)

      3. File\ Import \ Import Video

      3a. select f4v file from location: C:\Users\Andrew\Documents\WebSites\Projects\VideoTestFour/HuffinesOnline.f4v "Open"

      3b. "Next"

      3c. Select the skin I want (SkinOverPlaySotpSeekMuteVol) "Next"

      3d. "Finish"

      4. File\ Publish Settings

      4a. I select the location to save the file and change the file name:

      for Flash: C:\Users\Andrew\Documents\WebSites\Projects\VideoTestFour/VideoTestFour.swf

      for HTML: C:\Users\Andrew\Documents\WebSites\Projects\VideoTestFour/VideoTestFour.html

      4b. Select "Publish"

      4c. Select "OK"

      5. Save the project as TestVideoFour.fla

      6. ftp the whole folder "VideoTestFour" to the root of my server.

      7. go to http://www.mywebworldnow.com/VideoTestFour/VideoTestFour.html to test.

      All I see is the skin. No Video, No Audio

       

      Thank you in advance for any resolution\help with this issue.