4 Replies Latest reply on Apr 7, 2011 12:21 AM by Grapixsoft

    OSMF .mp4 video playback issue [audio only]

    Grapixsoft

      Hi,

       

      I developed a media player using OSMF for one of my clients which handles audio and video playlists. I tested video on it using .flv and .mp4 format. It worked perfectly fine during testing stages. Both me and my client were able to confirm that. (I tested only on localhost and I'm probably sure that my client also checked on localhost only.)

       

      Now that my client has uploaded the player to a test server the .mp4 video he has added to the playlist isn't just playing at all. And there are no errors thrown by the Flash player, so it's very hard for me to figure out why (if you try to skip forward in time by clicking on the progress bar the following error

      will be thrown - Video tab). I'm guessing this is cause there is nothing to seek. O_@

       

       

      Error: The specified capability is not currently supported

      at org.osmf.media::MediaPlayer/getTraitOrThrow()

      at org.osmf.media::MediaPlayer/seek()

      at MediaPlayer/onTrackClick()

       

       

      I downloaded the particular .mp4 video file and tried this on my localhost and it plays fine but I hear audio only. The video don't show up. I'm having other .mp4 videos as well on the playlist and apart from this perticular .mp4 video others work just fine. If I run the mentioned .mp4 on any windows media player it works fine too. So, is this something to do with servers or just something completely different that has to do with some encoding problem in this perticular file?

       

      This is my client's test link - http://apextestserver.info/cme/viewband/answer-band/

      The media player is midway down to the right. Click on Video tab and hit play. It won't work.