0 Replies Latest reply on Apr 11, 2011 12:21 PM by Oscar E. Despradel

    Can't configure servers in cf Builder using coldfusion as MultiServer

    Oscar E. Despradel

      I have coldfusion 9 installed as MultiServer in mac OS 10.6. I'm usisng Apache 2.2 I access each instances using apache virtual host.

       

      No matter witch WebServer port I configured when adding a new server in CF Builder it always start the cfusion instance. The one that is configure in port 8300.

       

      This an example setup:

      Server Name: odespra.com

      Description:

      Application Server: JRun

      Hostname: localhost

      WebServer Port: 8302

       

      In the local server settings:

      server home: Applications/JRun4

      Document root: Applications/JRun4/servers/odespra/cfusion.ear/cfsuin.war

       

      When i try to start the server the one that start is the cfusion instance (port:8300)

      I have this conf in apache virtual host to access the server through http://odespra

      <VirtualHost *:80>
          DocumentRoot /Applications/JRun4/servers/odespra/cfusion.ear/cfusion.war
          ServerName odespra
          <IfModule mod_jrun22.c>
              JRunConfig Serverstore "/Applications/JRun4/lib/wsconfig/odespra/jrunserver.store"
              JRunConfig Bootstrap 127.0.0.1:51002
              #JRunConfig Errorurl url <optionally redirect to this URL on errors>
              #JRunConfig ProxyRetryInterval 600 <number of seconds to wait before trying to reconnect to unreachable clustered server>
              #JRunConfig ConnectTimeout 15 <number of seconds to wait on a socket connect to a jrun server>
              #JRunConfig RecvTimeout 300 <number of seconds to wait on a socket receive to a jrun server>
              #JRunConfig SendTimeout 15 <number of seconds to wait on a socket send to a jrun server>
          </IfModule>
      </VirtualHost>


      Any help is appreciated.

       

      Thanks in advanse, Oscar