3 Replies Latest reply on Apr 13, 2011 8:18 PM by sjfkjskjfkljs

    CS5 Cannot find URL setting in flash application! Please assist

    shooterjd

      Hello....

      I am working on a template for a friend. I cannot find where you set the URL/Hyperlink on a menu template.

      The template has menu items for top of webpage such as home, about us, forum, contact us, etc.

       

      For the life of me I cannot find where you set/change the url when you click on one of these menu options. It is a rather complex flash and I would appreciate any assistance. I guess i will have to send the file to a trusted source and see if they can help me out.

       

      Thank you all for your time.

        • 1. Re: CS5 Cannot find URL setting in flash application! Please assist
          Ned Murphy Adobe Community Professional & MVP

          If the file is using Actionscript 2 then it is possible that the buttons have code attached to them, in which case you need to click on the button while the Actions window is open to see it.  The buttons could also be movieclips which means you might find the code internal to the movieclips.  There are a variety of ways templates can be made, but a good one will come with instructions on how to adjust things.

          • 2. Re: CS5 Cannot find URL setting in flash application! Please assist
            sjfkjskjfkljs

            Thank you for your reply... my shooterjd login was acting up so i had to create this one.

             

            I have found the code but it is still not working.

             

            This is what it looks like originally:

             

            onClipEvent (load) {
            num = 2;
            this.hitArea = area;
            }
            on (rollOver) {
            if (_root.link<>num) {
              this.gotoAndPlay("s1");
            }
            }
            on (releaseOutside, rollOut) {
            if (_root.link<>num) {
              this.gotoAndPlay("s2");
            }
            }
            on (release) {
            if (_root.link<>num) {
              _parent["item"+_root.link].gotoAndPlay("s2");
              _root.link = num;
              getURL("index-1.html");
              _root.menu2["item"+_root.link].gotoAndPlay("s1");
            }
            }

             

             

            AND THIS IS WHAT I CHANGED IT TOO

             

             

             

            onClipEvent (load) {
            num = 2;
            this.hitArea = area;
            }
            on (rollOver) {
            if (_root.link<>num) {
              this.gotoAndPlay("s1");
            }
            }
            on (releaseOutside, rollOut) {
            if (_root.link<>num) {
              this.gotoAndPlay("s2");
            }
            }
            on (release) {
            if (_root.link<>num) {
              _parent["item"+_root.link].gotoAndPlay("s2");
              _root.link = num;
              getURL("about.php");
              _root.menu2["item"+_root.link].gotoAndPlay("s1");
            }
            }

             

            The only thing i changed is the getURL but when i test movie it still sends me to "index-1.html

            What am I missing? Thank you again for your time Ned. It is much appreciated.