3 Replies Latest reply on Apr 21, 2011 8:07 PM by Praful_Jain

    Pop Up Behavior in RoboHelp 9

    muranoj

      My company has just upgraded from RoboHelp 7 to RoboHelp 9 and I am fairly new to RoboHelp so I was wondering if anyone can help me figure out an issue I am experiencing. I am working on a project that originated in RH7 that has been updated for RH9. I ran the "Update DHTML Effects Tool" and tried everything I could think of to try to address this issue but I'm stymied.

       

      This project makes very frequent use of pop-ups that link to other topics/images for quick reference.  I noticed that the pop-ups that originated in RH7 appear to work fine - i.e., clicking on a link results in a pop-up that does just that....pops up over the link. However when previewing topics that contain pop-ups that were added in RH9, clicking on the link to reveal the pop up causes the screen to scroll to the beginning of the host topic rather than just having the pop up appear where the link is.  Once the pop-up is dismissed, you must scroll back down to the link in order to resume reading the original topic. This occurs with both auto-sizing and custom-sized pop ups. 

       

      Is there a control or code that must be implemented to prevent this behavior in RH9? 

       

      Thanks in advance!

        • 1. Re: Pop Up Behavior in RoboHelp 9
          Praful_Jain Level 3

          Hi,

           

          You had mentioned the issue coming in preview of topic, does the same issue occur when you generate the output and view the topic.

          Also is the issue coming with this project only or did you try creating a new project and adding popup in that project and see if every thing works fine.

           

          Thanks

          Praful Jain

          • 2. Re: Pop Up Behavior in RoboHelp 9
            muranoj Level 1

            Yes, the same issue occurs when generating the output and viewing the topic.  I should note that the project is using a template that was created in RH7. When importing that template as a "Master Page" and starting from scratch in a new project, the issue does not appear to occur.

             

            I did also notice that links to bookmarks within other topics do not work correctly in the upgraded project.  The bookmarks are present and the highlighted text is still linked to the bookmark but when previewing (or reviewing in the final output) the link brings up the start of the topic containing the bookmark, not the text that has been bookmarked.  Each link has to be redefined in order to work properly.

             

            Thanks for your help!

            • 3. Re: Pop Up Behavior in RoboHelp 9
              Praful_Jain Level 3

              Hi,

               

              Is it possible for you to share a sample project where this issue is coming up. you can upload the sample project to http://www.acrobat.com and share it to praful@adobe.com. This will help us in root causing the issue and giving a better solution.

               

               

              thanks

              Praful Jain

              Adobe RoboHelp team.