3 Replies Latest reply on Apr 21, 2011 8:08 AM by Chris W. Griffith

    swf asset not showing

    swood4134

      I have been working on a project in FC and am having problems with a swf asset.

       

      I have two that where imported into FC and when I run the project they work fine, and the air package works fine. However, when I try to preview either the 'deploy-to-web' version of 'run-local' version one of the swf assests shows and the other does not.

       

      Each have different names and look like they are in the correct location using relative paths.

       

      any thoughts?

       

      Many thanks!

        • 1. Re: swf asset not showing
          Chris W. Griffith Adobe Community Professional

          Hum...

           

          In your web browser, have you tried entering the full url to each swf. That way you can be sure they are there, and play outside of the Catalyst.

           

          Also did you create the same directory structure on the server as in the local folders?

           

          Just some easy tests to start with.

           

          Chris

          • 2. Re: swf asset not showing
            swood4134 Level 1

            I haven't gotten that far yet...

             

            but shouldn't I be able to preview the final product from the main.html in either the 'deploy-to-web' or 'run local' folders or the main.swf in either folder as well.

             

            They are all missing the same swf file.

             

            Thanks!

            • 3. Re: swf asset not showing
              Chris W. Griffith Adobe Community Professional

              You should be able to see them in the 'run local' version. The deploy to web version might trigger some security flags. I would try re-importing them in Flash Catalyst and see if that solves the issue. I am assuming the swfs are written using ActionScript 3 and not ActionScript 2.0. Flash Catalyst will not support older versions of ActionScript.

              1 person found this helpful