3 Replies Latest reply on May 9, 2011 9:03 AM by milan_va

    All items lost in AdvancedDataGrid SDK 4.1.0

    milan_va

      Hi all.

       

       

      I had to upgrade my project from SDK 3.2.0 to a newer one, and I've tried to switch to 4.1.0.16076 (I think it's the latest 4.1 available today). Besides all the problems that could be solved, I've come across something I think is a bug that's not easily avoided.

       

       

       

      At application startup, an AdvancedDataGrid shows all items as expected. However, on a seemingly unrelated action, suddenly all items seem to be removed. I've spent a fair amount of time nailing this down and the conclusion is, it's a fairly serious bug that makes ADG nearly unusable. I wonder why nobody has found this yet...?

       

       

       

      I've created a demo project, source is at http://update.seapraha.cz/configurator/adgbug.zip . Simply click the button and the ADG gets cleared.

       

       

       

      From what I've learned, it seems that the root of the problem is that certain flag, rendererChanged, remains set after the creation of the ADG. All seems fine, until later updateDisplayList( ) is called for some reason. Then listItems are cleared, and then rowCount is set to zero, hiding all items. Setting rowCount back to the desired value kind of helps, but in a real application, it's hard to find the right time to do it.

       

       

       

      On a related note, if I set rowCount to 8, after some time it's read back as 6, because the two header lines somehow get lost during the creation of item renderers.

       

       

       

      Could someone confirm this as a bug, and perhaps fill a bug report? I'd love to do that myself, but I'm waiting since February to get an email to finish the registration at JIRA .

       

       

       

       

       

          Milan