37 Replies Latest reply on Nov 27, 2007 12:17 AM by Gheorghe Blanariu

    Error installing Flex 3 in Eclipse 3.3

    edfrk Level 1
      When trying to install the Flex 3 plugin into Eclipse 3.3, I'm getting the error...

      !ENTRY org.eclipse.update.core 4 0 2007-07-05 12:02:16.786
      !MESSAGE Featurecom.adobe.flexbuilder.feature.core 3.0.172437cannot be found onfile:/C:/Program Files/Adobe/Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/
      or a newer version is already installed.

        • 1. Re: Error installing Flex 3 in Eclipse 3.3
          C. Agruss (Adobe) Level 3
          Here are a few workarounds to try:
          - use a completely fresh copy of eclipse 3.3
          - delete the default workspace, and start fresh
          - if none of the above helps, try re-downloading the installer, to make sure it wasn't corrupted during the initial download.

          We've re-structured the FB plugin installer over the past month to avoid many of these anomalies, but in the meantime, please let us know if any of the workarounds listed above works for your configuration.

          C. Agruss
          Flex Builder Team
          • 2. Re: Error installing Flex 3 in Eclipse 3.3
            edfrk Level 1
            I did the first two suggestions and still no luck. So I redownloaded everything, wiped everything off my system, and it seems to be working now. Thank you.
            • 3. Re: Error installing Flex 3 in Eclipse 3.3
              mol35
              I have a similar problem, I get the error message at the end of the install pointing me to a log file with the following in it.
              I have re-downloaded eclipse 3.3 and flex builder 3, and tried this on 2 different machines with the same results.
              Does it matter which eclipse, i'm just using the plain Java eclipse?

              !SESSION 2007-07-10 18:21:08.483 -----------------------------------------------
              eclipse.buildId=I20070625-1500
              java.version=1.5.0_11
              java.vendor=Sun Microsystems Inc.
              BootLoader constants: OS=win32, ARCH=x86, WS=gtk, NL=en_AU
              Framework arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:\C:\dev\tools\flex\Flex Builder 3 Plug-in\com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.core -version 3.0.172437
              Command-line arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:\C:\dev\tools\flex\Flex Builder 3 Plug-in\com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.core -version 3.0.172437

              !ENTRY org.eclipse.update.configurator 2007-07-10 18:21:09.715
              !MESSAGE Could not install bundle plugins/org.eclipse.equinox.launcher_1.0.0.v20070606.jar Bundle "org.eclipse.equinox.launcher" version "1.0.0.v20070606" has already been installed from: update@plugins/org.eclipse.equinox.launcher.jar

              !ENTRY org.eclipse.update.core 4 0 2007-07-10 18:21:13.160
              !MESSAGE Featurecom.adobe.flexbuilder.feature.core 3.0.172437cannot be found onfile:/C:/dev/tools/flex/Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/
              or a newer version is already installed.

              • 4. Re: Error installing Flex 3 in Eclipse 3.3
                Frank_Krul
                Why not install Flex 3 with Eclipse Europa (3.3)? When you create a new project you can choose the type of compilation you require; Flex 2 or Flex 3.

                The concern over beta code seems to be limited to the new features of the Flex 3 compiler...as far as my experiences have been, Flex 2 compilation in Europa is very stable, it's probably a direct copy from the previous plug-in and not a port.

                Go for it!
                • 5. Re: Error installing Flex 3 in Eclipse 3.3
                  flowdjinn
                  I have the exact same problem, Eclipse 3.3, Mac OSX 10.4.10. I tried everything short of redownloading everything - I'll try that or just run standalone. Did you ever figure it out?
                  • 6. Re: Error installing Flex 3 in Eclipse 3.3
                    C. Agruss (Adobe) Level 3
                    There are two main reasons for this error that I've seen:
                    - corrupt download
                    - configuration conflicts in eclipse 3.3

                    To remedy the second problem, unzip a fresh copy of the 3.3 SDK, and be sure to configure a fresh new default workspace as well.

                    C. Agruss
                    • 7. Re: Error installing Flex 3 in Eclipse 3.3
                      Tom Sugden
                      Hi Chris, etc,

                      I'm also seeing this problem. Do you have a more specific solution? I've tried installing the plug-in several times using fresh installations of both Eclipse Java Europa 3.3 and Eclipse JEE Europa 3.3. I've downloaded the Eclipse distributions and the Flex Builder plug-in twice. I'm using Mac OS X with the latest updates applied. Here are the error logs:

                      ---
                      !SESSION 2007-07-14 19:29:02.183 -----------------------------------------------
                      eclipse.buildId=I20070625-1500
                      java.version=1.5.0_07
                      java.vendor=Apple Computer, Inc.
                      BootLoader constants: OS=macosx, ARCH=x86, WS=gtk, NL=en_US
                      Framework arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:/Applications/Adobe/flex3.b1/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.core.osx -version 3.0.172437
                      Command-line arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:/Applications/Adobe/flex3.b1/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.core.osx -version 3.0.172437

                      !ENTRY org.eclipse.update.core 4 0 2007-07-14 19:29:05.862
                      !MESSAGE Featurecom.adobe.flexbuilder.feature.core.osx 3.0.172437cannot be found onfile:/Applications/Adobe/flex3.b1/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/
                      or a newer version is already installed.
                      ---

                      Regards,
                      Tom

                      • 8. Re: Error installing Flex 3 in Eclipse 3.3
                        C. Agruss (Adobe) Level 3
                        Hi Tom,

                        Here are a few other things you can try. I can't reproduce the error (and neither can any of the testers in our QA group), so we can’t offer a sure fire solution, but here are some generic things from our installer wiki that might help:

                        Overview
                        With repeated installs and uninstalls, InstallAnywhere will sometimes get into a corrupt state leading to errors during subsequent installations. Here are some steps for deep cleaning previous installations that may not have been uninstalled completely before, or that you suspect may be corrupted.

                        Deep uninstalling on Windows
                        1) After uninstalling normally, delete the entire installed folder manually, including any stray folders (jre, etc.)
                        2) See if there’s any info stored under this key in the registry, and remove the key(s) if found:
                        HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flex Builder * (or Plugin)
                        3) Delete the file c:\Program Files\Zero G Registry\.com.zerog.registry.xml

                        Deep uninstalling on OS X
                        1) After uninstalling normally, delete the entire installed folder(s) manually, including any stray folders
                        2) Delete the file /{user home}/Library/Preferences/org.eclipse.eclipse.plist
                        3) Delete the file /{user home}/Library/Preferences/.com.zerog.registry.xml
                        4) Also delete this file {root volume}/Library/Preferences/.com.zerog.registry.xml, if found.

                        Let me know if any of this helps you get past that error.

                        C. Agruss
                        • 9. Re: Error installing Flex 3 in Eclipse 3.3
                          Tom Sugden Level 1
                          Hi Chris,

                          Still no joy, unfortunately. I followed your steps for a deep uninstall on Mac OS X. After a fresh install of Eclipse Europa Java 3.3, the same error occurred. Next I tried with Eclipse Europa JEE 3.3 and the same error occured again. For good measure, I then tried deleting some more .plist files with FlexBuilder in their names, made sure all older versions of Eclipse and Flex Builder were uninstalled, ran the Dick Utility Fix Permissions tool, then tried reinstalling again, and the same error still occurs.

                          Every time the installer lingers for a while during the "Installing... Execute Command: java -cp "/Applications..." stage before displaying an error dialog pointing to the log file. The log contains the following:

                          ---
                          !SESSION 2007-07-15 21:43:46.912 -----------------------------------------------
                          eclipse.buildId=I20070625-1500
                          java.version=1.5.0_07
                          java.vendor=Apple Computer, Inc.
                          BootLoader constants: OS=macosx, ARCH=x86, WS=gtk, NL=en_US
                          Framework arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:/Applications/Adobe/flex3.b1/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.core.osx -version 3.0.172437
                          Command-line arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:/Applications/Adobe/flex3.b1/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.core.osx -version 3.0.172437

                          !ENTRY org.eclipse.update.core 4 0 2007-07-15 21:43:50.566
                          !MESSAGE Featurecom.adobe.flexbuilder.feature.core.osx 3.0.172437cannot be found onfile:/Applications/Adobe/flex3.b1/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/
                          or a newer version is already installed.
                          ---

                          Any further help would be greatly appreciated. I'm desperate to use FB3 in conjunction with Eclipse 3.3, to make use of the new features from both. It seems I'm not the only person with this problem, so a solution would be great. If you'd like me to send any further details, please let me know.

                          Best regards,
                          Tom
                          • 10. Re: Error installing Flex 3 in Eclipse 3.3
                            I have the exact same error in my eclipse/configuration/*.log after multiple attempts.

                            Here's my setup:
                            OS: Windows Vista Ultimate
                            EclipseIDE: eclipse-java-europa-win32

                            Here's what I've tried:
                            # Scenario 1: UAC Enabled
                            1. Uninstalled All flex builder plugin instances (standalone version was not installed)
                            2. Uninstalled eclipse (removed workspaces as well)
                            3. Downloaded fresh versions of eclipse and fb3
                            4. Unzipped eclipse
                            5. Ran the fb3 installer pointed in the fresh eclipse directory
                            6. Failure

                            # Scenario 2: UAC Enabled
                            Same as scenario 1, except prior to step 5 I ran eclipse once to create a workspace

                            # Scenario's 3 and 4:
                            Same as 1 and 2, but with UAC Disabled.

                            I've done this on two seperate PCs, both with vista ultimate installed. Any other suggestions?

                            Thanks,

                            -Aaron
                            • 11. Re: Error installing Flex 3 in Eclipse 3.3
                              C. Agruss (Adobe) Level 3
                              Sorry that you're having trouble installing the last beta release into eclipse 3.3. We tested it pretty heavily before releasing the beta, but it was before the final 3.3 release, so we were testing against one of the milestone releases at the time.

                              Since 3.3 has released, we've been testing against that version, and though we're still eliminating a few warnings, the installations have been error free for us. We also redesigned the plug-in version last month to install as a Product Extension, so the configurations have changed a good bit since the last beta.

                              It's puzzling that the beta plug-in installer works for some people on 3.3, but not for others, so it would be useful to figure out the underlying differences. Here are a few other steps you could try before the next plug-in installation attempt:

                              - make sure that the generic workspace named @user/workspace/ is deleted, where @user is your user home folder.
                              - remove everything else in eclipse's /configuration/ folder, other than config.ini
                              - add the following lines to eclipse's file /configuration/config.ini:

                              osgi.configuration.area=@user.home/Flex Builder 3 Plug-in/configuration
                              osgi.sharedConfiguration.area=platform\:/base/configuration
                              osgi.sharedConfiguration.area.readOnly=true
                              osgi.configuration.cascaded=true

                              The lines above added to config.ini will lock eclipse's configuration folder, redirecting all info to your user home folder. If you need to uninstall subsequently, be sure to remove the folder @user.home/Flex Builder 3 Plug-in/configuration/ afterwards to clean the slate.

                              Please let us know if any of the additional suggestions above work for you. There are a few other more complicated tricks we could try, before throwing in the towel on getting the last beta release working for your plug-in configurations.

                              C. Agruss
                              • 12. Re: Error installing Flex 3 in Eclipse 3.3
                                Thanks for the suggestions Chris. Unfortunately this did not work, same error. The workaround now is to use the plugin with 3.2/callipso, and that seems to work without issue.

                                I'm game to try the more complicated tricks, but it will have to be later in the week - I have some coding to do :)
                                • 13. Error installing Flex 3 in Eclipse 3.3
                                  dougkeen
                                  Out of curiosity, Chris, which 3.3 distro did you all test against? I also ran into these same issues when trying to install Flex Builder 3, and the only way I could get it to work was to install the plugin on a completely fresh install of the "Eclipse Classic" 3.3 distro. Trying to install on the Java EE or the Java distros never worked for me.

                                  For anyone still having issues:
                                  Try installing Flex Builder on a fresh copy of the "Eclipse Classic" distro, not the Java or Java EE versions.
                                  • 14. Re: Error installing Flex 3 in Eclipse 3.3
                                    C. Agruss (Adobe) Level 3
                                    Excellent point Doug. When we tested the beta release, the final milestone distros available for 3.3 most closely resembled the Classic distros. Also, I think the Classic distro is the one we're mainly using now for the release version.

                                    I'll take a closer look at the other distros to see what's causing the problem.

                                    Please try Doug's suggestion of installing the last FB 3 beta using the Eclipse Classic distro.

                                    C. Agruss
                                    • 15. Re: Error installing Flex 3 in Eclipse 3.3
                                      Tom Sugden Level 1
                                      I'll try using the classic version instead. It would be great if you could solve the problem with the java and jee distributions, since these include mylyn, which is not a part of the classic distribution.

                                      Cheers,
                                      Tom
                                      • 16. Re: Error installing Flex 3 in Eclipse 3.3
                                        AlexRudloff
                                        Just to chime in, similar situation on my side. OS/X w/ the java variant of Eclipse 3.3
                                        • 17. Re: Error installing Flex 3 in Eclipse 3.3
                                          Doug,

                                          I owe you a beer - using the 3.3 "classic" distro worked like a charm, and made me feel quite silly for not trying it.

                                          Many thanks,

                                          -Aaron
                                          • 18. Re: Error installing Flex 3 in Eclipse 3.3
                                            flowdjinn Level 1
                                            Same here - classic distro fixed it. Go Doug!
                                            • 19. Re: Error installing Flex 3 in Eclipse 3.3
                                              TimSkySurfSnow
                                              How to Install Flex3 Beta on Eclipse Europa MAC OSX
                                              1. Get annoyed that Flex2 will not install on Europa
                                              2. Download Flex3
                                              3. Install on Europa...failed...get extremely annoyed at broken promises of Flex3 Delight
                                              ---------------------OK, down to business---------------------

                                              1. Run installer
                                              2. When installer throws the "install problem message" DO NOT PROCEED. STOP IMMEDIATELY
                                              3. Navigate to your Flex 3 installation directory (e.g. /Applications/Adobe Flex Builder 3 Plug-in)
                                              4. Navigate to the update site directory (/Applications/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site)
                                              5. Copy all the jars in the features directory to your eclipse_europa features directory
                                              6. Copy all the jars in the plugins directory to your eclipse_europa plugins directory
                                              7. LET THE INSTALL PROCEED NORMALLY after that
                                              8. Start eclipse europa
                                              9. Navigate to preferences->flex->installed sdks
                                              10. Add moxie (/Applications/Adobe Flex Builder 3 Plug-in/sdks/moxie)
                                              11. Add flex2.0(/Applications/Adobe Flex Builder 3 Plug-in/sdks/2.0.1)
                                              12...create flex3 project and enjoy.
                                              Painless...This seems to work just fine. I haven't had an issue(yet)
                                              • 20. Re: Error installing Flex 3 in Eclipse 3.3
                                                tmcw
                                                Same errors on WinXP... the log file reads:

                                                !SESSION 2007-10-29 20:02:37.502 -----------------------------------------------
                                                eclipse.buildId=I20070625-1500
                                                java.version=1.5.0_11
                                                java.vendor=Sun Microsystems Inc.
                                                BootLoader constants: OS=win32, ARCH=x86, WS=gtk, NL=en_US
                                                Framework arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:\C:\Program Files\Adobe\Flex Builder 3 Plug-in\com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.core -version 3.0.183654 -to C:\Program Files\Adobe\Flex Builder 3 Plug-in
                                                Command-line arguments: -application org.eclipse.update.core.standaloneUpdate -command install -from file:\C:\Program Files\Adobe\Flex Builder 3 Plug-in\com.adobe.flexbuilder.update.site/ -featureId com.adobe.flexbuilder.feature.core -version 3.0.183654 -to C:\Program Files\Adobe\Flex Builder 3 Plug-in

                                                !ENTRY org.eclipse.update.configurator 2007-10-29 20:02:39.165
                                                !MESSAGE C:\Program Files\Adobe\Flex Builder 3 Plug-in\eclipse\plugins is not a valid plugins directory.

                                                !ENTRY org.eclipse.update.core 4 0 2007-10-29 20:03:33.363
                                                !MESSAGE Featurecom.adobe.flexbuilder.feature.core 3.0.183654cannot be found onfile:/C:/Program Files/Adobe/Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/
                                                or a newer version is already installed.


                                                I've tried adding it manually, and I'll get all of the first controls (switch to workspace, about Flex Builder) but all of them just give an alertbox telling me the feature is not enabled. Any ideas, or will there be a new release soon? I'm just wishing that Adobe chose to use the standard update method instead of packaging it as an installer, which seems to give everyone headaches.
                                                • 21. Re: Error installing Flex 3 in Eclipse 3.3
                                                  C. Agruss (Adobe) Level 3
                                                  Note that this bug was fixed in eclipse 3.3.1. If you download any of the Fall Maintenance Distros (JEE, Java, etc.), you'll be able to install FB3 Beta into it without hitting this error.

                                                  C. Agruss
                                                  Flex Builder Team
                                                  • 22. Re: Error installing Flex 3 in Eclipse 3.3
                                                    tmcw Level 1
                                                    I just updated Eclipse (I don't use the Classic version) to 3.3.1.1 and the installer gave me a 'proceed with caution' warning even though I chose the correct folder.

                                                    I got a 'finished but some errors occurred' (thanks for being specific...)
                                                    message, and the log shows

                                                    Execute ANT Script: Script: copy.equinox.launcher.xml
                                                    Status: ERROR
                                                    Additional Notes: ERROR - copy.equinox.launcher.xml:17: Cannot concatenate multiple files into a single file.


                                                    ... and no dice. Nothing shows up in Eclipse.

                                                    I'll wait until this becomes beta or something.
                                                    • 23. Re: Error installing Flex 3 in Eclipse 3.3
                                                      C. Agruss (Adobe) Level 3
                                                      Actually, last month was our second beta release. Are you using something older than that?

                                                      The generic error you saw is telling you that it couldn't find the feature org.eclipse.core in the path you pointed to. Is it possible that you chose a path other than one that contains the eclipse 3.3.1 features and plugins folders?

                                                      We've done many dozens of plug-in installation into eclipse 3.3.1 distros, and so far it always works like a charm. I'd like to figure out what's different about your configuration.

                                                      C. Agruss
                                                      Flex Builder Team
                                                      • 24. Re: Error installing Flex 3 in Eclipse 3.3
                                                        tmcw Level 1
                                                        I downloaded it today, so it's the most recent version. It's definitely the right folder (I have running eclipse.exe from that location). I do have a few plugins already installed in Eclipse (WST, PDT, etc)

                                                        Here's my configuration details: http://pastebin.com/m53ee2966
                                                        • 25. Re: Error installing Flex 3 in Eclipse 3.3
                                                          C. Agruss (Adobe) Level 3
                                                          Thanks for posting the log file. In looking it over, one difference I notice between what you're using and what we've been testing with is the version of your plugin org.eclipse.platform. We've been using the 3.3.1 version, but it looks as if you're using version 3.3.2. Perhaps that's was included in the recent 3.3.1.1 release you mentioned yesteday?

                                                          I've no idea why that would make a difference, but there was a bug in eclipse 3.3.0 that prevented our installing FB3 Plug-in, that was fixed in 3.3.1. Have you tried installing into version 3.3.1, to see if that will work around the problem you're describing?

                                                          Perhaps that bug regressed again in 3.3.1.1? We'll check that out here. Thanks again for the details.

                                                          C. Agruss
                                                          Flex Builder Team
                                                          • 27. Re: Error installing Flex 3 in Eclipse 3.3
                                                            tmcw Level 1
                                                            Eclipse updates whenever I start it up, so going back to an earlier build will mean some annoyance. I'll wait until FB3 is up to speed with the latest Eclipse.
                                                            • 28. Re: Error installing Flex 3 in Eclipse 3.3
                                                              C. Agruss (Adobe) Level 3
                                                              Good idea. The Beta you're using is about a month old now, and we've been keeping Flex Builder 3 synced up with Eclipse 3.3.x more regularly now. Our daily Plugin builds have been working fine with the latest Eclipse 3.3.x builds for the last few weeks, so when we release the next beta I expect you'll find it more seamless.

                                                              Thanks for your patience, and for participating in the Beta program.

                                                              C. Agruss
                                                              Flex Builder Team
                                                              • 29. Re: Error installing Flex 3 in Eclipse 3.3
                                                                ArronH
                                                                I'm not sure if this addresses all of the issues here, but we have had problems with FB3b2 installs for Eclipse 3.3.

                                                                One thing I noticed is that the file created in eclipse/links is not formatted correctly. It doesn't have the "path=" preceding the directory location for the eclipse configuration extension location for FB3. Here's a clip from our local developer wiki on workarounds for this issue:

                                                                Plugin not activated in Eclipse 3.3 after install

                                                                1. Check the <Flex Builder Plugin Folder>/eclipse/features folder and make sure the com.adobe.flexbuilder.feature.core_3.0.xxx folder exists.
                                                                * if it does not exist, the Flex Builder did not install correctly. Either re-install, or you can install the Eclipse part of the plugin from the provided update site as a workaround. Follow the instructions under the Installing the plugin from the update site section.

                                                                2. If it does not exist, create a directory under you eclipse installation <eclipse>/links and create a text file called com.adobe.flexbuilder.link containing the following content with your specific path to your Flex Builder Plugin root directory:

                                                                path=C:/dev_tools/Flex_Builder_3_Plug-in

                                                                3. Start (or restart) Eclipse and the plugin should be available and functional. If Help->Flex Start Page and the Flex perspective is available, you're all set.

                                                                Installing the plugin from the update site

                                                                1. Configure the com.adobe.flexbuilder.link file in step 2 above.

                                                                2. Start (or restart) Eclipse and select Help->Software Updates->Find and Install. Select Search for new features to install->next. Create a New Local Site and point it at <Flex_Builder_3_Plug-in>/com.adobe.flexbuilder.update.site.

                                                                3. When you install the plugin from this location, make sure you Choose Location to install the plugin to the external configuration site defined from the flexbuilder link, not your original Eclipse installation directory. You must also remember to set this back on subsequent installations of other plugins as it keeps the last one you chose. If you don't, those plugins will install to the <Flex_Builder_3_Plug-in>/eclipse location. They will still work, but it makes it harder to uninstall and manage your plugins.
                                                                • 30. Re: Error installing Flex 3 in Eclipse 3.3
                                                                  tmcw Level 1
                                                                  All right - that works (sixth time's a charm). Everything's working... except that when I create a project, put in some basic code ( http://flare.prefuse.org/doc/tutorial/ ), and try to run it, it isn't generating the HTML file to display it.
                                                                  • 31. Re: Error installing Flex 3 in Eclipse 3.3
                                                                    tmcw Level 1
                                                                    Apparently the Flex 0.0 (1) Library in Build Path Libraries of my project is bad (it has the little red x on the icon).
                                                                    • 32. Re: Error installing Flex 3 in Eclipse 3.3
                                                                      tmcw Level 1
                                                                      Should C:\eclipse\plugins\com.adobe.flexbuilder.flex_3.0.183654\devsdks contain a Flex SDK?
                                                                      • 33. Re: Error installing Flex 3 in Eclipse 3.3
                                                                        tmcw Level 1
                                                                        I pointed it to
                                                                        C:\Program Files\Adobe\Flex Builder 3 Plug-in\sdks\3.0.0

                                                                        And the sad icon is now happy. However, I still get the error

                                                                        File not found: file:/C:/Documents%20and%20Settings/Thomas/workspace/Miles/bin/Miles.html

                                                                        When trying to Run As Flex Application.
                                                                        • 34. Re: Error installing Flex 3 in Eclipse 3.3
                                                                          tmcw Level 1
                                                                          All projects (Actionscript and Flex) are created with an empty /bin directory, and in the create project dialog, clicking "next" or "finish" creates a project and then gives the error that the project could not be created (so I can't use the extra settings in next)
                                                                          • 35. Re: Error installing Flex 3 in Eclipse 3.3
                                                                            briforge
                                                                            I'm trying to get Flex Builder 3 set up on a brand new WinXP machine. I just downloaded eclipse 3.3.1.1 for J2EE. The exact zip file was 'eclipse-jee-europa-fall2-win32'. It works fine, as far as just getting to a blank workbench. Haven't tried actually doing anything yet besides getting it up and running.

                                                                            Next I downloaded Flex Builder 3 beta. I downloaded the eclipse plugin version. On the download page it said it was 258 MB but it only downloaded about 50 meg. The file is 'flexbuilder3_b2_win_plugin_101107' When I double-click on this file, I get an InstallAnywhere box that says to select another location to install the file to. I tried selecting eclipse/plugins, but get the same message. It won't accept any location to install into.

                                                                            I had this working on another WinXP machine. I think that one also has Eclipse 3.3, but maybe not the J2EE version. But I don't think it has anything to do with eclipse on the new machine (yet) since it won't even install anywhere.

                                                                            any ideas?
                                                                            • 36. Re: Error installing Flex 3 in Eclipse 3.3
                                                                              C. Agruss (Adobe) Level 3
                                                                              Hi,

                                                                              It sounds as if there was a problem with your download, if you only ended up with ~50MB. Try downloading it again, and see if you get the full file size.

                                                                              C. Agruss
                                                                              Flex Builder Team
                                                                              • 37. Re: Error installing Flex 3 in Eclipse 3.3
                                                                                Gheorghe Blanariu Adobe Employee
                                                                                Can you try downloading the beta again because it should have, as you said, more that 200Mb. I