4 Replies Latest reply on Apr 27, 2011 9:16 AM by wasi26

    Long Lived processes not working at all

    wasi26

      This has just recently happened and there have been no changes made on the server, (with the exception of restarting the server after finding out about this issue.).  No long lived processes are currently working at all.  The rendering (short lived) processes seem to work, but if it needs to go beyond that, it doesn't happen.  And there is no sign that the process ever exisited at all. We first saw this happening when we went to terminate the lone process running on the server.  It did not allow us to do so.  We've attached an image of the error.  Then we tried running new processes and that's when we found that they're not being created.

       

      This led us to believe that there is possibly something wrong in the database, like the process table was dropped or something.  But when we looked  the table were in fact there.  So we decided to create a new test process that would render a simple form, pre-populated with the users common name, and when the user clicked complete, would route itself back to that user.  After that it would end.  The purpose was just to see if we could route anything.  Needless to say this test failed.  The rendering portion worked, but the process never goes beyond that.  The end user (in workspace) gets no indication that anything is wrong.  It looks as though the process runs fine.  But in the admin console, you will not see any instance of the process.  The process table is created, but with no data in it.

       

      We then decided to attempt to invoke the process from work bench.  We received an error when attempting to do so.  I've attached an image of that error also.

       

       

      Anyone have any ideas?  Any help with this is greatly appreciated.

       

      invoke_from_workbench_error.JPG

      terminate_process_error.JPG