16 Replies Latest reply on May 2, 2011 4:08 PM by The MtnLion

    Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)

    RShaffer21

      I am having trouble patching my Adobe Reader 9.4.3 MSI file to install the latest MSP patch 9.4.4.

       

      When I attempt to patch it by using the batch command (below):

       

      msiexec /a "C:\Documents and Settings\ShafferR\Desktop\AdbeRdr943_en_US.msi" /p "C:\Documents and Settings\ShafferR\Desktop\AdbeRdrUpd944_all_incr.msp"

       

      I receive the following Error (below).

      Adobe Patching Error.jpg

       

      All previous patches have applied without error.  I have re-downloaded all patches and even the 9.4.0 MSI file from Adobe's FTP site and attempted to re-patch from the flat 9.4.0 up to 9.4.4 using all incremental patches, but I keep getting hung up on patch 9.4.4.

       

      Once this error pops up, the patch rolls back and uninstalls.  Anyone run into this problem or know how to fix it?

        • 1. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
          bg99UW

          I was running into this same error today and lucked across the following post

          http://forums.adobe.com/message/3467967#3467967

           

          I did a nos extract of the 9.4 executable, then did a msiexec /a of the Acroread.msi it generated, saved that MSI in a secondary directory, and was able to apply the 9.4.2 - 9.4.4 patches to it. Hope that link helps.

          1 person found this helpful
          • 2. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
            RShaffer21 Level 1

            The problem is that I'm already doing what you suggested... The only difference is that I'm not extracting the EXE, but instead I directly downloaded the MSI version of the 9.4.0 so that I wouldn't have to extract it.

             

            I then copy the MSI file into a directory and run the msiexec commands on all of the patches 9.4.2 > 9.4.3 > 9.4.4 and I still get that error when 9.4.4 tries to update the MSI.  No idea why... I don't see a reason why extracting the MSI from the EXE would make a difference.

            • 3. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
              deepak_sisodia Level 2

              You are not following the correct process to create an AIP for Reader.

               

              You are trying to apply 9.4.4 patch on 9.4.3 msi,  which is not the correct way.

              You have to apply the patches on the msi which is there in the AIP-distribution-folder (not the product msi) .

               

              1. First create an AIP from 9.4.0 msi. (let's say the AIP created is in Folder X. Folder X is AIP-distribution-folder )

              2. Now patch the msi present in the folder X with 9.4.2.

              3. Again patch the msi present in the folder X with 9.4.3.

              4. Again patch the msi present in the folder X with 9.4.4.

               

              For detailed steps(with Snapshots) you may refer http://forums.adobe.com/message/3467967#3467967

              1 person found this helpful
              • 4. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                RShaffer21 Level 1

                I am trying to patch the MSI within the AIP.... I have done this 3 different ways now and still get this error.

                 

                Here are the 4 things I've tried...

                 

                1. I copied the entire AIP folder from version 9.4.3 which is fully functional (we've been using this for months) and tried to patch the 9.4.3 MSI file in this AIP to 9.4.4 and I get the error listed in the original post.

                 

                2. I followed the link provided in your last post and when I tried to run the command in step #3

                 

                msiexec /a "C:\AIP_Enterprise_Installation_Version_9_4_4\AdbeRdr940_en_US.msi"  I get the following error

                 

                Adobe msiexec Error.jpg

                 

                3.  I re-downloaded all MSP patch files (9.4.2, 9.4.3, and 9.4.4) and I also re-downloaded MSI file 9.4.0.  I placed the newly downloaded files into a folder with the AIP files (abcpy.ini, Data1.cab, Setup.exe, and Setup.ini) from the previous working package and I then tried to apply each MSP patch onto the 9.4.0 MSI file sequentially and I was able to update all the way to 9.4.3, but then got the error when trying to patch to 9.4.4

                 

                4. I created a new AIP package using the newly downloaded MSI 9.4.0.  In this new folder I copied the MSI and all MSP's as well as the previous setup.ini file (because Adobe Customization Wizard doesn't create it for you). I modified my settings in the Customization wizard and saved them, which created the AdbeRdr940_en_US.mst file.  I then ran the command to patch the AIP of 9.4.0 to 9.4.2 (since 9.4.1 doesn't step to 9.4.2).

                 

                msiexec /a "C:\Documents and Settings\ShafferR\Desktop\AIP of Enterprise_Installation_Version_9.4.4\AdbeRdr940_en_US.msi" /p "C:\Documents and Settings\ShafferR\Desktop\AIP of Enterprise_Installation_Version_9.4.4\AdbeRdrUpd942_all_incr.msp"

                 

                This worked to patch the 9.4.0 MSI to 9.4.2... (even though the name remains the same, so it looks as if its 9.4.0 still)

                 

                Then I ran the command again with MSP 9.4.3

                 

                msiexec /a "C:\Documents and Settings\ShafferR\Desktop\AIP of Enterprise_Installation_Version_9.4.4\AdbeRdr940_en_US.msi" /p "C:\Documents and Settings\ShafferR\Desktop\AIP of Enterprise_Installation_Version_9.4.4\AdbeRdrUpd943_all_incr.msp"

                 

                This also worked to patch the 9.4.2 MSI to 9.4.3

                 

                Then I ran the command one more time to patch the 9.4.3 MSI to 9.4.4

                 

                msiexec /a "C:\Documents and Settings\ShafferR\Desktop\AIP of Enterprise_Installation_Version_9.4.4\AdbeRdr940_en_US.msi" /p "C:\Documents and Settings\ShafferR\Desktop\AIP of Enterprise_Installation_Version_9.4.4\AdbeRdrUpd944_all_incr.msp"

                 

                This time I got the error just as before and the install rolled back and wouldn't finish.  Am I missing something?  I have tried every possible way that i can think of... I notice that the error states that it's looking in the Data1.cab file, and I didn't copy it over from the last AIP for the third attempt in hopes that it may create one or something, but it doesn't.  However, this doesn't matter because on my first attempt, I copied the Data1.cab from the previous AIP and it still failed... So frustrating... The only thing that I can think of is that what you refer to as AIP is different from what I am referring to... We've been using Adobe Customization Wizard 9 to automate the install of Adobe reader packages and updates... Is there another way to make an AIP?

                • 5. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                  bg99UW Level 1

                  Ok step by step, here's what worked

                   

                  1) extracted the Acrobat Reader9.4.0 msi from a newly downloaded 9.4.0 installer, did this because patching on top of any modified MSI failed at some point. Customizing the msi in Adobe Customization Wizard can wait till after the patches are all rolled up.

                   

                  2) created a new directory where the installer would be pointed and put newly uncompressed program files

                   

                  3) ran "msiexec /a <Reader9.4.0.msi>" and when prompted for where to install the files, directed it to the directory created in step 2

                   

                  4) finished the installer, seeing a new acroread.msi and 4 folders in the new directory created in step 2 This is the MSI we will apply patches to.

                   

                  5) copied the 9.4.2, 9.4.3 and 9.4.4 MSP files in with the *new* msi we created in step 4.

                   

                  6) applied patch to the new msi created in 4, using the "msiexec /a <path of MSI created in 4> /p <path to reader patch 9.4.2>

                   

                  7) repeat for 9.4.3 and 9.4.4 patches

                   

                  at this point I tested if the newly created and patched MSI would install 9.4.4 and I discovered that it wanted the CAB and setup files that were originally uncompressed out of the EXE with it. I put all the original material (minus the old un-patched acroread MSI) into a directory on the network and tested the install, it worked.

                   

                  8) at this point I used Adobe Customization Wizard 9 on the fully patched MSI I had put on the network. I created a transform package for it, saved it all, and was able to create a software distribution package based on the MSI we created and patched, using the MST just newly created.

                  • 6. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                    RShaffer21 Level 1

                    How did you extract the MSI?

                     

                    I've been downloading the 9.4.0 MSI directly so that I shouldn't have to do that.  Did you download the EXE version and extract the MSI?

                     

                    If so, what did you use to do this?

                    • 7. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                      bg99UW Level 1

                      Cut/pasted from some other post:

                       

                      Extracting Files From the EXE
                      The example shown here uses Adobe Reader X version 10.01, english (AdbeRdr1001_en_US.exe). 

                       

                      Using the following command will extract the files inside the Adobe Reader installer to a folder called AdobeReaderFiles in the root of your C drive:
                      AdbeRdr1001_en_US.exe -nos_oc:\AdobeReaderFiles -nos_ne

                       

                      Notes About Extracting Files From the EXE
                      There is no space between the -nos_o switch and the path “c:\AdobeReaderFiles”

                      • 9. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                        RShaffer21 Level 1

                        I was able to extract the AdbeRdr940_en_US.exe file using the command you listed.

                         

                        This extracted the following files:

                         

                        abcpy.ini

                        AcroRead.msi

                        Data1.cab

                        Setup.exe

                        setup.ini

                         

                        I then attempted to run the msiexec /a "C:\AIP_Enterprise_Installation_Version_9_4_4\AcroRead.msi" command on the newly extracted MSI file as directed in your instructions and I get the same error once again when I point the install to the folder.

                         

                        Adobe_msiexec_Error2.jpg

                        I cannot continue if this doesn't work...

                        • 10. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                          RShaffer21 Level 1

                          I Found out that I don't get the database error if I select a different folder to install the files to when I run the msiexec /a "C:\AIP_Enterprise_Installation_Version_9_4_4\AcroRead.msi" command.

                           

                          I was initially attempting to select the same folder that the initial AcroRead.msi was located in as the destination folder, but this caused the Database error.

                           

                          All I did was create another folder on my C: drive and named it Adobe_AIP.  When I ran the msiexec /a "C:\AIP_Enterprise_Installation_Version_9_4_4\AcroRead.msi" command and it prompted for the destination folder, I selected the new C:\Adobe_AIP folder and it ran fine without error.

                           

                          I then copied all of the initial extract files and MSP patches into the C:\Adobe_AIP folder so it now contained the following:

                           

                          Adobe_AIP_Final_Folder.jpg

                          Now I was able to run all MSP patch updates (via my BAT file which I created, so that I wouldn't have to re-type the commands in the command prompt).

                           

                          All patches applied successfully.

                           

                          I will now run the Adobe Customization Wizard on the MSI file to setup the installation settings.

                           

                          Thanks for the help everyone!

                          • 11. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                            The MtnLion

                            When I saw that this was answered, I dug out my old patch kit and went to work (reader X is not ready for me).  Funny thing is I get to installing 9.4.4 and I get:

                            Adobe Reader 9.4.4 travails.PNG

                            So, I went back through all of the historical Data1.cab files (9.4.0, 9.4.1 (not used to get to 9.4.4), 9.4.2, and 9.4.3) and looked for Adobe.Reader.Dependencies.Manifest and it is not in any of them.  I did find the file, and it is located in [Install Folder 9.4.(1,2,3)]\program files\Adobe\Reader 9.0\Reader\ so the patch file is never going to find it in Data1.cab unless one were to modify Data1.cab to copy it in.  Is that what has been done?

                            • 12. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                              RShaffer21 Level 1

                              No, I didn't add the manifest to the Data1.cab file... It simply works if the steps are done properly...

                               

                              Here... Now that I've figured it out, I made my own Procedure list for it expalaining exactly what I had to do.

                               

                              1. Create a folder to hold the Adobe download (i.e. for example and use below  C:\AdobeFiles)

                               

                              2. Download the base/root EXE of the current version of Adobe  Reader from the Adobe Website. (i.e. if the latest version is 9.4.4,  then download the 9.4.0 EXE file)

                              Download EXE of Any Version of Adobe Reader

                               

                              3. Extract the MSI file and other required files from the EXE  (should give you files such as AcroRead.msi, abcpy.ini, Setup.ini,  Setup.exe, and Data1.cab)

                               

                              To extract the files navigate to the Command Prompt and enter the following command:

                                C:\AdobeFiles\AdbeRdr940_en_US.exe -nos_oC:\AdobeFiles -nos_ne 
                               
                              * Notice there is NO SPACE between the “-nos_o” and the destination folder

                              4. Create a distribution point (a folder where the installer can  install the uncompressed program files).  The folder must be separate from the folder (C:\AdobeFiles) where the  current MSI (step 3) resides – We will use C:\Adobe_AIP as the  distribution point

                               

                              5. Click Start, click Run, and then enter the following command:

                                msiexec /a "C:\AdobeFiles\AcroRead.msi"

                              6. When you receive a prompt asking where to install the files,  browse to the distribution point (C:\Adobe_AIP) you created in step 4.

                               

                              7. Click OK. When the installer finishes, the files will be at  the distribution point. AcroRead.msi is also present at the distribution  point. (This MSI is used in step 10 below)

                               

                              8. Copy the other files extracted from the original EXE  (C:\AdobeFiles) into the distribution folder (C:\Adobe_AIP) - (i.e.  abcpy.ini, Setup.exe, Setup.ini, and Data1.cab)

                               

                              9. Download the Reader 9.4.2, 9.4.3, and 9.4.4 MSP patches on  your machine (into the distribution folder C:\Adobe_AIP) in order to use  them to run the incremental updates.  (patch 9.4.1 isn’t necessary, it goes straight to 9.4.2 from 9.4.0)

                              Download Incremental Adobe Reader MSP Patches

                               

                              10. Open the Command Prompt (click Start -> Run -> type “CMD”, then hit enter).

                               

                              At the command prompt, type the following:

                                msiexec /a “<path of MSI at distribution point>” /p “<path of 9.4.2 MSP at distribution point>”

                              Translates to (in our example):

                                msiexec /a “C:\Adobe_AIP\AcroRead.msi” /p “C:\Adobe_AIP\AdbeRdrUpd942_all_incr.msp”

                              Accept default install settings until finished

                               

                              Run this command as many times as you need to (modifying the name  of the MSP file each time) in order to update every sequential patch  until your AcroRead.msi installs the latest version of the Reader.

                               

                              Another option to patch the MSI file is to create and run a BAT  file which contains the command to apply the patches to the MSI.  Then  you don’t have to type it out in the command prompt multiple times.

                               

                              11. Now that the AcroRead.msi file is fully updated to the latest  version via patching, we can use Adobe Customization Wizard 9 to dictate  how we want the program to be installed when we push it out using Group  Policy.

                               

                              Here’s where you can download the Customization Wizard if you don’t have it:

                              Adobe Customization Wizard 9

                              • 13. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                                The MtnLion Level 1

                                That is a very good description of my procedure.  However, I still encounter the error when applying 9.4.4 patch.

                                 

                                I did find one small difference.  It appears that unlike previous patches, the 9.4.4 patch requires that the target installation file reside in the Install Point shared folder with full control permissions and that the target msi be accessed via the share.  I was successful when using a shared folder as target:

                                msiexec -a "\\server\temp\acroread.msi" -p "c:\AdbeRdrUpd944_all_incr.msp"

                                 

                                versus (did not work):

                                msiexec -a "c:\temp\acroread.msi" -p "c:\AdbeRdrUpd944_all_incr.msp"

                                 

                                (The c:\temp folder is the shared folder with full control, substituting for the actual installation point.)

                                • 14. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                                  RShaffer21 Level 1

                                  That's odd.... I didn't find that to be the case when I finally figured it out... I simply had two seperate folders on my C: local drive and it worked... I'm glad it worked for you in the end though. 

                                  • 15. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                                    The MtnLion Level 1

                                    Adobe Travils with 944.PNG

                                    Well, it has not worked for me.  Now I get the error during an install, meaning when policies are being enforced the machine hangs and no one is able to log onto the machines.  Nice DoS, whoever got this thing screwed up! 

                                    • 16. Re: Reader 9.4.4 msp patching error 1334 (Adobe.Reader.Dependencies.manifest)
                                      The MtnLion Level 1

                                      Okay, I seem to have broken out of the loop.  What extraordinary measures:

                                       

                                      1.     Using the NOS package obtain the MSI file:

                                      "D:\Original Software - Master Copy\Adobe Reader 9.4\AdbeRdr940_en_US.exe" -nos_o"D:\Original Software - Master Copy\Adobe Reader 9.4\9.4.0 Install" -nos_ne

                                       

                                      2.     Using the MSI create an Admin install point to a shared installation point (I use something like D:\shares\adobe shared as "Adobe Reader 9.4"):

                                      msiexec.exe /a "D:\Original Software - Master Copy\Adobe Reader 9.4\9.4.0 Install\acroread.msi" 

                                      Installed to:  \\ilsadc\Adobe Reader 9.4 share which is unrelated to this directory.

                                       

                                      3.     Apply the patches (9.4.2, 9.4.3, and 9.4.4):

                                      msiexec.exe /a "\\ilsadc\Adobe Reader 9.4\Acroread.msi" PATCH="D:\Original Software - Master Copy\Adobe Reader 9.4\AdbeRdrUpd942_all_incr.msp"
                                      msiexec.exe /a "
                                      \\ilsadc\Adobe Reader 9.4\Acroread.msi" PATCH="D:\Original Software - Master Copy\Adobe Reader 9.4\AdbeRdrUpd943_all_incr.msp"
                                      msiexec.exe /a "
                                      \\ilsadc\Adobe Reader 9.4\Acroread.msi" PATCH="D:\Original Software - Master Copy\Adobe Reader 9.4\AdbeRdrUpd944_all_incr.msp"

                                       

                                      3.     To apply customizations via the customization wizard, copy setup.ini into the distribution point.  Of course I know that the EULA still displays when it is supposed to be disabled.  None of the help, update, or Adobe links are removed from the help menu.  Who knows maybe other parts of the customizations that I apply are broken as well.  (Overall, I have become very frustrated when dealing with Adobe products, especially when the procedure here seems to be a mystical incantation that was discovered totally by trial and error.  It should not take 24+ hours to patch a product for a GPO install.  If it does, then why isn't a pre-patched product available for download?)