3 Replies Latest reply on May 16, 2011 7:48 AM by nmlibrarian

    Ordinal 19 in MAPI32.dll

    Utahgenealogist

      I have tried reinstalling and also repairing the Reader X on my sister's machine running Windows XP Home SP3.  When trying to open any PDF file, we get an error message, "The ordinal 19 could not be located in the dynamik link library MAPI32.dll."  How can this be taken care of?  The machine is a Compaq Presario SR1517CL.

        • 1. Re: Ordinal 19 in MAPI32.dll
          nmlibrarian

          I've just encountered this same problem after updating to ReaderX.  I updated

          everything possible on Microsoft without luck.  What worked -- I had saved my document just to the desktop. I right-clicked on my document's file icon and selected "open with" "Adobe Reader." It popped open a license agreement for using ReaderX, which I "accepted" and then my document opened up.  Miraculous!  Now my PDF files seem to working just fine again. An odd little quirk.  I hope this works for you too.

          • 2. Re: Ordinal 19 in MAPI32.dll
            Utahgenealogist Level 1

            After my post I found some other references to the MAPI32.dll being changed and I found that the MAPI32.dll being ussed was only 7KB in size.  I searched the machine for other files the same name; changed the name on the one that was there and copied one of the larger MAPI32.dll files to the /system32 folder.  That larger file cured the problem.

            • 3. Re: Ordinal 19 in MAPI32.dll
              nmlibrarian Level 1

              Thanks for letting me know about your fix.  I had seen a comment on another forum about double-clicking the MAPI32.exe file, but a search of my computer didn't turn that one up, at least not the .exe file, so I couldn't fix it that way.  But I'll take another look and see if I find anything like your situation.  I've encountered odd errors with Adobe before and had no luck in getting a response from Adobe, so I'm glad to find this forum.