1 Reply Latest reply on May 1, 2011 5:59 AM by Ken Binney

    Coding error

    frank2022 Level 1

      I am building my first website in Dw CS3 on Windows XP pro with IE as the primary browser. I have built a template from a page and used that template to create other pages. I have a vertical left menu and a matching horizontal menu at the bottom of each page (in the template footer). The only editable region is for content in the centre column. I ran into a problem trying to place a page title on each page and found a solution of placing the following code on the template page:

       

      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns="http://www.w3.org/1999/xhtml">
      <head>
      <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
      <!-- TemplateBeginEditable name="doctitle" -->
      <title>Your Page Title Goes Here</title>
      <!-- TemplateEndEditable -->
      <style type="text/css">
      <!--

       

      Other code which might be relevant is at the bottom of the .dwt page:

       

         <!-- TemplateBeginEditable name="content" -->
          <div id="content">Enter text here</div>
          <!-- TemplateEndEditable --></div>
        <div id="right"></div>
      </div>
      </body>
      </html>

       

      I'm not sure I placed the code correctly but it works as I now have page titles which show up correctly in the browser.

       

      Suddenly, I started getting problems when I tried to save a change to the template:

      "There is an error at line 6, column 47 (absolute position 436) of F:\ ... <filename>.html: instanceBegin Editable tag inside editable region"

       

      Line 6 is:

      <title>Your Page Title Goes Here</title>

       

      I have no idea what column 47 is ...

       

      When I view in IE I can tab through the left menu to the pages but when I try to go back to the bottom two items (Resources & Contact us), I get the following error messages:

       

      dw_resources.JPG

      dw_contact.JPG

       

      I can see immediately that there is a problem with the path in the bottom one but I have removed the link and re-established it and it seems fine ... but it clearly isn't.

       

      Interestingly, I have the same menu items in a footer at the bottom of the page with the same links. They all work fine there. I can browse through them in either direction over and over without a problem. They are linked to the same html files as the left vertical navigation bar.

       

      So, I'm still trying to problem-solve but not making much progress, just getting more frustrated. I know there is an answer and I need to find it. I feel like deleting the template and starting again, but that is not the answer. I need to solve the problem so I can learn.

       

      Can any gurus help ... suggest what I should look for ... is the problem with the editable region or what??? The order of my code - not that you can see much...? I suspect if I can find out what is wrong in the above image which shows not the file but "class=" I might be on the right track. It should read not 'class=' but 'contact_us' which is the name of the html file. I have looked in the property inspector and I can't see a class style but I suspect it has developed through my playing about solving other problems and experimenting.  But interestingly, when I view the index.html page in IE and click on Resources and Contact us, I am taken to the correct page. It is only in returning to Resources I have the problem (or returning to Contact us). I can return to the other menu items with no problem.

       

      Look forward to hearing any suggestions. I hope I have made enough sense. Bear in mind this is my first website but it won't be my last (I hope lol).

       

      Thanks.